Mouse & Keyboard Lag

Hi,

I am having a very annoying problem in Windows 7 Ultimate x64 Final. Almost every time my PC boots up, it takes the mouse and keyboard about 10 seconds to start working on the Windows login screen. Does anyone know what causes this? I never had this problem on XP.

My computer is high end, so resource hogging at start-up isn't an explanation (I am running on 12GB RAM and Core i7 940) via RAID 5 Adaptec 5805 Controller. I also have a brand new Windows 7 install with literally no other software installed. My mouse and keyboard are NOT wireless, they are USB and no other 3rd party devices are connected to the system.

I understand it is not a big deal and I can wait until they start working but I would really like to know what is causing this, because I am suspecting some faulty hardware in my system.
17 answers Last reply
More about mouse keyboard
  1. I'm having the same proble,

    It's annoying to have invested in an expensive ssd for a fast boot only to have to wait for mouse and keyboard to become active on login screen. Both the mouse and keyboard are active before the login screen.

    Any help would be greatly appreciated
  2. Look in device manage, Mouse, How many entries. if more than one make it one.
  3. Doesn't seem to work, I have disabled the second mouse entry in Device manager which has not solved the problem... Strangely once in a while the mouse and keyboard do not have any delay before being active on the login screen, but this was also so before I disabled the second mouse entry in the device manager.

    Could this possibly be related to the fact that I havn't installed the driver for the fingerprint reader? it is disabled in the device manager though. I dont want to install a 102MB driver bundle for something I don't use...
  4. we need your BSOD massage may be ican help. u !
    go bios safe default (Press F9) save & reboot again
  5. BSOD? as in Blue Screen OF Doodoo? Havn't seen one of those in years.
    Anyway Bios is set to default but no difference, the mystery remains...
  6. do update frimwire ? Adaptec RAID 5805 Firmware/BIOS Update b17911. ?
    Clear CMOS ?
  7. I am also experiencing this problem, and can't find anyone else with a similar case.

    I'm on a desktop with an M4 crucial boot drive, and I've got about a 10 second delay before I can type or move the mouse.

    I recently reinstalled windows and all my programs this week, and haven't experienced this problem until just today.

    edit: I just checked device manager. I have my keyboard listed 3 times as HID Keyboard Device, and my mouse listed twice as HID-compliant mouse. I tried removing them and then checking hardware changes to re-add it, but it always re-adds the same number of entries as what I started with...?
  8. Some additional info: I have a Logitech G110 keyboard and A razer deathadder. Both have lights, and I've noticed that they are fully lit within a few seconds of turning on the computer, but once I hit the windows loading screen they turn off, and then on again.

    edit: the mouse is immediately responsive and although the cursor is flashing in the password box, my keyboard does not work.
  9. Oddly enough this answer seemed to work:

    http://answers.yahoo.com/question/index?qid=20091029080104AAT812e

    can anyone explain why?

    edit: nevermind it's back to being about 5-7 seconds long delay...
  10. I had the same problem. I removed my "Netgear WPN111" wireless adapter and the problem went away. It was giving me other problems anyway. I would suggest removing other USB devices to see if one of them is the culprit.
  11. Corrected by removing Intel 7 Series/C216 Chipset Family USB Host Controller (both entries) from the device manager and then restarting with the reset button on the computer.
  12. andreb2019 said:
    Corrected by removing Intel 7 Series/C216 Chipset Family USB Host Controller (both entries) from the device manager and then restarting with the reset button on the computer.


    That's right! I had remove this driver. so the system reinstalled the driver from internet after reboot, now, my system worked as good as win xp.
  13. logika said:
    Hi,

    I am having a very annoying problem in Windows 7 Ultimate x64 Final. Almost every time my PC boots up, it takes the mouse and keyboard about 10 seconds to start working on the Windows login screen. Does anyone know what causes this? I never had this problem on XP.

    My computer is high end, so resource hogging at start-up isn't an explanation (I am running on 12GB RAM and Core i7 940) via RAID 5 Adaptec 5805 Controller. I also have a brand new Windows 7 install with literally no other software installed. My mouse and keyboard are NOT wireless, they are USB and no other 3rd party devices are connected to the system.

    I understand it is not a big deal and I can wait until they start working but I would really like to know what is causing this, because I am suspecting some faulty hardware in my system.


    I had the same problem with a Logitech Wireless keyboard and mouse using a unified usb receiver. It also occurred with a wired USB keyboard andwired usb mouse.
    The solution was to use a different USB port! . I moved it from a top of desktop case port to one on the bottom.
  14. I had this and corrected it finally. I had given up on this issue and was trying to get a Solidworks installation to work properly. I uninstalled service pack 1 and used my Windows 7 Ultimate disc to do a repair install of the OS. This kept all my files and settings, I just had to redownload and install the updates over the next several days. While this did not fix my SW problem, it did fix the long delay at the password screen where I had no mouse or keyboard input and I've had zero computer lock-ups, freezes, or other hiccups since. My computer literally boots up in less than 30 seconds now . This is the repair instructional vid I used, there are others. Good luck.

    https://www.youtube.com/watch?v=RC_5eb9wTfk
  15. I had this very same problem, for months. It was maddening. I tried all the standard solutions in Power Options, Device Manager, BIOS, etc.

    I finally fixed it by disabling the Workstation service (one of the many hidden programs that automatically run when you start Windows). The Workstation service is necessary only if your PC is connected to a private network (not the Internet) so you can share files, printers, and other devices with other computers. (You can read more about it here: www.theeldergeek.com/workstation.htm)

    When you resume from Sleep mode, the Workstation service searches for other computers on your network. Even if they don't exist, in some cases it can still take a while to realize that and release your system back to you. If your PC is NOT on such a network, you can safely turn it off and avoid this delay.

    1. At the Start menu, type cmd and look for "cmd.exe" in the list above.

    2. Right-click "cmd.exe", then click Run as Administrator. A command-line window appears.

    3. In the window, type services.msc and press Enter. The Services window appears.

    4. Find "Workstation" in the list of services. Right-click it, then click Stop. After the service stops, right-click "Workstation" again, then click Properties. The Workstation Properties window appears.

    5. In the "Startup type" list, select "Disabled", then click OK.

    6. Close all open windows, then log off and back on again for the change to take effect.
  16. ander said:
    I had this very same problem, for months. It was maddening. I tried all the standard solutions in Power Options, Device Manager, BIOS, etc.

    I finally fixed it by disabling the Workstation service (one of the many hidden programs that automatically run when you start Windows). The Workstation service is necessary only if your PC is connected to a private network (not the Internet) so you can share files, printers, and other devices with other computers. (You can read more about it here: www.theeldergeek.com/workstation.htm)

    When you resume from Sleep mode, the Workstation service searches for other computers on your network. Even if they don't exist, in some cases it can still take a while to realize that and release your system back to you. If your PC is NOT on such a network, you can safely turn it off and avoid this delay.

    1. At the Start menu, type cmd and look for "cmd.exe" in the list above.

    2. Right-click "cmd.exe", then click Run as Administrator. A command-line window appears.

    3. In the window, type services.msc and press Enter. The Services window appears.

    4. Find "Workstation" in the list of services. Right-click it, then click Stop. After the service stops, right-click "Workstation" again, then click Properties. The Workstation Properties window appears.

    5. In the "Startup type" list, select "Disabled", then click OK.

    6. Close all open windows, then log off and back on again for the change to take effect.



    ^^^^^^^ THIS WORKED ^^^^^^

    Thank you sir.
  17. ander said:
    I had this very same problem, for months. It was maddening. I tried all the standard solutions in Power Options, Device Manager, BIOS, etc.

    I finally fixed it by disabling the Workstation service (one of the many hidden programs that automatically run when you start Windows). The Workstation service is necessary only if your PC is connected to a private network (not the Internet) so you can share files, printers, and other devices with other computers. (You can read more about it here: www.theeldergeek.com/workstation.htm)

    When you resume from Sleep mode, the Workstation service searches for other computers on your network. Even if they don't exist, in some cases it can still take a while to realize that and release your system back to you. If your PC is NOT on such a network, you can safely turn it off and avoid this delay.

    1. At the Start menu, type cmd and look for "cmd.exe" in the list above.

    2. Right-click "cmd.exe", then click Run as Administrator. A command-line window appears.

    3. In the window, type services.msc and press Enter. The Services window appears.

    4. Find "Workstation" in the list of services. Right-click it, then click Stop. After the service stops, right-click "Workstation" again, then click Properties. The Workstation Properties window appears.

    5. In the "Startup type" list, select "Disabled", then click OK.

    6. Close all open windows, then log off and back on again for the change to take effect.


    THIS WORKED FOR ME! THANK YOU! :)
Ask a new question

Read More

Configuration Mice Keyboards Windows 7