Sign in with
Sign up | Sign in
Your question

Changing Hard Drive Letter

Last response: in Storage
Share
September 21, 2004 4:40:01 PM

I have 2 hdd's on my pc. My master is listed as letter F and my slave is listed as letter C. I wanna change my master to C and my slave to D. How can I do this?
September 21, 2004 11:20:17 PM

start - Control Panel - Admin Tools - Computer Management - Disk Management - Work it out from there! Its simple.

_______________________
"In the US and A there are many jobs. For Men: Accountant, Life Guard, and Sportsman. For Women...Prostitute"
September 22, 2004 12:14:49 AM

Hehe, until he reboots

<font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
<font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
Related resources
September 22, 2004 1:30:53 AM

I wouldn't do that. It could render your system unbootable. You can change drive letter for non-system drive, but not the one contains OS.

:smile: Good or Bad have no meaning at all, depends on what your point of view is.
September 22, 2004 12:28:31 PM

correct, windows XP will not allow the user to change the boot partition's drive letter

Trust me I know what I'm doing... ooops, grab the cat...
September 22, 2004 2:40:08 PM

I have the same issue on my machine. The primary drive was immediately detected as drive E when I was partitioning it during a reinstall -- even though I have it configured as master. This has caused only minor headaches so far but I would like to fix it when I reinstall again about three months from now. Any ideas on how to prevent this? My bios correctly recognizes the drive as master. Any tips for how to handle this in fdisk?
September 22, 2004 3:18:24 PM

After you reinstall windows to your harddrive, assuming it is not a SATA, and assuming you are formatting them, it should automatically be the new C: drive. I would make sure the partion you are using is the first partition on the drive.

On my SATA drive, I have to unplug all the other drives before I install Windows, otherwise my computer sets my SATA to D:. After Windows is installed I replug in the drives so Windows can detect them.

My Desktop: <A HREF="http://Mr5oh.tripod.com/pc.html" target="_new">http://Mr5oh.tripod.com/pc.html&lt;/A>
September 23, 2004 4:03:05 PM

I'm not using SATA, but I do have two drives that I fdisked at once, maybe that did cause the problem somehow. I'll try your method when I do the reinstall. Thanks!
September 23, 2004 7:45:18 PM

achieving information in brain for further you at later date.

Thanks

_______________________
"In the US and A there are many jobs. For Men: Accountant, Life Guard, and Sportsman. For Women...Prostitute"
September 24, 2004 12:23:16 AM

Of course Primary Master is normally designated as C: unless another drive was previously designated as C: The best way to fix it next time you do a fresh install is to disconnect the other drives, in which case Windows should assign C: to the only remaining hard drive and force the others to take new letters.

<font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
<font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
September 24, 2004 5:21:30 AM

In your BIOS make sure you have the boot order set to HDD0 and disable boot from other device. Disable the slave drive if necessary.

When you reboot, you should see NTLDR missing or no boot device. Get your windows XP cd, shove it in the CD tray and boot to recovery console. Your master drive should now be assigned as drive c: Run FIXBOOT c:. Reboot and windows should start normally.

<A HREF="http://www.anandtech.com/myanandtech.html?member=114979" target="_new">My PCs</A> :cool:
October 15, 2004 3:07:43 PM

We had a similar problem at work, where we installed a slave drive into a machine and it forced the master's drive letter to e:. Some software on the machine was installed and configured by overseas consultants, so formatting was not an option.

In a nutshell, fixing the problem required a registry change outlined here: http://support.microsoft.com/kb/q223188/

In the event that you can't log into the user account, follow this guide: http://support.microsoft.com/kb/249321

Also make sure the page file is being written to the right drive from in the registry.
October 16, 2004 11:37:16 PM

what the hell?! was I drunk in my last post, it makes NO sence! :lol: 

_______________________
Whos round is it? Down that beer quick, smash my glass down, fall over the table - all rowdy and pissed
!