Sign in with
Sign up | Sign in
Your question

Unwanted multiple boot screen

Last response: in Windows XP
Share
Anonymous
July 7, 2005 4:32:19 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

After 4 years of usage adding/removing programs, my Win XP had slowed down to
a crawl on startup, so I bit the bullet and did a fresh Win XP installation
from my original system disks, and performed all updates including sp-2. The
system works fine, but on boot-up, it takes me to a selection page to choose
the installation of "Windows XP Home edition" I want to start with. Now, I
only have one operating system installed on my C drive (not partitioned), and
D drive is all data storage. If I don't make a choice, it counts down for 30
seconds and then chooses the first choice, and I boot into Windows. If I
click the second choice, which also says "windows xp home edition", I get an
error message saying problem finding the operating system on the hard drive.
I tried deleting the second example of "windows" from the boot.ini file. That
stopped the multiple boot screen from appearing, but it takes a long time for
windows to then startup. Is it waiting 30 seconds behind the scene? Here is
my original boot.ini file that I had with the problem (before I edited it)
Thanks for any help:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home
Edition" /fastdetect /noexecute=optin
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home
Edition" /fastdetect
Anonymous
July 7, 2005 7:47:28 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Set the timeout to 0 and/or remove

multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home
Edition" /fastdetect

Why are you using the switch /noexecute=optin?

This probably won't help your boot time. For that is it holding up at
Preparing Network Connections?

--
George Hester
_______________________________
"wedodesign" <wedodesign@discussions.microsoft.com> wrote in message
news:D F70C76E-9091-4A49-9080-0A0CA820C1D1@microsoft.com...
> After 4 years of usage adding/removing programs, my Win XP had slowed down
to
> a crawl on startup, so I bit the bullet and did a fresh Win XP
installation
> from my original system disks, and performed all updates including sp-2.
The
> system works fine, but on boot-up, it takes me to a selection page to
choose
> the installation of "Windows XP Home edition" I want to start with. Now, I
> only have one operating system installed on my C drive (not partitioned),
and
> D drive is all data storage. If I don't make a choice, it counts down for
30
> seconds and then chooses the first choice, and I boot into Windows. If I
> click the second choice, which also says "windows xp home edition", I get
an
> error message saying problem finding the operating system on the hard
drive.
> I tried deleting the second example of "windows" from the boot.ini file.
That
> stopped the multiple boot screen from appearing, but it takes a long time
for
> windows to then startup. Is it waiting 30 seconds behind the scene? Here
is
> my original boot.ini file that I had with the problem (before I edited
it)
> Thanks for any help:
>
> [boot loader]
> timeout=30
> default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
> [operating systems]
> multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home
> Edition" /fastdetect /noexecute=optin
> multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home
> Edition" /fastdetect
>
>
>
Anonymous
July 7, 2005 7:53:24 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Hi,

Change timeout=30 to timeout=0

Timeout= seconds
Specifies the number of seconds that the startup menu is displayed
before the operating system specified in the default= line is loaded.

* If you set this value to 0, Ntldr immediately starts the default
operating system without displaying the bootstrap loader screen.
* If you set this value to -1, Ntldr displays the menu
indefinitely unless you make a choice.

Microsoft Windows XP - Reviewing and Correcting Boot.ini Settings on
x86-based Systems
http://www.microsoft.com/resources/documentation/Window...

--
Regards,
Bert Kinney MS-MVP Shell/User
http://dts-l.org/

wedodesign wrote:
> After 4 years of usage adding/removing programs, my Win
> XP had slowed down to a crawl on startup, so I bit the
> bullet and did a fresh Win XP installation from my
> original system disks, and performed all updates
> including sp-2. The system works fine, but on boot-up, it
> takes me to a selection page to choose the installation
> of "Windows XP Home edition" I want to start with. Now, I
> only have one operating system installed on my C drive
> (not partitioned), and D drive is all data storage. If I
> don't make a choice, it counts down for 30 seconds and
> then chooses the first choice, and I boot into Windows.
> If I click the second choice, which also says "windows xp
> home edition", I get an error message saying problem
> finding the operating system on the hard drive. I tried
> deleting the second example of "windows" from the
> boot.ini file. That stopped the multiple boot screen from
> appearing, but it takes a long time for windows to then
> startup. Is it waiting 30 seconds behind the scene? Here
> is my original boot.ini file that I had with the problem
> (before I edited it) Thanks for any help:
>
> [boot loader]
> timeout=30
> default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
> [operating systems]
> multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft
> Windows XP Home Edition" /fastdetect /noexecute=optin
> multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft
> Windows XP Home Edition" /fastdetect
Related resources
Anonymous
July 7, 2005 8:05:26 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

XP SP2 adds it.

/noexecute=OptIn

OptIn
This setting is the default configuration. On systems with processors that
can implement hardware-enforced DEP, DEP is enabled by default for limited
system binaries and programs that "opt-in." With this option, only Windows
system binaries are covered by DEP by default.
http://support.microsoft.com/kb/875352

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:eE2sgyygFHA.3868@TK2MSFTNGP14.phx.gbl,
George Hester <hesterloli@hotmail.com> hunted and pecked:
> Set the timeout to 0 and/or remove
>
> multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home
> Edition" /fastdetect
>
> Why are you using the switch /noexecute=optin?
>
> This probably won't help your boot time. For that is it holding up at
> Preparing Network Connections?
>
> --
> George Hester
> _______________________________
> "wedodesign" <wedodesign@discussions.microsoft.com> wrote in message
> news:D F70C76E-9091-4A49-9080-0A0CA820C1D1@microsoft.com...
>> After 4 years of usage adding/removing programs, my Win XP had slowed
>> down to a crawl on startup, so I bit the bullet and did a fresh Win XP
>> installation from my original system disks, and performed all updates
>> including sp-2. The system works fine, but on boot-up, it takes me to a
>> selection page to choose the installation of "Windows XP Home edition" I
>> want to start with. Now, I only have one operating system installed on
>> my C drive (not partitioned), and D drive is all data storage. If I
>> don't make a choice, it counts down for 30 seconds and then chooses the
>> first choice, and I boot into Windows. If I click the second choice,
>> which also says "windows xp home edition", I get an error message saying
>> problem finding the operating system on the hard drive. I tried deleting
>> the second example of "windows" from the boot.ini file. That stopped the
>> multiple boot screen from appearing, but it takes a long time for
>> windows to then startup. Is it waiting 30 seconds behind the scene? Here
>> is my original boot.ini file that I had with the problem (before I
>> edited it) Thanks for any help:
>>
>> [boot loader]
>> timeout=30
>> default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
>> [operating systems]
>> multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home
>> Edition" /fastdetect /noexecute=optin
>> multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home
>> Edition" /fastdetect
Anonymous
July 8, 2005 1:42:39 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Bert you can set the timout to anything you want if there is no more than
one entry under [operating systems]. It is ignored if that is the case.

--
George Hester
_______________________________
"Bert Kinney" <bert@NSmvps.org> wrote in message
news:u3VlH2ygFHA.3444@TK2MSFTNGP10.phx.gbl...
> Hi,
>
> Change timeout=30 to timeout=0
>
> Timeout= seconds
> Specifies the number of seconds that the startup menu is displayed
> before the operating system specified in the default= line is loaded.
>
> * If you set this value to 0, Ntldr immediately starts the default
> operating system without displaying the bootstrap loader screen.
> * If you set this value to -1, Ntldr displays the menu
> indefinitely unless you make a choice.
>
> Microsoft Windows XP - Reviewing and Correcting Boot.ini Settings on
> x86-based Systems
>
http://www.microsoft.com/resources/documentation/Window...
/prmc_str_masc.asp?frame=true
>
> --
> Regards,
> Bert Kinney MS-MVP Shell/User
> http://dts-l.org/
>
> wedodesign wrote:
> > After 4 years of usage adding/removing programs, my Win
> > XP had slowed down to a crawl on startup, so I bit the
> > bullet and did a fresh Win XP installation from my
> > original system disks, and performed all updates
> > including sp-2. The system works fine, but on boot-up, it
> > takes me to a selection page to choose the installation
> > of "Windows XP Home edition" I want to start with. Now, I
> > only have one operating system installed on my C drive
> > (not partitioned), and D drive is all data storage. If I
> > don't make a choice, it counts down for 30 seconds and
> > then chooses the first choice, and I boot into Windows.
> > If I click the second choice, which also says "windows xp
> > home edition", I get an error message saying problem
> > finding the operating system on the hard drive. I tried
> > deleting the second example of "windows" from the
> > boot.ini file. That stopped the multiple boot screen from
> > appearing, but it takes a long time for windows to then
> > startup. Is it waiting 30 seconds behind the scene? Here
> > is my original boot.ini file that I had with the problem
> > (before I edited it) Thanks for any help:
> >
> > [boot loader]
> > timeout=30
> > default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
> > [operating systems]
> > multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft
> > Windows XP Home Edition" /fastdetect /noexecute=optin
> > multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft
> > Windows XP Home Edition" /fastdetect
>
>
!