Windows Firewall (ICS won't start)

Archived from groups: microsoft.public.windowsxp.general (More info?)

I have XP Home edition on my computer, and my Windows firewall is suddenly
off. I tried turning it back on, but it keeps saying that ICS is not running.
It will then ask me if I want to start the service and if I say yes, it
fails. I tried starting the service manually from within the control panel
(services), but it still will not start. Is reinstalling sp2 the only thing
left to try? Thanks in advance for any help.
14 answers Last reply
More about windows firewall start
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    In news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com,
    LMM912 <LMM912@discussions.microsoft.com> typed:

    > I have XP Home edition on my computer, and my Windows firewall
    > is
    > suddenly off. I tried turning it back on, but it keeps saying
    > that
    > ICS is not running. It will then ask me if I want to start the
    > service and if I say yes, it fails. I tried starting the
    > service
    > manually from within the control panel (services), but it still
    > will
    > not start. Is reinstalling sp2 the only thing left to try?
    > Thanks in
    > advance for any help.


    ICS is the "Internet Connection Sharing" feature, not the
    firewall. It sounds like you're mixing up the two. To turn on the
    firewall, go to Start | Settings | Control Panel | Windows
    Firewall.

    --
    Ken Blake - Microsoft MVP Windows: Shell/User
    Please reply to the newsgroup
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    when I try turning on the firewall as you stated, that's when it tells me
    that it can not turn on the firewall because ICS is not running. Maybe I'll
    have to perform an uninstall of sp2, and then reinstall SP2? I am hoping
    there's a way around that! : )

    "Ken Blake" wrote:

    > In news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com,
    > LMM912 <LMM912@discussions.microsoft.com> typed:
    >
    > > I have XP Home edition on my computer, and my Windows firewall
    > > is
    > > suddenly off. I tried turning it back on, but it keeps saying
    > > that
    > > ICS is not running. It will then ask me if I want to start the
    > > service and if I say yes, it fails. I tried starting the
    > > service
    > > manually from within the control panel (services), but it still
    > > will
    > > not start. Is reinstalling sp2 the only thing left to try?
    > > Thanks in
    > > advance for any help.
    >
    >
    > ICS is the "Internet Connection Sharing" feature, not the
    > firewall. It sounds like you're mixing up the two. To turn on the
    > firewall, go to Start | Settings | Control Panel | Windows
    > Firewall.
    >
    > --
    > Ken Blake - Microsoft MVP Windows: Shell/User
    > Please reply to the newsgroup
    >
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Here's the message I'm getting:
    Firewall/Internet Connection Sharing Service fails to start. Logs event #
    7023 in Event Viewer with the error:
    "An address incompatible with the requested protocol was used".


    "Ken Blake" wrote:

    > In news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com,
    > LMM912 <LMM912@discussions.microsoft.com> typed:
    >
    > > I have XP Home edition on my computer, and my Windows firewall
    > > is
    > > suddenly off. I tried turning it back on, but it keeps saying
    > > that
    > > ICS is not running. It will then ask me if I want to start the
    > > service and if I say yes, it fails. I tried starting the
    > > service
    > > manually from within the control panel (services), but it still
    > > will
    > > not start. Is reinstalling sp2 the only thing left to try?
    > > Thanks in
    > > advance for any help.
    >
    >
    > ICS is the "Internet Connection Sharing" feature, not the
    > firewall. It sounds like you're mixing up the two. To turn on the
    > firewall, go to Start | Settings | Control Panel | Windows
    > Firewall.
    >
    > --
    > Ken Blake - Microsoft MVP Windows: Shell/User
    > Please reply to the newsgroup
    >
    >
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.general (More info?)

    In news:F0ED20A7-76F2-43F9-9F02-AF8C2AEFD155@microsoft.com,
    LMM912 <LMM912@discussions.microsoft.com> typed:

    > when I try turning on the firewall as you stated, that's when
    > it
    > tells me that it can not turn on the firewall because ICS is
    > not
    > running. Maybe I'll have to perform an uninstall of sp2, and
    > then
    > reinstall SP2? I am hoping there's a way around that! : )


    OK, I understand now. Read here:
    http://support.microsoft.com/kb/892350

    --
    Ken Blake - Microsoft MVP Windows: Shell/User
    Please reply to the newsgroup


    > "Ken Blake" wrote:
    >
    >> In news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com,
    >> LMM912 <LMM912@discussions.microsoft.com> typed:
    >>
    >>> I have XP Home edition on my computer, and my Windows
    >>> firewall
    >>> is
    >>> suddenly off. I tried turning it back on, but it keeps saying
    >>> that
    >>> ICS is not running. It will then ask me if I want to start
    >>> the
    >>> service and if I say yes, it fails. I tried starting the
    >>> service
    >>> manually from within the control panel (services), but it
    >>> still
    >>> will
    >>> not start. Is reinstalling sp2 the only thing left to try?
    >>> Thanks in
    >>> advance for any help.
    >>
    >>
    >> ICS is the "Internet Connection Sharing" feature, not the
    >> firewall. It sounds like you're mixing up the two. To turn on
    >> the
    >> firewall, go to Start | Settings | Control Panel | Windows
    >> Firewall.
    >>
    >> --
    >> Ken Blake - Microsoft MVP Windows: Shell/User
    >> Please reply to the newsgroup
  5. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Try scanning for viruses, spyware, etc. I saw a computer last week with the
    exact same problem and once cleaned of all viruses and sypware the firewall
    became available again and worked fine. Worth a try, if you haven't already
    done so.

    "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com...
    >I have XP Home edition on my computer, and my Windows firewall is suddenly
    > off. I tried turning it back on, but it keeps saying that ICS is not
    > running.
    > It will then ask me if I want to start the service and if I say yes, it
    > fails. I tried starting the service manually from within the control panel
    > (services), but it still will not start. Is reinstalling sp2 the only
    > thing
    > left to try? Thanks in advance for any help.
  6. Archived from groups: microsoft.public.windowsxp.general (More info?)

    yeah, that was my first thought as well. I ran live updates for my antivirus,
    performed a scan...no virus found, and I ran Microsoft's beta spyware
    program. Sorry I forgot to include that important information. Any other
    suggestions?

    "Phyllis" wrote:

    > Try scanning for viruses, spyware, etc. I saw a computer last week with the
    > exact same problem and once cleaned of all viruses and sypware the firewall
    > became available again and worked fine. Worth a try, if you haven't already
    > done so.
    >
    > "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    > news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com...
    > >I have XP Home edition on my computer, and my Windows firewall is suddenly
    > > off. I tried turning it back on, but it keeps saying that ICS is not
    > > running.
    > > It will then ask me if I want to start the service and if I say yes, it
    > > fails. I tried starting the service manually from within the control panel
    > > (services), but it still will not start. Is reinstalling sp2 the only
    > > thing
    > > left to try? Thanks in advance for any help.
    >
    >
    >
  7. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Do you have XP SP2 installed with all available updates?

    "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    news:17EF9B57-49C5-4F67-AC3A-6945530E2C16@microsoft.com...
    > yeah, that was my first thought as well. I ran live updates for my
    > antivirus,
    > performed a scan...no virus found, and I ran Microsoft's beta spyware
    > program. Sorry I forgot to include that important information. Any other
    > suggestions?
    >
    > "Phyllis" wrote:
    >
    >> Try scanning for viruses, spyware, etc. I saw a computer last week with
    >> the
    >> exact same problem and once cleaned of all viruses and sypware the
    >> firewall
    >> became available again and worked fine. Worth a try, if you haven't
    >> already
    >> done so.
    >>
    >> "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    >> news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com...
    >> >I have XP Home edition on my computer, and my Windows firewall is
    >> >suddenly
    >> > off. I tried turning it back on, but it keeps saying that ICS is not
    >> > running.
    >> > It will then ask me if I want to start the service and if I say yes, it
    >> > fails. I tried starting the service manually from within the control
    >> > panel
    >> > (services), but it still will not start. Is reinstalling sp2 the only
    >> > thing
    >> > left to try? Thanks in advance for any help.
    >>
    >>
    >>
  8. Archived from groups: microsoft.public.windowsxp.general (More info?)

    yes I do.


    "Phyllis" wrote:

    > Do you have XP SP2 installed with all available updates?
    >
    > "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    > news:17EF9B57-49C5-4F67-AC3A-6945530E2C16@microsoft.com...
    > > yeah, that was my first thought as well. I ran live updates for my
    > > antivirus,
    > > performed a scan...no virus found, and I ran Microsoft's beta spyware
    > > program. Sorry I forgot to include that important information. Any other
    > > suggestions?
    > >
    > > "Phyllis" wrote:
    > >
    > >> Try scanning for viruses, spyware, etc. I saw a computer last week with
    > >> the
    > >> exact same problem and once cleaned of all viruses and sypware the
    > >> firewall
    > >> became available again and worked fine. Worth a try, if you haven't
    > >> already
    > >> done so.
    > >>
    > >> "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    > >> news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com...
    > >> >I have XP Home edition on my computer, and my Windows firewall is
    > >> >suddenly
    > >> > off. I tried turning it back on, but it keeps saying that ICS is not
    > >> > running.
    > >> > It will then ask me if I want to start the service and if I say yes, it
    > >> > fails. I tried starting the service manually from within the control
    > >> > panel
    > >> > (services), but it still will not start. Is reinstalling sp2 the only
    > >> > thing
    > >> > left to try? Thanks in advance for any help.
    > >>
    > >>
    > >>
    >
    >
    >
  9. Archived from groups: microsoft.public.windowsxp.general (More info?)

    LMM912 wrote:

    > yeah, that was my first thought as well. I ran live updates for my antivirus,
    > performed a scan...no virus found, and I ran Microsoft's beta spyware
    > program. Sorry I forgot to include that important information. Any other
    > suggestions?

    Forget MS antispyware. Use Ad-aware and Spybot Search and Destroy.

    Steve

    >
    > "Phyllis" wrote:
    >
    >
    >>Try scanning for viruses, spyware, etc. I saw a computer last week with the
    >>exact same problem and once cleaned of all viruses and sypware the firewall
    >>became available again and worked fine. Worth a try, if you haven't already
    >>done so.
    >>
    >>"LMM912" <LMM912@discussions.microsoft.com> wrote in message
    >>news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com...
    >>
    >>>I have XP Home edition on my computer, and my Windows firewall is suddenly
    >>>off. I tried turning it back on, but it keeps saying that ICS is not
    >>>running.
    >>>It will then ask me if I want to start the service and if I say yes, it
    >>>fails. I tried starting the service manually from within the control panel
    >>>(services), but it still will not start. Is reinstalling sp2 the only
    >>>thing
    >>>left to try? Thanks in advance for any help.
    >>
    >>
    >>
  10. Archived from groups: microsoft.public.windowsxp.general (More info?)

    What's the error message?
    Meanwhile, see: http://support.microsoft.com/kb/892350

    --
    Ramesh, Windows XP MVP
    http://windowsxp.mvps.org


    "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com...
    >I have XP Home edition on my computer, and my Windows firewall is suddenly
    > off. I tried turning it back on, but it keeps saying that ICS is not
    > running.
    > It will then ask me if I want to start the service and if I say yes, it
    > fails. I tried starting the service manually from within the control panel
    > (services), but it still will not start. Is reinstalling sp2 the only
    > thing
    > left to try? Thanks in advance for any help.
  11. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Firewall/Internet Connection Sharing Service fails to start. Logs event #
    7023 in Event Viewer with the error:
    "An address incompatible with the requested protocol was used".


    "Ramesh, MS-MVP" wrote:

    > What's the error message?
    > Meanwhile, see: http://support.microsoft.com/kb/892350
    >
    > --
    > Ramesh, Windows XP MVP
    > http://windowsxp.mvps.org
    >
    >
    > "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    > news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com...
    > >I have XP Home edition on my computer, and my Windows firewall is suddenly
    > > off. I tried turning it back on, but it keeps saying that ICS is not
    > > running.
    > > It will then ask me if I want to start the service and if I say yes, it
    > > fails. I tried starting the service manually from within the control panel
    > > (services), but it still will not start. Is reinstalling sp2 the only
    > > thing
    > > left to try? Thanks in advance for any help.
    >
    >
  12. Archived from groups: microsoft.public.windowsxp.general (More info?)

    The computer that I was working on had never heard of Microsoft Windows
    Spyware (Beta) and was having just the problem that you describe. I would
    still try to run several free online virus scans like from McAfee, Trend
    Micro, etc. Also, Stinger, CWShredder, Adaware, Spybot. I did all of these
    things along with installing SP2 and updates. Don't know which solved the
    problem but once I completed all the scans, the problem with the firewall
    being available was gone.

    "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    news:1970F6D5-8BE5-4144-892D-2D5CACB8F1A8@microsoft.com...
    > Firewall/Internet Connection Sharing Service fails to start. Logs event #
    > 7023 in Event Viewer with the error:
    > "An address incompatible with the requested protocol was used".
    >
    >
    >
    > "Ramesh, MS-MVP" wrote:
    >
    >> What's the error message?
    >> Meanwhile, see: http://support.microsoft.com/kb/892350
    >>
    >> --
    >> Ramesh, Windows XP MVP
    >> http://windowsxp.mvps.org
    >>
    >>
    >> "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    >> news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com...
    >> >I have XP Home edition on my computer, and my Windows firewall is
    >> >suddenly
    >> > off. I tried turning it back on, but it keeps saying that ICS is not
    >> > running.
    >> > It will then ask me if I want to start the service and if I say yes, it
    >> > fails. I tried starting the service manually from within the control
    >> > panel
    >> > (services), but it still will not start. Is reinstalling sp2 the only
    >> > thing
    >> > left to try? Thanks in advance for any help.
    >>
    >>
  13. Archived from groups: microsoft.public.windowsxp.general (More info?)

    After you run Microsoft Windows AntiSpyware (Beta), you have
    network-related problems, or you receive an error message

    http://support.microsoft.com/kb/892350

    regards,
    ssg MS-MVP

    LMM912 wrote:
    > I have XP Home edition on my computer, and my Windows firewall is suddenly
    > off. I tried turning it back on, but it keeps saying that ICS is not running.
    > It will then ask me if I want to start the service and if I say yes, it
    > fails. I tried starting the service manually from within the control panel
    > (services), but it still will not start. Is reinstalling sp2 the only thing
    > left to try? Thanks in advance for any help.
  14. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Q892350 addresses the problem. See if that helps.
    http://support.microsoft.com/kb/892350

    --
    Ramesh, Windows XP MVP
    http://windowsxp.mvps.org


    "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    news:1970F6D5-8BE5-4144-892D-2D5CACB8F1A8@microsoft.com...
    > Firewall/Internet Connection Sharing Service fails to start. Logs event #
    > 7023 in Event Viewer with the error:
    > "An address incompatible with the requested protocol was used".
    >
    >
    >
    > "Ramesh, MS-MVP" wrote:
    >
    >> What's the error message?
    >> Meanwhile, see: http://support.microsoft.com/kb/892350
    >>
    >> --
    >> Ramesh, Windows XP MVP
    >> http://windowsxp.mvps.org
    >>
    >>
    >> "LMM912" <LMM912@discussions.microsoft.com> wrote in message
    >> news:C5714FB5-B580-4EF9-8083-729A826F12DE@microsoft.com...
    >> >I have XP Home edition on my computer, and my Windows firewall is
    >> >suddenly
    >> > off. I tried turning it back on, but it keeps saying that ICS is not
    >> > running.
    >> > It will then ask me if I want to start the service and if I say yes, it
    >> > fails. I tried starting the service manually from within the control
    >> > panel
    >> > (services), but it still will not start. Is reinstalling sp2 the only
    >> > thing
    >> > left to try? Thanks in advance for any help.
    >>
    >>
Ask a new question

Read More

Firewalls Microsoft Windows XP