Closed

Unable to remove read only attributes for folders and disks

Archived from groups: microsoft.public.windowsxp.general (More info?)

This problem is not consistant throughout the system. I am running XP, SP2
and all current updates. Yesterday, a number of folders became read only.
It was not consistant throughout the logical disk, there were some folders
that were not. For the folders, I tried to remove the read only properity
via a R click - properity - uncheck read only. I then clicked apply then ok.
The disk remained read only.

A DVD that I was trying to back up the disk on was marked read only. I have
a disk image of the system just after I loaded it. I was going to back up my
data, then restore the system to its original state.

Is there a way I can remove the read only attribute?

Mike
7 answers Last reply
More about unable remove read attributes folders disks
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Mike wrote:

    > This problem is not consistant throughout the system. I am running XP, SP2
    > and all current updates. Yesterday, a number of folders became read only.
    > It was not consistant throughout the logical disk, there were some folders
    > that were not. For the folders, I tried to remove the read only properity
    > via a R click - properity - uncheck read only. I then clicked apply then ok.
    > The disk remained read only.
    >
    > A DVD that I was trying to back up the disk on was marked read only. I have
    > a disk image of the system just after I loaded it. I was going to back up my
    > data, then restore the system to its original state.
    >
    > Is there a way I can remove the read only attribute?
    >
    > Mike

    The read only attribute had no meaning for folders on hard drives. The
    folder is always open for reading unless it's modified in permissions.

    CDs/DVDs except RWs are always read only.


    --
    Rock
    MS MVP Windows - Shell/User
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Read-only means nothing for folders. Only a file can be Read-only.

    The Read-only check box for folders is there for convenience, it allows you
    to change the Read-only attribute of all the files contained in that folder.
    -----

    Files saved to CD/DVD are automatically listed as Read-only. When they are
    restored to a hard drive they remain Read-only.

    Locate the files through My Computer or Windows Explorer.

    Highlight the file or group of files | Right click the file or group of
    files | Properties | Uncheck the Read-only box found in Attributes | Click
    Apply | Click OK

    See also...
    HOW TO: Remove the Read-Only Attribute While You Copy Files from a CD-ROM in
    Windows 2000
    http://support.microsoft.com/default.aspx?scid=kb;en-us;323002

    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:7B924708-5C7E-4678-871C-527883B86E6D@microsoft.com,
    Mike <Mike@discussions.microsoft.com> hunted and pecked:
    > This problem is not consistant throughout the system. I am running XP,
    > SP2 and all current updates. Yesterday, a number of folders became read
    > only. It was not consistant throughout the logical disk, there were some
    > folders that were not. For the folders, I tried to remove the read only
    > properity via a R click - properity - uncheck read only. I then clicked
    > apply then ok. The disk remained read only.
    >
    > A DVD that I was trying to back up the disk on was marked read only. I
    > have a disk image of the system just after I loaded it. I was going to
    > back up my data, then restore the system to its original state.
    >
    > Is there a way I can remove the read only attribute?
    >
    > Mike
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    In news:7B924708-5C7E-4678-871C-527883B86E6D@microsoft.com,
    Mike <Mike@discussions.microsoft.com> typed:

    > This problem is not consistant throughout the system. I am
    > running
    > XP, SP2 and all current updates. Yesterday, a number of
    > folders
    > became read only. It was not consistant throughout the logical
    > disk,
    > there were some folders that were not. For the folders, I
    > tried to
    > remove the read only properity via a R click - properity -
    > uncheck
    > read only. I then clicked apply then ok. The disk remained
    > read only.


    If you'll look more closely at the check mark in that Read-Only
    box, you'll see that it's gray, not black. You can also verify
    this by clicking a few times in the box; it will cycle among
    *three* states: unchecked, checked in black, and checked in gray.


    A black check means the item is read-only and an unchecked box
    means it's not read-only. But the gray check means that it's
    neither. The read-only attribute is not pertinent to folders.


    So no, your folders aren't read-only, and what you are seeing is
    perfectly normal. There's nothing to worry about and nothing to
    fix.


    --
    Ken Blake - Microsoft MVP Windows: Shell/User
    Please reply to the newsgroup
  4. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Wesley Vogel wrote:

    > Files saved to CD/DVD are automatically listed as Read-only. When they are
    > restored to a hard drive they remain Read-only.

    ¿Are you sure about this last thing?

    For me the Read-only attribute remains set under Win98, but under this
    here WinXP setup it is auto-cleared when copying from a CD/DVD-ROM to a
    HardDiskDrive volume.

    N.B. I adjust my OS's to suit me as much as i know how, but i don't
    remember changing anything regard this. I do like that Read-only gets
    cleared under WinXP and wish i could change Win98 to do the same.

    --
    Please followup in newsgroup.
    E-mail address is invalid due to spam-control.
  5. Well I hope Ken Blake, Microsoft MVP, has learned something in the mean time. It's been almost 5 years, you know. The folder's Read Only attribute prevents other computers from writing to the folder with a RO attribute set to gray. An attempt to write to the folder returns an error message saying the the folder is "Read Only" and the write attempt failed.
    Moreover, the question was how to remove the Read Only attribute. Ken only told people to live with it. That's pathetic.

    Nico


    Quote:
    Archived from groups: microsoft.public.windowsxp.general (More info?)

    In news:7B924708-5C7E-4678-871C-527883B86E6D@microsoft.com,
    Mike <Mike@discussions.microsoft.com> typed:

    > This problem is not consistant throughout the system. I am
    > running
    > XP, SP2 and all current updates. Yesterday, a number of
    > folders
    > became read only. It was not consistant throughout the logical
    > disk,
    > there were some folders that were not. For the folders, I
    > tried to
    > remove the read only properity via a R click - properity -
    > uncheck
    > read only. I then clicked apply then ok. The disk remained
    > read only.


    If you'll look more closely at the check mark in that Read-Only
    box, you'll see that it's gray, not black. You can also verify
    this by clicking a few times in the box; it will cycle among
    *three* states: unchecked, checked in black, and checked in gray.


    A black check means the item is read-only and an unchecked box
    means it's not read-only. But the gray check means that it's
    neither. The read-only attribute is not pertinent to folders.


    So no, your folders aren't read-only, and what you are seeing is
    perfectly normal. There's nothing to worry about and nothing to
    fix.


    --
    Ken Blake - Microsoft MVP Windows: Shell/User
    Please reply to the newsgroup
  6. The solution when sharing a folder , is to go under Sharing and modify the permissions by adding change priviliege to everyone !
  7. To remove the Read-only attribute and to set the System attribute, use the following command:
    attrib -r +s drive:\<path>\<foldername>
Ask a new question

Read More

Read Only Microsoft Windows XP