Sign in with
Sign up | Sign in
Your question

USB Flash Drive is not recognized. Must restart system to ..

Last response: in Windows XP
Share
July 14, 2005 6:49:01 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

My Sony Microvault 1.0 GB. flash drive is not found in my Windows XP
Professional system. I have to reboot the system, then it will find it. And
after I safely remove it and plug it back in, it's not recognized again. In
Device Manager, it said 'Unknown Device' when it's not recognized. Could you
please help? I've checked with Sony for a driver, but it seems I have the
current one already. Please help.

Thanks a million!!
July 14, 2005 10:36:44 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Pat wrote:

> My Sony Microvault 1.0 GB. flash drive is not found in my Windows XP
> Professional system. I have to reboot the system, then it will find it. And
> after I safely remove it and plug it back in, it's not recognized again. In
> Device Manager, it said 'Unknown Device' when it's not recognized. Could you
> please help? I've checked with Sony for a driver, but it seems I have the
> current one already. Please help.
>
> Thanks a million!!

General USB troubleshooting in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;310575

--
Rock
MS MVP Windows - Shell/User
Anonymous
July 14, 2005 10:42:07 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

I can't speak for the Sony Microvault, but I have a SanDisk Cruzer Mini USB
drive, and with WinXP you do not have to anything other than pull the USB
drive out of the socket when you are ready to go. Removing it safely, in XP
removes the driver, which you can only get back again with a reboot.

With Win2000 you do need to do the safe removal or you get an error message
and run the risk of files not being closed properly on the USB drive.

Art

"Pat" <Pat@discussions.microsoft.com> wrote in message
news:93E2B8BD-39FD-4DDE-B18D-18323DC53DC0@microsoft.com...
> My Sony Microvault 1.0 GB. flash drive is not found in my Windows XP
> Professional system. I have to reboot the system, then it will find it.
> And
> after I safely remove it and plug it back in, it's not recognized again.
> In
> Device Manager, it said 'Unknown Device' when it's not recognized. Could
> you
> please help? I've checked with Sony for a driver, but it seems I have the
> current one already. Please help.
>
> Thanks a million!!
February 18, 2009 3:55:46 PM

I had this same problem that I was able to resolve. For me, the problem was that I had a network drive letter H: that was conflicting with my flash drive (It also wanted to be H:)  So if I tried to plug and play the flash drive, nothing happened, if I restarted, the flash drive would show up as H:, and I would be missing my H: network drive.

I changed drive letters on my flash drive to I: and have not had the problem since.

Good luck!
!