Sign in with
Sign up | Sign in
Your question

I have LAST xp As my O.S CANON multipass l6000

Last response: in Other Consumer Electronics
Share
July 17, 2009 5:09:21 AM

I have a problem my system after installing it it wont let me print! When I try to print with notepad it says "INVALID HANDLE" when i try to print with "Google Chrome" it simply doesn't do anything just stays blank. Any help? Any Idea?

More about : canon multipass l6000

July 17, 2009 1:37:38 PM

to be more specific I am running LAST XP. and my printer IS an CANON MULTIPASS L6000 I have downloaded the drivers for it but still nothing. It shows that everything is running and that it should be printing, i checked in "device manager" it shows it there as nothing wrong.
January 27, 2010 10:12:36 PM

I had the same problem, well still have technically...

I worked on it for perhaps 16 hours, tried everything - reloading XP, setting and resetting port type in bios, trying different XP service packs(1-3), reloading the Cannon software and patch after reboot, and on and on - and couldn't get it to work.

My best guess is that it is some sort of device driver incompatibility, most likely culprit is the device driver that XP loaded for this particular parallel port, as I couldn't even get my new PC to print over the network to the L6000 operating off of my old hardware. The L6000 doesn't appear to have a standard "printer" interface, just happens to use the parallel port in some nonstandard fashion, thus the MPService(?) must be running, and a separate "Service" isn't required for true printer drivers.

So, being the penny pinching type, I now print to PDF using CutePDF, copy the file(s) to my old hardware over my network connection, and print it out from there. I'll probably bite the bullet after my toner runs out and upgrade, and although it was gently used, 10+ years is still a pretty good lifetime for a printer.
Related resources
January 28, 2010 7:10:31 PM

Well, after posting my tale of woe, I found a solution - at lease one that worked for me.

Found a post that indicated that the NVIDIA video card driver caused issues with the Canon Desktop Manager 3.01software here - http://www.pchelpforum.com/windows-xp-2000/59149-canon-multipass-l6000-stops-working-01-01-2009-a-3.html on the second page.

Sure enough, I went to my backup Windows XP installation, removed the video drivers, installed the Canon 3.01 software and it worked.

But it gets better, I installed the latest NVIDIA drivers for my 8800GTS (196.21) and it still worked.

And still better - I went back to my main XP install and simply installed the Canon 3.01 "drivers" (setup/reboot/setup2) and everything is working / printing as it should. The NVIDIA v191.07 drivers are on that install, and I am hesitant to upgrade them, but my guess is the newer NVIDIA drivers will work just fine w/ the 3.01 printer "drivers." Apparently whatever the conflict was, it has been resolved with these newer video drivers.

So after a couple of years of shuttling files to the other machine for printing, I can finally print locally.

The info here - http://www.computer-u.com/techCanon.htm - was also useful in that it indicated the correct bios setting for the port. I didn't have to do any of the device reloading it mentions, just set the port in bios to ECP and loaded the Canon software.

I hope this comes up on search for those of you that have had this problem printing with the Canon Multipass L6000 printer (or other models that use the Desktop Manager 3.01 software). I wish I could remember some of the error messages that I saw other than the " invalid handle " in notepad to produce more complete search engine coverage, but hopefully I have included enough keywords. Canon printing error solved - Canon printing problem solved - Canon printing fix

Best of luck

June 25, 2010 2:59:02 PM

Thank you very much I greatly appreciate your reply, however now I just use xp professional and the printer works good, but when I was using the last xp thats when I was having problems and struggling with it, that info you provided is very helpful if I decide to go back to last xp I will give it a try, thanks.
!