Sign in with
Sign up | Sign in
Your question

COM port 4 in use?

Tags:
  • Comm Port
  • Microsoft
  • Windows XP
Last response: in Windows XP
Share
Anonymous
July 16, 2005 11:04:25 PM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware (More info?)

I'm using Windows XP Professional SP2.

1. Modem is using COM port 3
2. There is no COM port 4 shown in Device Manager

When I added my Bluetooth, I noticed it created a Serial port COM 5.
Out of curiosity, I tried to change it to COM 4, but only to find COM 4
was being used.

How do I find out what is using COM 4? Thanks.

More about : port

Anonymous
July 16, 2005 11:04:26 PM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware (More info?)

Check Device Manager, Ports category. Most motherboards
have at least one or perhaps 2 on-board Serial Ports on them.
Defined as Serial-A & Serial-B. Modems have their own port.

One of the "Oldest" PITA aspects of a Personal Computer.

Ports can conflict, as they use Multiplexing where COM1 &
COM3 share an IRQ but have different Addresses. The same
holds true for COM2 and COM4.

If your Ports Category shows COM1, COM2 - then you may
need to enter BIOS setup and set Serial A/B to disabled to
avoid conflicts, Unless you have physical connections to the
Serial ports on the backplane of the computer.

"PHiLiP" <@.com.hk> wrote in message
news:%23kplrYfiFHA.3596@TK2MSFTNGP10.phx.gbl...
> I'm using Windows XP Professional SP2.
>
> 1. Modem is using COM port 3
> 2. There is no COM port 4 shown in Device Manager
>
> When I added my Bluetooth, I noticed it created a Serial port COM 5.
> Out of curiosity, I tried to change it to COM 4, but only to find COM 4
> was being used.
>
> How do I find out what is using COM 4? Thanks.
>
>
Anonymous
July 17, 2005 1:22:26 AM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware (More info?)

Like I said originally, there is no COM4 shown in Device Manager.
Forgot to mention my computer has no physical PS/2, LPT or COM port -
only the modem has been assigned COM3 prior to adding the Bluetooth
dongle.

I did a search in the Registry and found COM4 is associated to the
Bluetooth dongle I added - for some unknown reasons it added an
"invisible" COM4 along side COM5 (that I can see listed in Device
Manager).

How can I remove this COM4? It is not even visible when I tick the
option to show hidden devices in Device Manager.


"R. McCarty" <PcEngWork-NoSpam_@mindspring.com> wrote in message
news:o 4Ln6dfiFHA.3672@TK2MSFTNGP10.phx.gbl...
: Check Device Manager, Ports category. Most motherboards
: have at least one or perhaps 2 on-board Serial Ports on them.
: Defined as Serial-A & Serial-B. Modems have their own port.
:
: One of the "Oldest" PITA aspects of a Personal Computer.
:
: Ports can conflict, as they use Multiplexing where COM1 &
: COM3 share an IRQ but have different Addresses. The same
: holds true for COM2 and COM4.
:
: If your Ports Category shows COM1, COM2 - then you may
: need to enter BIOS setup and set Serial A/B to disabled to
: avoid conflicts, Unless you have physical connections to the
: Serial ports on the backplane of the computer.
:
: "PHiLiP" <@.com.hk> wrote in message
: news:%23kplrYfiFHA.3596@TK2MSFTNGP10.phx.gbl...
: > I'm using Windows XP Professional SP2.
: >
: > 1. Modem is using COM port 3
: > 2. There is no COM port 4 shown in Device Manager
: >
: > When I added my Bluetooth, I noticed it created a Serial port COM 5.
: > Out of curiosity, I tried to change it to COM 4, but only to find
COM 4
: > was being used.
: >
: > How do I find out what is using COM 4? Thanks.
: >
: >
:
:
Related resources
Anonymous
July 17, 2005 1:22:27 AM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware (More info?)

On Sat, 16 Jul 2005 21:22:26 +0800, "PHiLiP" <@.com.hk> wrote:

>Like I said originally, there is no COM4 shown in Device Manager.
>Forgot to mention my computer has no physical PS/2, LPT or COM port -
>only the modem has been assigned COM3 prior to adding the Bluetooth
>dongle.
>
>I did a search in the Registry and found COM4 is associated to the
>Bluetooth dongle I added - for some unknown reasons it added an
>"invisible" COM4 along side COM5 (that I can see listed in Device
>Manager).
>
>How can I remove this COM4? It is not even visible when I tick the
>option to show hidden devices in Device Manager.

You don't mention how your dongle is attached to your computer.
XP has a bug associated with assigning com port addresses to USB
devices. Every time the device is connected, it is assigned a
higher com port number. In the advanced section of the com port
setup in device manager when the device is connected, you can
just reassign the port number for the device to a lower port
number that you know is not in use, and ignore the windows
warning. I've done this with my USB/serial port adapter and XP
seems to remember the assigned com port after that. Check the
link below for some info.

http://www.modemsite.com/56k/xptip.asp
Anonymous
July 17, 2005 3:26:59 AM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware (More info?)

Thanks. I'm not trying to reassign to a different COM port.
I'm trying to get rid of or free up an invisible COM4 port that somehow
my Bluetooth dongle has created and Windows reports it is in use.


"Si Ballenger" <shb*NO*SPAM*@comporium.net> wrote in message
news:42d9172b.233175328@news.comporium.net...
: On Sat, 16 Jul 2005 21:22:26 +0800, "PHiLiP" <@.com.hk> wrote:
:
: >Like I said originally, there is no COM4 shown in Device Manager.
: >Forgot to mention my computer has no physical PS/2, LPT or COM port -
: >only the modem has been assigned COM3 prior to adding the Bluetooth
: >dongle.
: >
: >I did a search in the Registry and found COM4 is associated to the
: >Bluetooth dongle I added - for some unknown reasons it added an
: >"invisible" COM4 along side COM5 (that I can see listed in Device
: >Manager).
: >
: >How can I remove this COM4? It is not even visible when I tick the
: >option to show hidden devices in Device Manager.
:
: You don't mention how your dongle is attached to your computer.
: XP has a bug associated with assigning com port addresses to USB
: devices. Every time the device is connected, it is assigned a
: higher com port number. In the advanced section of the com port
: setup in device manager when the device is connected, you can
: just reassign the port number for the device to a lower port
: number that you know is not in use, and ignore the windows
: warning. I've done this with my USB/serial port adapter and XP
: seems to remember the assigned com port after that. Check the
: link below for some info.
:
: http://www.modemsite.com/56k/xptip.asp
:
Anonymous
July 17, 2005 3:30:40 AM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware (More info?)

Please ignore what I just wrote. Didn't realize you were pointing out
that I could reclaim the port.
THANKS!!!

"PHiLiP" <@.com.hk> wrote in message
news:ej7hTrhiFHA.2484@TK2MSFTNGP15.phx.gbl...
: Thanks. I'm not trying to reassign to a different COM port.
: I'm trying to get rid of or free up an invisible COM4 port that
somehow
: my Bluetooth dongle has created and Windows reports it is in use.
:
:
: "Si Ballenger" <shb*NO*SPAM*@comporium.net> wrote in message
: news:42d9172b.233175328@news.comporium.net...
:: On Sat, 16 Jul 2005 21:22:26 +0800, "PHiLiP" <@.com.hk> wrote:
::
:: >Like I said originally, there is no COM4 shown in Device Manager.
:: >Forgot to mention my computer has no physical PS/2, LPT or COM
port -
:: >only the modem has been assigned COM3 prior to adding the Bluetooth
:: >dongle.
:: >
:: >I did a search in the Registry and found COM4 is associated to the
:: >Bluetooth dongle I added - for some unknown reasons it added an
:: >"invisible" COM4 along side COM5 (that I can see listed in Device
:: >Manager).
:: >
:: >How can I remove this COM4? It is not even visible when I tick the
:: >option to show hidden devices in Device Manager.
::
:: You don't mention how your dongle is attached to your computer.
:: XP has a bug associated with assigning com port addresses to USB
:: devices. Every time the device is connected, it is assigned a
:: higher com port number. In the advanced section of the com port
:: setup in device manager when the device is connected, you can
:: just reassign the port number for the device to a lower port
:: number that you know is not in use, and ignore the windows
:: warning. I've done this with my USB/serial port adapter and XP
:: seems to remember the assigned com port after that. Check the
:: link below for some info.
::
:: http://www.modemsite.com/56k/xptip.asp
::
:
:
!