Mouse stops working

Just in the last couple of weeks my mouse has stopped working after I reboot my comp. If I unplug it and plug it back in again it works fine, until the next reboot anyway. I've tried different usb ports, a different mouse, defaukt mircosoft drivers, the latest logitech drivers, disabling my AV but nothing seems to help. Any ideas?

I'm using XP pro and logitech mx310 mouse to btw
7 answers Last reply
More about mouse stops working
  1. When it stop working, And there's a red light under the mouse? then it's not comunicating.

    Have you try the PS2 connection instead of USB?

    Try uninstalling the driver then restart the computer. Let the compter install the hardware. Then restart again after self diagnostic install the driver.
  2. bLaNk_ said:
    Just in the last couple of weeks my mouse has stopped working after I reboot my comp. If I unplug it and plug it back in again it works fine, until the next reboot anyway. I've tried different usb ports, a different mouse, defaukt mircosoft drivers, the latest logitech drivers, disabling my AV but nothing seems to help. Any ideas?

    I'm using XP pro and logitech mx310 mouse to btw



    yes !!! uninstall the software,reboot machine,i have never input the software for any mouse
    it just snafu's the system,the only time that the software is really needed is, and, might be for certain types of spread sheets and the like,i have two mice the logitech mx610 and it's twin which came with my easy call ? whatever voip keyboard system,never used the drivers,of course it is all usb,but the 610 has an adapter and can be used as a ps2 also,, at the moment though it is plugged into the base of my dead G7 mouse's receiver,if after all the fooling around that you can think of and it does not work,try it on a chum's system,no drivers,and, if it still is nonfunctional ,,well,,,,..:>)
  3. You know dokk, you may want to check the date on a thread before replying...
  4. hate to necro post but im having the exact same issue. nothing seems to work. different usb ports, mouse drivers or no mouse drivers.


    its a razer Lachesis and a brand new ibuypower gamer power 509 pc.
  5. Found a way to fix it? I also have this with a Razer Lachesis
  6. I have the same issue with v5 kensington expert mouse (sorry about the zombie thread, but it is the EXACT same problem) any solution?
Ask a new question

Read More

Mice Drivers Logitech Peripherals