Sign in with
Sign up | Sign in
Your question

[Solved] 32bit Program No longer Working On 64bit Win7

Last response: in Windows 7
Share
September 19, 2012 9:13:44 AM

Hello all, I was hoping you can help me out.

I recently built a new computer using Windows 7 Ultimate 64bit, and it is fully up to date. I am trying to run 3D Studio Max 2009 32bit but it wont run. The splash screen will show for a few milliseconds, then disappear, and nothing will happen.

My old computer had Windows 7 Home 64bit, and I could run the same copy of 3D Studio Max 32bit easily. So I'm trying to figure out why my new computer wont run it.

3D Studio Max 2009 64bit runs perfectly, just not the 32bit version (both installed at the same time).

I absolutely need to use the 32bit version because I have to use a custom exporter / plugin that only works with the 32bit 3DSM.

I am really stumped on this one. I know it's not the copy of 3DSM because I used the same copy on my old computer.

I reinstalled multiple times.
I repair installed multiple times.
I ran under every compatibility mode possible.
I disabled visual themes, desktop composition, etc.
I run under admin mode.
I've disabled Anti-Virus.

Just can't get it to work.

I also installed 3DSM Version 9 32bit and that doesn't work either. That version also worked on my old computer with Windows 7 Home 64bit. So it's not the 3DSM install... It has something to do with my Windows install.

This is a clean install of Windows 7 Ultimate.

Specs:
i7 3930K
Gigabyte G1 Assassin 2 Mobo
Gigabyte Geforce GTX 680
32GB G-Skill DDR3 RAM
OCZ 128GB SSD
Velociraptor 1TB HDD
September 19, 2012 9:26:32 AM

I also looked in the Windows Event log for Applications to find an error message, and there is nothing usefull...
m
0
l
September 19, 2012 1:19:20 PM

Anybody have any ideas?
m
0
l
Related resources
a b $ Windows 7
September 19, 2012 3:07:25 PM

Run it as Administrator?
m
0
l
a b $ Windows 7
September 19, 2012 3:35:26 PM

If you're after an answer and it's important, I would suggest contacting Autodesk or at least going on their forums. You're more likely to find people with the right knowledge there as it sounds like a problem very specifically with that software.
m
0
l
a b $ Windows 7
September 19, 2012 4:02:23 PM

Did you have both the 64bit and 32bit running on the old pc?
m
0
l
September 19, 2012 5:08:26 PM

I already tried running as administrator.

Yes, 64 and 32 bit versions of 3DSM were running on the old computer which was 64bit Windows.
m
0
l
a c 228 $ Windows 7
September 19, 2012 5:12:25 PM

Dou you have DEP (data execution prevention) turned on for all programs? If so, you may need to add 3DSM to the exception list.
m
0
l
September 19, 2012 5:26:45 PM

Nope, DEP is not on for all programs. Only essential Windows programs and services.

The 64bit 3DSM is running fine. So you can rule out a lot of things knowing that.
m
0
l
a c 228 $ Windows 7
September 19, 2012 5:33:43 PM

Ok, well normally DEP throws up an error message when a program has issues, but I've noticed under windows 7 that this is not always the case and a program will simply crash to the desktop without warning, similar to what is happening in your situation, so I thought I'd throw that out there for you.
m
0
l
September 19, 2012 5:50:12 PM

Try compatibility mode.
m
0
l
September 19, 2012 5:55:35 PM

I'm sorry but some of you are not even reading my first post?

I clearly state I tried every compatibility mode.
m
0
l
September 19, 2012 6:03:13 PM

Sorry dude, i didnt read carefully. Actually compatibility mode works for me in some program in my 64-bit os.
m
0
l
September 19, 2012 6:18:00 PM

Also found this....

Try This:

Uninstall Max (all of it, components the lot)

Now reinstall, but when configuring locations to install to make sure you do not install 32 and 64 bit versions to the same location, otherwise windows will get confused at trying to load a 32 bit exe under 64 bit architecture rules.

m
0
l
September 19, 2012 6:27:39 PM

It's not a video card compatibility issue. The 64bit 3DSM works perfect...

Also, 32bit and 64bit are installed in different directories. One is in Program Files, the other is in Program Files (x86).

Nothing in the provided links thus far works.

Again, the 64bit 3DSM works perfectly fine... this rules out a lot.

This issue has me confused... and I know my way around computers lol.
m
0
l
September 20, 2012 12:13:33 AM

Well, thanks for trying anyway. I guess nobody knows the answer to this one.
m
0
l
September 20, 2012 12:48:23 AM

I do not know if virtual xp is a download available for ultimate, but have had no problem with legacy 32 bit programs in 7 pro 64 bit. If you can add virtual xp problem solved.
Edit, Looks like you are worthy
http://www.microsoft.com/windows/virtual-pc/
Have fun, you can even have a link on the win 7 desktop!
m
0
l
September 20, 2012 2:16:43 AM

Tried it. 3D Studio Max 2009 won't run on the Virtual XP.

The reason I want to run it on 64bit is because I can take advantage of my high amount of RAM. Otherwise I would just dual boot Windows 7 32bit but that only allows 4 GB of ram.

I know 3DSM 2009 32bit can run on Windows 7 Ultimate 64bit.... I just need to find the cause of it not starting. It runs on Windows 7 HOME 64bit quite easily. I need to know the difference.

I think the difference might be hardware related though.
m
0
l
September 20, 2012 2:25:10 AM

Are there any messages in the event viewer. In the olden days most problems like this were related to video.
m
0
l
September 22, 2012 12:57:57 AM

Well, I found the problem and a workaround...

The program doesn't seem to be compatible with the multiple cores for my Intel i7 3930k Sandy Bridge. There was a hot fix for 3DSM 2009 and up to increase compatibility for processors with 24 cores or more, but it doesn't seem to work with the newer i7's with 6 cores and 6 virtual cores with hyperthreading for a total of 12 "CPUs".

The original workaround I discovered was to disable multiple cores in BIOS. That's not fun.

There is also a way to limit cores in "msconfig" advanced boot options which also worked. Also not fun.

But, I have discovered that setting the processor affinity of 3dsmax.exe to be the best workaround for now. However, since the program wont run I can't change the CPU affinity in Task Manager. Even if 3dsmax.exe was running, it still wont allow you to change CPU affinity. So I had to set the affinity via command prompt BEFORE starting 3DSM.

To do that I right clicked on the 3DSM shortcut on my desktop, clicked Properties, and next to Target I put this:

C:\Windows\System32\cmd.exe /C start "" /affinity F "C:\Program Files (x86)\Autodesk\3ds Max 2009\3dsmax.exe"

After that, 3DSM started instantly when I clicked on the shortcut...

I found that with Windows 7 64bit, 3DSM would run with only 4 CPUs. With Windows 7 32bit, 3DSM would run with only 2 CPUs.

If anyone should read this in the future and have a similar problem, here is some info about Affinity.

The affinity attribute requires a bit mask in the form of hex values (nibbles). This allows you to select specific CPUs that you want to run. With just a nibble (4 bits) you can control 4 CPUs. With one byte (8 bits) you can control 8 CPUs. With two bytes (16 bits) you can control 16 CPUs.

Example: If you have 4 CPUs and you want to run only CPU 0 and CPU 2, then your bit mask would be "1010" and converted to hex that is "A". If you have 4 CPUs and you want them ALL to run, then your bit mask would be "1111" and in hex that is "F". 1 is on 0 is off. You can use a binary to hex converter if you have trouble.

If you have more than 4 CPUs, say 8 CPU's, but only want to run the first 4, you don't have to have assign bit values for the rest like this "11110000". You don't have to worry about the last bits, and can just use "1111".

In my case, I found 3DSM would only work with 4 CPUs in Win7 64bit. So I set the affinity to "F" which is "1111". I have 12 CPUs, so I could have done "FFF".

Hope that helps someone along the line.

Anyway, thanks to everyone that tried to help.
m
0
l
September 22, 2012 3:45:47 AM

You can also set cpu affinity via task manager. Just select the process tab and right click the desire program execution file and select 'set affinity'. But it not going to help if the desire program is not running. Just telling.
m
0
l
!