Solved

Kodak Z1275

I have a Kodak Z1275 digital camera, It's about 2 years old, and never had a problem until now.
I took some pictures and then it turned off, so I thought that it was the batteries.
I put them to charge (they're AAs), and when they finished charging, I put them back in the camera.
When I press the On button, it opens and extends the lenses, and the battery led starts flashing red, then it closes the lens cover and the lenses.
I tried 3 different sets of (charged) rechargeable batteries with the same results.
Anyone knows what could be happening with this camera and how to solve it.

Thanks in advance.
3 answers Last reply Best Answer
More about kodak z1275
  1. Best answer
    Try non-rechargeable. They run at 1.3 volts instead of 1.5 and many cameras either won't take them at all or get cranky after using them for a while since the batteries degrade and don't hold full charges.
  2. The non-rechargeable worked!
    I'll see if there's a firmware update for my camera or something.
    Thanks Viper, here's your best answer.
  3. Much appreciated, DunkLegend.
Ask a new question

Read More

Cameras Kodak