Sign in with
Sign up | Sign in
Your question
Solved

Graphics black while playing WOW

Last response: in Windows 7
Share
September 20, 2012 12:13:54 PM

Hello,
Since the last patch the graphics are going black. The characters gear turn black, the scenary turns black. If I go to "system" "graphics" and hit "recommended" the whole screen goes black for a second or two, then comes back up and everything runs normally for a little while. When I zone into a different area, it does it again. It is doing it on my desk top and lap top so it has to have something to do with the game. Is anyone else having this issue? Thanks...
October 31, 2012 11:01:18 AM

vcsuber01 said:
Hello,
Since the last patch the graphics are going black. The characters gear turn black, the scenary turns black. If I go to "system" "graphics" and hit "recommended" the whole screen goes black for a second or two, then comes back up and everything runs normally for a little while. When I zone into a different area, it does it again. It is doing it on my desk top and lap top so it has to have something to do with the game. Is anyone else having this issue? Thanks...


I have the exact same problem.
Anyone know how to fix it? :S
m
0
l
a b \ Driver
a b Ý World of Warcraft
a c 354 $ Windows 7
October 31, 2012 3:23:24 PM

Wait till the patch finishes downloading. You're seeing blank textures that have not been downloaded yet.
m
0
l
Related resources
November 7, 2012 11:02:57 AM

It won't fix..I've even taken WOW completely off my machines and reinstalled, same problem. Very frustrating.
m
0
l
a b \ Driver
a b Ý World of Warcraft
a c 354 $ Windows 7
November 7, 2012 12:47:50 PM

Try updating the video card drivers. Have you tried with any other games to see if they do that?
m
0
l
November 7, 2012 12:56:31 PM

WOW is the only game I play :)  I tried updating drivers and it said all up to date. If it was just either my lap top or my desk top I could understand something being wrong, but both? My lap top is a little over a year old and my desk top is only 2 yrs old. I'm just stumped.
m
0
l
a b \ Driver
a b Ý World of Warcraft
a c 354 $ Windows 7
November 7, 2012 3:35:08 PM

vcsuber01 said:
WOW is the only game I play :)  I tried updating drivers and it said all up to date. If it was just either my lap top or my desk top I could understand something being wrong, but both? My lap top is a little over a year old and my desk top is only 2 yrs old. I'm just stumped.


How did you update drivers? Though Windows or did you go to the vendor's site and check there? For laptop you want to go to the laptop vendor's support, desktop OK to go to the video card makers web site.

I had this same issue when my wife re-subscribed and got a new patch, but all the issues went away after the patch fully finished.

You may want to check Blizzard support forums.
m
0
l
November 7, 2012 4:36:54 PM

I went to the Dell website, both of my computers are Dell...then I went to the website of the video card, can't remember the name...(not very computer savvy)...the game was completely downloaded before I tried to log in.
m
0
l

Best solution

November 8, 2012 9:25:16 PM

If you're using a Dell notebook to play it could be the version of DirectX you are using Lots of people have it, the fix is switching to DirectX 9 from DirexctX 11. There is a thread here where one of the WOW devs discusses the issue. http://us.battle.net/wow/en/forum/topic/6679199008
Share
November 19, 2012 3:50:56 PM

I hope I'm not speaking too soon...but I went to Zen Puppy's suggested forum...Mine was set on 11, I changed it to 9 and I'm no longer having the issue...thanks so much!
m
0
l
November 26, 2012 10:39:59 AM

Best answer selected by vcsuber01.
m
0
l
!