Solved

New sandisk class 10 32gb micro sdhc moblie ultra card wont format

I'm trying to format the above listed card through my Toshiba Sattilite 660-x running windows 7 w/ an sd adapter card slot from out of my Nokia E-5 cellphone. It keeps telling me in 6 attempts that windows cannot format it. Properties on the card show it as full, but it has never had more than 16gb put on it. As this card is not even 2 months old. Is there a site that can use to format this on freeware...etc?
6 answers Last reply Best Answer
More about sandisk class 32gb micro sdhc moblie ultra card wont format
  1. Make sure u got genuine card.. (double check it with Sandisk)

    there a lot of fake card with firmware modified to report higher capacity than it was, ....
  2. I appricate your input bro. I've heard alot of bad things about the supposed 32GB cards on e-bay, but I assumed buying from cellphoneshop.net that I could expect a product from the manufacturer. I downloaded the program from the sd association with a new formatter at sdcard.org. Then tried a second sd to micro sd adapter. It is still claiming that the card is write protected and therfore will not format. My second adapter has no lock switch to write protect. I've tried both quick and full formats on both adapters with both programs. Same results. I downloaded the disks files to the laptop before I attempted...so I have it. I just can't get it format to retrieve. I hope I don't have to eat this $42.00 2 month old disk is all. I'm afraid I might have to. Thanks for your time. Tom.
  3. Best answer
    Try using a Linux livecd, had this on one of mine and Windows wouldn't touch it, Linux just flattened it. If that fails RMA.
  4. Best answer selected by nikkidog1440.
  5. Hey Stig: You got got my best answer vote after a week. But I still have a question for all. if I'm mistaken Linux is another, separate OS. How am I to get my windows 7 to accept that cd. If and when I could find it, much less download it to windows to use same. I thought those 2 were incompatable. Am I missing something here? I still have the micro 32gb awaiting response to save it. Thank you.
  6. Quote:
    Hi,


    You have to tell Windows to optimize your SD slot for performance instead of quick removal:
    1. Right-click on My Computer and select Properties
    2. Click on the Hardware Tab
    3. Click on the Device Manager button
    4. Click on the little + next to Disk Drives
    5. Right-click on USB2.0 CardReader SD0 USB Device and select Properties
    6. Click on the Policies tab
    7. Click on the Optimize for performance circle
    8. Click on OK

    Hope this information helps you.

    - jmsmrtn98 from http://forums.sandisk.com

    Unfortunately this didn't work for me. I'm using a 16GB Class 4 Sony SDHC.

    I also tried - format /FS:FAT32 F: - in cmd prompt. Apparently my SD Card is formated as RAW (really?) and it has 0M (0 mb) space available. Then 'Cannot format. This volume is write protected.' Not true. I have a switch, but I've tried both options. so currently my SD Card doesn't work and I'm sad. Apparently this issue is occuring fairly often.
Ask a new question

Read More

Sandisk Format Windows 7