Sign in with
Sign up | Sign in
Your question

Windows XP\Lexmark problem

Last response: in Computer Peripherals
Share
September 4, 2005 6:57:19 PM

I recently bought a USB Lexmark X1190 all-in-one. It installed on my Windows XP Pro with no problems and works great. However, as soon as I restarted my computer, Windows re-detected the printer for some reason, and came up with a "Found new hardware" message saying that installation could not be completed because a file was missing... it didn't specify which file though, and it was working fine before the restart. The wizard only has the "Finish" button available, and when you click it, it pops up again and again and...

I've tried re-installing the device several times, both over the top of the previous installation and also removing the device completely, uninstalling all its software and drivers, etc. and yet every time I restart after a sucessful installation, Windows seems to think its not done yet and can't find this mysterious file! There is no way of getting the wizard to check the installation CD... just the "Finish" button, which brings the same box up no matter how many times you press it. Despite this message that won't go away, the device works perfectly well, and Device Manager reports no issues.

In desperation, I installed the printer on another XP Pro machine, and it worked and restarted fine, no problems. It seems something on my main XP Pro machine is making Windows think that installation is not complete.

Any suggestions?
September 7, 2005 12:06:35 AM

Is that machine an AMD based one?

..this is very useful and helpful place for information...
September 9, 2005 9:32:57 PM

My guess is that your printer install bombed because the printer install routine could not find some required dll.

Had similar experiences twice. Printer driver assumes it can find required dll on your computer. Dll may be moved, changed, or maybe was never installed. Have you called Lexmark tech support?

Its likely that the required dll is on yout windows install disk cab files or easily downloadable on the internet. Scant help if you don't know what dll is required.

In my case the printer software did identify the missing dll's. But that just a first step. Had to work with tech support at hp and lexmark and get hours of help getting the printer driver to grab the required dll from either the original OS install disk cab files or the internet.

The bottom line is that the printer manufacturers blame microsoft windows and say its a "windows problem." Something I don't buy.------I believe its the fault of a clunky and poorly written driver. A driver that needs to be idiot proof and able to recover from presisely those missing dll problems. And be able to pull these missing dll's automatically from the cab files or the internet. Having endured the hours of pain it took to force the printer driver to get the missing dll's now twice I have a new personal rule.

If the printer driver does not install correctly I will make
exactly one call to tech support. If tech support tries to charge me or tells me its a windows problem I take the printer back for a full refund. If the tech cannot help me promptly, I take the printer back for a full refund. Without a correctly installed driver a printer is worthless. Its not worth my time---I finally got both printers working but ultimately replaced both printers for other reasons.

If the manufacturer cannot design a printer driver that installs correctly all the time, its a defective driver and defective manufacturer. Accept none of this its a windows problem. Its their fault not yours.
September 10, 2005 10:09:50 AM

thanks to anyone who tried to help. unfortunately none of your solutions were helpful. i fixed it myself.

it turned out that the installation had indeed bombed the first time i installed it... no file was actually missing, it was a registry key in HKLM/Software/Microsoft/Windows/CurrentVersion/. the RunOnce key had been accidentally deleted, hence every time the PC detected the printer, it could not complete the installation. Because this key should not have been deleted in the first place, no amount of re-installing drivers etc would restore it. I discovered that this problem can happen at any time to any piece of hardware, so watch out. It wasn't the Lexmark installer's fault... as stated, it installed fine on an identical machine downstairs. Neither was it Windows. It's just one of those things. The solution was simply to create a blank key under that registry path, and then plug the printer in again. Windows found the key it needed, and added whatever info it needed to complete installation. Everything now works fine. In fact, the scanner side of the device even works when the device is not turned on! (The X1190 cannot function as a standalone copier, unlike its bigger brothers).
!