Sign in with
Sign up | Sign in
Your question

Rebel XTi Won't Focus

Last response: in Digital Camera
Share
May 5, 2010 6:16:59 PM

GRRRRRRR! I've tried everything I've found online so far. . . it acts like it is focusing, but only the focus sensor on the left of the screen turn red and when I open the pics they are fuzzy. HELP!

None of the buttons on the right next to the screen seem to respond when I push them either.

Thanks for the help!

More about : rebel xti focus

June 8, 2010 6:05:22 AM

Sounds like you've chosen a manual focus point.

Here's a checklist to go through:

Check that the switch on the lens (not the body) is set to auto focus and not manual.

Remove the camera battery and put it back in.

Put the camera in full-auto mode and aim at something directly in front of you (make sure it's the object closest to you). If the camera does not lock on to that object then something might be wrong.

Try using the focus point that does light up to focus on a particular area and see if that's in focus (the rest of the picture may be blurry). If it is in focus, then at least the auto focus is working on that focus point.

Try another lens and see if you have the same problem.

Put the camera in P mode.

See if you can change the focus point by pressing the button in the top right-hand corner and then the arrow keys next to the screen.

If all that fails, try updating the firmware.

If still doesn't work then have the body serviced.


Hope it helps.
Bo
!