Sign in with
Sign up | Sign in
Your question

Problem formatting sd card

Last response: in Digital Camera
Share
Anonymous
June 14, 2010 12:26:55 AM

Hello,
i bought a 4gb "traveler" sd memory card. I formatted it on my computer, but when I put it in my camera (Kodak LS753) it indicates it needs to be formatted. I push the buttons to format, but it always go back to "must be formatted". it looks like it is formatting, but it always lead back to "need formatting". Any suggestions?
June 16, 2010 6:23:47 AM

I purchased the same, windows 7 could see it and said it was formatted, Ubuntu could not see it, my PVR could see it but not show a folder. Tried to re-format it with windows 7, it did that but Ubuntu still could not see it, reformatted again windows said problems, then could not read the card at all, all though it could see it. Eventually reformatted using win 7, then tried to copy a file to it (twice) twice failed. I think these cards have some type of program in the root directory as in windows they show a special icon, not just a generic removable drive icon. IT goes back to where i purchased it and i will be asking for my money back.

Brian
m
0
l
!