Audio over TV problem using HDMI cable

Hi, not sure if this is the right place to ask this, but here goes:

I've spent hours and hours browsing sites and forums hoping for a solution, and keep thinking im on to something, but still no luck. I've noticedd a lot of good responses from this site, so hope for a bit of luck :D

I'm attemping to hook my LG LCD TV to my PC (with windows xp 32-bit). I've attempted dvi to HDMI cable with seperate audio cable, and now moved on to HDMI to HDMI cable (using supplied dvi-hdmi dongle that came with gfx card).

However, I can only manage to get picture and no audio. I'm using GTX 280 and a Asus P5Q Pro, which i've connected using a SPDIF connection. I've set output to HDMI audio in the BIOS, but still nothing & in my Realtek Audio Control Panel the digital output bit is greyed out.

The bit I belive is the problem (tried countless solutions) is that in sounds & audio, the only device is Realtek Audio Output, i cannot select HDMI, or SPDIF (they don't appear at all).

I have latest drivers for nvidia graphics card + realtek audio drivers.

Going crazy here, nothings seem to work. Appreciate if anybody can help

Thanks, Sharpey
7 answers Last reply
More about audio problem hdmi cable
  1. shameless bump, still can't get this working :(
  2. Okay, so, I'm so not even close to computer savvy but I had the same issue with my TV/PC hook up. Nothing I did with HDMI cables worked at all. My TV came with a VGA hook up on the back which is what I ended up having to use. But after all the nonsense with the HDMI cables my realtek had put digital audio as my default so I had to go back in, hook up normal speakers and set the speaker setting as the default before I could hook up the audio to the TV...

    But of course I had to spend an additional $30 on those cords... I hope this helps, and I'd like to know if you ever figure out the HDMI cable thing because it would save cable room behind my TV, lol.
  3. Maybe you have seen this already but Nvidia has a fairly detailed answer regarding no audio output....maybe it will help.

    hmm, the URL is obnoxiously long so I will copy and paste.

    Question
    I have connected my GPU to my DLP and I cannot get audio on my television’s speakers. How do I fix that?
    Answer


    This issue could be caused by a few things, so its important to describe the different ways to connect your GPU to your DLP.

    Using the HDMI connector on the GPU to plug directly into the DLP HDMI input

    For this configuration, check to make sure that you have connected the S/PDIF connector from the motherboard to the GPU. Please check with your motherboard manufacturer to ensure it has the correct S/PDIF connector.

    If your motherboard does not have a S/PDIF connector and you wish to use the analog output on your motherboard to connect to the DLP, follow the instructions in Using the DVI connector on the GPU to plug directly into the DLP below.

    Using the DVI connector on the GPU to plug directly into the DLP using a DVI to HDMI adapter

    3D Vision ships with a DVI to HDMI connector that can be used to connect to the HDMI input on the DLP. In order to connect analog audio from your PC to the analog input on the television to use the television's speakers, follow these instructions:

    1. Download the 3D Vision DLP Hotfix.

    · Windows Vista 32-bit DLP Hotfix

    · Windows Vista 64-bit DLP Hotfix

    2. Connect your PC's analog audio into the analog input on the back of your DLP. Mode DLPs use left and right RCA audio inputs so you will likely need a cable called "3.5mm Stereo Headphone To RCA Adapter Cable" to connect your PC to the DLP.

    3. Run the 3D Vision DLP Hotfix. Make sure you are running this as an Administrator on your PC

    4. Follow the onscreen instructions to disable HDMI audio. Note that this DLP Hotfix will also toggle the HDTV Resize Desktop compatibility mode. For more information on that mode, please read this Knowledge Base article.

    5. Reboot your PC.

    6. If your DLP requires any changes to its settings, use your DLP remote to configure the audio input.

    7. Start up your media player and adjust the volume to a comfortable level.

    answer taken from Nvidia's knowledgebase at http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_alp.php
  4. Cheers for trying to help, but the fix you linked to is for Vista only - I am currently using windows XP.

    Unfortunately, I'm still unable to select HDMI audio output and have such still not fixed my audio issue.
  5. Sharpey said:
    Cheers for trying to help, but the fix you linked to is for Vista only - I am currently using windows XP.

    Unfortunately, I'm still unable to select HDMI audio output and have such still not fixed my audio issue.


    Even i was facing same problem but i tried from one of website i found using googling. They had provided following solution which worked for me
    In Control Panel, navigate to Sound and Audio Devices ->Audio tab.

    Select Realtek HD Audio output and click 'Volume'
    Speaker dialog will open. Then Go to Options -> Properties
    select Mixer Device as any HD related audio and click OK.
    That's it. Its done. Check with audio if its working

    For more help visit following link
    http://acer--uk.custhelp.com/app/answers/detail/a_id/3417/~/configuring-a-pc-to-send-audio-via-hdmi-in-windows-xp
  6. This problem happens because of OS have conflict between two different HDMI ports such as onboard Intel HDMI port and another GPU HDMI port. This conflict leads to leak of sound signal that OS doesn't recognizes.

    I have perfect tricky solution for this situation.
    (1) First of all Remove your graphics card from your PC.
    (2) After that Attach your home theater or TV's HDMI cable to your Intel (or on board) HDMI port. If you have Monitor that has DVI Port that attach it. If display doesn't come on boot.
    (3) Star your Computer with Internet connection if you have.
    (4) Your OS will automatically update driver as it suits. and You must have to uninstall all your NVIDIA Drivers entirely.
    (5) Now Download latest driver for your on board graphics from its manufacturer's site and install it.
    (6) Restart your Computer and DO NOT INSERT YOUR GRAPHICS CARD AT THIS MOMENT.
    (7) Your sound may or may not come out of your TV. if not than just remove HDMI cable from back panel and re insert it even if your computer is ON.
    (8). try to play or test your TV now it 100% playing sound.
    *** BUT I KNOW YOU WANT AUDIO FROM YOUR GRAPHICS CARD, NOT FROM ON BOARD ****
    SO
    NOW,
    (9) Shutdown your computer and insert your graphics card. and attach all your home theater or TV to it.
    (10) Boot into BIOS. and if your BIOS has option to choose or enable disable graphics adapter than your graphics card will be primary and your on board should be choose "always enable".
    (11) Save your BIOS settings and restart PC.
    (12) As PC Restarts install graphics driver from windows update not from driver provided from CD or website.
    (13) After installation completes. Restart your PC. disconnect your HDMI Cable and reconnect it force fully.
    (
    ITS DONE.
    YOUR SOUND IS NOW ALL OK.!!!!
  7. I just hooked up my comcast HDTV box to my TV, I had picture but no sound.
    What is not included in the comcast box is a 2 way cord with a red and white end. (I used one from my VCR, it has red, yellow, and white ends so I just used the 2 I needed and left the yellow hanging) Next to where you insert your HDMI cable in the TV should be 2 holes for the cord, then plug the other end directly in the cable box next to AUDIO. I have an older TV (2007)

    Hope it helps
Ask a new question

Read More

HDTV Audio HDMI Cable Home Theatre