Sign-in / Sign-up
Your question

Inspiron 1200 + internal HDD help?

Tags:
  • Dell
  • Laptops
  • Hard Drives
  • Computers
Last response: in Computer Brands
January 26, 2010 8:25:35 PM

I'm having an issue working with a Dell Inspiron 1200 laptop and its internal HDD.

I was originally asked to look at the machine for a friend. He claimed it had been running "slow" and everything he tried didn't seem to help. (This laptop had Windows XP 32 sp 3 installed, fyi.) I'm not sure what this entailed, but deduced he defragmented the hdd, ran a disk cleanup, and ran a virus check with "windows defender" (<- I'm not familiar with that antivirus.) at the least. When I booted the machine, it literally took 20 minutes to load from the XP logo screen to a usable desktop. This immediately struck me as something more than just an "old" or "full" machine. I was told someone had tried to reformat windows on the machine, but wasn't familiar with the process, so they didn't load drivers or some such. The gentleman who asked me to look at it said he was able to get all the correct drivers loaded, but that was when it began running slow.

From working with the machine for 15 minutes or so, I was finally able to look at what was on the c: drive. Not only was 32 of the 34 gigs in use, but the drive was also set to compress all files. After looking at the few programs/folders shortcutted on the desktop and in the start menu, what was running in the taskbar at startup, and the programs installed on c:, it didn't appear as though 32 gigs could be used for this. I asked the owner and he confirmed that he highly doubted there could be 32 gigs worth of anything on the laptop. I decided that even if the owner prefer I did not backup his files and reformat, that I would just in case.

I removed the laptop's HDD and was in the process of attaching it to my desktop when something happened. I have a 2.5"-3.5" IDE adapter and in the process of plugging the adapter's molex to one of mine, my desktop restarted. Probably an elementary mistake, but I had been doing these types of HDD transfers before with the desktop still on, but I recently had to revert back to a slightly older mobo/cpu/ram generation. I figured this happened b/c I didn't set some jumper correctly on the laptop HDD. I tried hooking up the laptop's hdd with no jumpers, then the jumper set to slave, and then the jumper set to cable select and in each instance, my comp was unable to detect the laptop's hdd.

I went to put the hdd back into the laptop and now the laptop is no longer recognizing it. I'm getting a message saying "no bootable device found, press f2 for set up". I check the bios and yeah, it's not seeing the hdd. I tried again hooking it up to my comp, but even my bios was no detecting the hdd.

I wrote on here (sorry for the story, but i felt it relevant) because I'm concerned if I somehow shocked the laptop's hdd to death or if the hdd could have honestly been on it's last leg and moving it between computer's was the straw that broke the camel's back.

I have a number of diagnostic programs that I can run on the hdd, but one of the motherboards, either my desktop or the laptop, would need to recognize the hdd first.

If it helps at all the model of the laptop's hdd is Fujitsu model: MHT2040AH, rev .A00.

Thanks for any insight provided and I apologize for the length!

More about : inspiron 1200 internal hdd

a b D Laptop
January 26, 2010 9:58:34 PM

It may be worth a shot to try an external enclosure.
m
0
l
January 27, 2010 8:35:25 PM

more than likely you put the HDD on the connector backward and sent +5 v down the wrong pins- it is visible on the PCB usually, as a dark spot. sometimes its just the fuse/diode on the hdd and can be repaired, but often its gone.
Q: is the drive spinning?
m
0
l
Related resources
January 27, 2010 8:58:48 PM

A: yes, the drive spins

The connector is an IDE connector, both ways, so it's missing that single pin in the middle of one of the rows on both the male and female end, and on the drive itself. Unless I broke off the corresponding pin on the hdd (which I just checked and I hadn't), I don't see how I could have connected it backward.
m
0
l
February 1, 2010 12:17:49 AM

Unlicensed_bus_driver said:
A: yes, the drive spins

The connector is an IDE connector, both ways, so it's missing that single pin in the middle of one of the rows on both the male and female end, and on the drive itself. Unless I broke off the corresponding pin on the hdd (which I just checked and I hadn't), I don't see how I could have connected it backward.



OK, Just asking, b/c I have done it a while back , as my adapter didnt have the safety key... The fact that it spins is a good sign.. Would try it in external bay or a differnet IDE Adapter device..
m
0
l
Anonymous
a b D Laptop
February 14, 2010 2:59:43 PM

not sure if it will help but my dad was working on my sisters dell inspiron 1200 and it stopped recognizing the hard drive, the laptop has other MB problems so we figured the IDE BUS went out so i told my sister i would see what i could do and that i would at least get it to boot off a flash drive(sorry for the story but relevent) well i took the laptop home and tried to get it to boot off the cdrom drive and it wouldn't boot well this was a dvd-rom drive that was 3 months old cause i had allready replaced it. so i pulled the hard drive to see if that was causeing the prob and it still didn't work so i pull the dvdrom and then slid it firmly back into place and it worked so just for giggles i slid the hard drive firmly into place and like magic it worked. sorry for the long story but apparently the dvdrom screw was not tight and the dvdrom had loosened causing the ide controller to freak and not recognize any of the drives. You might try pulling the cdrom/dvdrom and the hard drive and then seating them firmly into place.
m
0
l