Sign in with
Sign up | Sign in
Your question

HeadSETS

Last response: in Other Consumer Electronics
Share
May 8, 2010 2:59:39 PM

Hey!

So, I've owned a couple of cheaper headsets in the past with good microphones and reasonable sound quality (but not exactly directional quality). Now I own the "Steelseries Siberia Full-Size Headset" (V1) (http://www.amazon.co.uk/SteelSeries-Siberia-Fullsize-He...).


The headset has one huge problem however, and perhaps a second (recently). Firstly, the microphone that came with the SteelSeries Siberia Fullsize Headset means few people online can hear me; everyone on Skype that talks with me regularly actually needs to change their settings to hear me (this is with talking normal, I'm not a quiet guy) in or outside of games. p.s. it's shocking that it says "uni-directional" with this headset, it make's me think the V2 ("much improved") with "uni-directional" is just as poor - a few user reviews even say it's still on adequate for non-gaming chat.

Secondly, surround sound interests me, this headset simulates that well enough though, still the best audio I've ever had - but now I see certain headsets (http://www.turtlebeach.com/products/efhpa2/home.aspx) which as far as I know are vastly superior? I'm unsure but that's just something I'd like people to voice their knowledge on if they can (without bias).



So, microphone strength is important to me, and audio quality is something I am willing to pay for - but there seems to be no good balance that I can find with comfort, microphone quality and audio quality.

If there's a forum with people who know about this, I know this is it.

More about : headsets

May 9, 2010 4:05:19 AM

first, what OS are you using, second does your computer or sound card have HD sound, there is a mic boost button in the controls somewhere depending on the OS where it is, is different, if you need additional help PM ME
May 9, 2010 12:51:45 PM

I have Windows 7. I've always needed (or chose) to use Mic Boost on microphones on other OS's, but on W7 I believe mic boost is "recording devices">(select microphone)>properties>levels (tab). I have this at 100.


I believe my soundcard (Creative X-Fi Xtreme Music Vista) has HD sound. I uninstalled (by accident) several Creative programs which installed via an update, but don't know how/where to get them again. In "Programs + Features" I only have "Creative Audio Control Panel" and "Creative Sound Blaster Properties x64 Edition" remaining - there used to be 6 I think.
For the 1 day that I had those programs by Creative, I didn't test the mic quality but I doubt it was affected at all.
Anonymous
June 23, 2010 8:13:22 PM

Sorry for the delay but I just stumbled upon your post. Is this still an issue?

All available Creative Labs drivers and applications for 64-bit Windows 7 as of this writing (6/23/2010) are here (if this is removed just Google "creative 64-bit x-fi drivers" and take the first relevant link on Creative.com):

http://support.creative.com/downloads/welcome.aspx?nLan...

Here's some info about my setup, which I think is similar to yours:

I have Windows 7 Ultimate 64-bit with a SoundBlaster Elite Pro too, and I use a headset when gaming and desktop mic and 7.1 surround speakers all other times (for hands-free Skype and general use). My Creative Fatal1ty HS-800 analog (NOT USB) headset is plugged in to the front of the Elite Pro break-out box: Headphones in far left jack and mic into the "Line In 2/Mic In 2" jack. The el-cheapo hands-free desktop mic from my box-o-junk (left over from previous builds) is plugged into the mic input on the sound card itself inside the PC.

When I right-click Windows 7's speaker icon in the Notification Area (formerly System Tray) and select "Recording devices", the Sound dialog box appears with the Recording tab selected. There are several devices there that I don't use, so I've disabled them and then right-clicked and selected to not show disabled devices. The only two remaining entries are "Line-In 2/Mic 2" and "Microphone", corresponding to my headset mic and the desktop mic, respectively.

In Windows 7, one of these devices can be made the default for communications program(s), and a different one can be made the default for all other voice-enabled programs. I've got my desktop mic set as the default for comm (I use Skype), and the headset mic set for the normal "default device". I get a little green icon of a checkmark next to the headphone entry, and a little green icon of a phone handset next to the desktop microphone entry. Note you can click the drop-down portion of the "Set Default" button at the bottom of that dialog box or right-click each device to choose "Default Device" or "Default Communications Device" for each mic.

The reason I set them up this way is that Skype (again, the *only* program I use with the desktop mic) has its own mic selection setting. It can override the system default (my headphones) for its own purposes whenever it is active. OTOH, none of my (few) games are multi-mic aware, and as they don't allow a specific mic selection they all use the system default which is the headset's mic. Further, I work at home during the day where there's little background noise when I'm on the phone, but at night when I fire up some games I don't want the background noise of kids and my clackety Northgate OmniKey keyboard competing with my voice as I'm trying to kill some zombies.

OK. In the Properties for the headset mic, there is only one setting on the Levels tab, which is the mic level itself. However, in the Properties for the desktop mic, there is an additional tab labeled "Custom" where you'll find a "Microphone +20dB Boost" checkbox. Check it and your problem should be solved.

I've also installed the 64-bit Creative X-Fi drivers and application programs for the card itself. Their "Volume Panel" application contains a Mixer tab where you can select your main recording device and set the input levels for that and all other input devices (i.e., aux, line-in, midi synth, digital in, line-in 2/mic 2, s/pdif-in, etc.). If that's the "Microphone" entry (corresponding to the mic input on the back of the sound card itself, not on the breakout box) you should get a little "+" icon above the input level slider. Click that "+" to enable the "Microphone +20dB Boost" setting.

These two "+20dB" settings seem to be the same, in that checking one will automatically check the other, between the Creative app and the Windows Sound applet.

Hope that helps, and good luck!
!