Sign in with
Sign up | Sign in
Your question

Kodak easyshare Z1275

Tags:
  • Point & Shoot
  • Kodak
  • Cameras
Last response: in Digital Camera
Share
October 3, 2010 9:20:00 PM

OK, folks here goes, my sister-in-law dropped her camera and asked me to look at it. It will power on and all the buttons except the shutter button work. If you remove the back and try it all the buttons work OK. Any ideas of the how to fix said problem. Thanks.

More about : kodak easyshare z1275

Anonymous
October 3, 2010 10:59:24 PM

I can only suggest going into the setup menus and select restore defaults (or similar)
m
0
l
October 11, 2010 12:13:54 AM

Quote:
I can only suggest going into the setup menus and select restore defaults (or similar)


I'll give it a try, thanks.
m
0
l
Related resources
October 11, 2010 12:34:24 AM

Tried it didn't work, still need help......
m
0
l
Anonymous
October 11, 2010 4:53:22 AM

"If you remove the back and try it all the buttons work OK"

Does that include the shutter button ? Normally on top, not back.

m
0
l
October 11, 2010 6:02:19 AM

Quote:
"If you remove the back and try it all the buttons work OK"

Does that include the shutter button ? Normally on top, not back.


Yes, the shutter is on top and it will work with the back removed, this leads me to believe that something bent but I can't figure out which way, up or down.
m
0
l
Anonymous
October 11, 2010 6:29:54 AM

Not much I can do from here.

Suggest you try ringing Kodak (if in US) as I gather they can be quite helpful -- though usually in these things you need to get lucky and find a smart and generous tech guy.
m
0
l
!