Sign in with
Sign up | Sign in
Your question

SPDIF problem!

Last response: in Components
Share
May 28, 2005 11:32:13 PM

i have an onboard soundcard, its an Epox EP-8RDA3 motherboard,
and the soundcard is a Six Channel Audio with analog and digital output using Realtek ALC655 AC'97 Codec (v2.3 compliant), Nforce 2 chipset.

i have this problem with it, it basicly works fine, i connnected it to my speakers using the SPDIF out and not the analog out so i would get 5.1 channels,
and i also connected my cable box to the analog LINE IN connector in the back of the motherboard. but i can NOT hear it through the SPDIF Output.

when i connect headphones to the analog output, it works fine, but there is not Line-In output through the SPDIF.

since i already have something else connected to my ANALOG speaker input, i cant connect it too. so this must work.

i tried upgrading drivers, but none solve this issue. can it be solved?
i'm tired of always using headphones when i watch tv through my computer
i'm not looking for sorround sound, just basic stereo output through my SPDIF connector.

if you still dont understand what the problem is here's a little diagram:

CABLE BOX --analog--> MOTHERBOARD~LineIn ___> MOTHERBOARD~SPDIF ---digital--> SPEAKERS


and it doesnt work.

waiting for an intelegent reply.

Thanks!

More about : spdif problem

May 30, 2005 9:38:02 PM

It seems your Realtek soundcard has been set to output only digital signals through the SPDIF not both analogue and digital. However this can be corrected by adjusting the sound card properties using the software provided by realtek.

Realtek soundcards come with a utility known as the Sound Manager and this can be located in the system tray with a blue square with four yellow semi circles and a yellow dot (a bit like the SRS logo in yellow on a blue background, if you know what the SRS logo looks like). Right click that and chose "Sound Manager" from the menu that appears. If you cannot find this icon by the system tray then look for the Sound Manager icon in your Control Panel.

Once the sound manager dialogue box appears click the SPDIF tab. Where it says SPDIF output click the dot which says Output Digital and Analogue. Once you have chosen these options click the OK button or if you are using the new version of the realtek sound manager click the close button.

Did that solve your problem?

PC Spec: AMD Athlon XP 2000+, ECS K7S5A Motherboard, 768MB SDRAM PC133, Sparkle nVidia Riva TNT2 M64 32MB AGP Graphics Card, Creative Sound Blaster Audigy 2 6.1, Windows XP
May 31, 2005 2:00:48 AM

no option like what you mentioned.
furthor more, i just got an email from Epox which says:

Dear Sir
The board design was no A/D function ,so the board audio was not support analog from line in and SPDIF digital out .

why is this happening??
Related resources
May 31, 2005 6:37:06 PM

Not too sure actually, I would have thought that everything sent out the line out socket would be duplicated through the SPDIF socket. :S

I am using a newish Epox motherboard manual as a reference (I intend to purchase this motherboard so I wish to learn how to use it before I purchase it so I can get started building the new rig once it arrives) and pictured is the new Realtek Sound Manager - What colour is the window? Is it a light blue colour or is it a standard grey/biege colour?

PC Spec: AMD Athlon XP 2000+, ECS K7S5A Motherboard, 768MB SDRAM PC133, Sparkle nVidia Riva TNT2 M64 32MB AGP Graphics Card, Creative Sound Blaster Audigy 2 6.1, Windows XP
May 31, 2005 6:47:14 PM

first of all, thanks for the response.
the window is called the AC97 Audio Configuration
and is standard windows gray/white.
it has the following tabs: Connector sensing, HRTF Demo, Microphone effect, General, Sound Effect, Equalizer, Spaker configuration, Speaker Test, SPDIF/in.

and yes, i looked in spdif/in, infact i looked everywhere, but there is no option like you mentioned..

what do you think?
May 31, 2005 10:55:26 PM

What options are availible in the SPDIF tab then? In fact what optins are availible on every tab? It seems you have the older Sound Manager window which came before the new type which supports up to 8 channel audio.

Have you tried looking in the volume control? Go to the Options menu and then click Properties. Ensure that all the boxes below are ticked so that all the volume sliders are showing up. Also ensure that the advanced options under the options menu has a tick so that you have access to the advanced option in some of the sound cards' source. If you can tell me what options you have in your volume control and what the advanced options consist of.

PC Spec: AMD Athlon XP 2000+, ECS K7S5A Motherboard, 768MB SDRAM PC133, Sparkle nVidia Riva TNT2 M64 32MB AGP Graphics Card, Creative Sound Blaster Audigy 2 6.1, Windows XP<P ID="edit"><FONT SIZE=-1><EM>Edited by marshahu on 06/01/05 00:22 AM.</EM></FONT></P>
May 31, 2005 11:11:48 PM

its kind'a wierd, i have 3 boxes that read:
Status: UNLOCK
Sampling Rate: ----
Data Validation: -----
then a check box that says [ ]Ignore
then another checkbox that says: [V] Real-time S/PDIF-in Monitor
and next to the "UNLOCKED" there is also a button that says "AUTO LOCK"
i tried changing everything there. nothing works.

how do i get the new version of this menu?
June 1, 2005 8:21:35 AM

Hmmm very strange options, it seems you only have options for the SPDIF input, when you want options for SPDIF output. I'm not too sure how to get a new version of this menu - the best I could find is this link. However double check with Epox that their m/b sound card will support it:

http://www.softwarepatch.com/utilities/ac97.html

PC Spec: AMD Athlon XP 2000+, ECS K7S5A Motherboard, 768MB SDRAM PC133, Sparkle nVidia Riva TNT2 M64 32MB AGP Graphics Card, Creative Sound Blaster Audigy 2 6.1, Windows XP
June 9, 2005 5:25:41 PM

Quote:
Dear Sir
The board design was no A/D function ,so the board audio was not support analog from line in and SPDIF digital out .


Unless they are lying what you want to do is impossible for your soundcard.
a b V Motherboard
May 16, 2011 7:15:56 PM

It looks like Realtek doesn't have an analog to digital function built in, in which case there isn't much you can do.

Just in case, check the Windows Control Panel, and make sure the SPDIF output is set as the default output device, and the line input is set as the default input device. Farther, on the default input device, right click and open properties, and if there is a setting for "listening" or anything else of the sort, enable it.
May 16, 2011 9:32:48 PM

Done all that and I can get it to play with "listen to this device" but that has a lag of about half a second so the circuitry and the codecs exist....it seems to be "muted" for the audio input whereas when you re-routed to the analog side it works, very strange .....

I have uploaded another picture via this link

http://www.manikata.com/it/realtek/realtek.htm ...at the very end.

I bet there is a registry setting to mute the input ....!!!!! :hello: 
Thanks for thje reply by the way ...it always is great to have some feedback.


Frank
!