Sign in with
Sign up | Sign in
Your question
Closed

Audigy 2ZS compatibility with Windows 7

Last response: in Windows 7
Share
September 29, 2012 4:46:29 AM

Hello,
I am a hobbyist, I plan to upgrade the OS of my music production desktop from Windows XP SP2 to Windows 7, would the current Audigy 2ZS soundcard be compatible with the new OS? Thanks - Rickem
July 14, 2013 2:05:03 AM

noidea_77 said:
Easy to find out! Goto http://support.creative.com and search for win7 drivers. (took me 15 seconds to find out)


I am having the same "problem" with the Thread Starter. I am also running a Windows 7 Pro (64-bit) OS PC. Unfortunately, I did visit the support page of Creative and I downloaded the existing drivers (SBAX_PCDRV_LB_2_18_0017.exe), which is the latest for the Audigy series cards, according Creative. I tried to run it, but after a few seconds, I received a message on my screen, saying:

Setup is unable to detect a supported product on your system. Please ensure that your product is properly installed before running this setup program. Setup will exit!

Then I thought that perhaps the previous drivers would be OK, so I downloaded and tried to run those (SBAX_PCDRV_LB_2_18_0011.exe). The same message appeared again.

Finally, I tried to install and run the drivers on the accompanying CD of the card itself, although I knew that these would not be the appropriate ones. Same results!

I don't think that there is something wrong with the card itself, because as soon as it was installed in an empty PCI slot in my PC, it was immediately recognized by the OS, which tried to install drivers through the Windows Update wizard, but naturally it failed, asking the user to install them manually.

Is there any other drivers that would be the appropriate ones for this card and for Win7 Pro64? Or is there any other solution or trick that would make it operational?

Thanks
-
July 14, 2013 8:41:03 AM

After various shut-downs and restarts of the PC, which had nothing to do with the problem, after one day, I tried again to install the drivers and - for an inexplicable reason - they were finally installed, the card was recognized by the OS and it is now working perfectly alright.

Thanks again for your attention.
-
!