Sign in with
Sign up | Sign in
Your question

Reboot after shutdown - only on Windows 7

Last response: in Windows 7
Share
September 30, 2012 2:42:01 PM

Hi

I have a problem that has been driving me crazy for a while. After a power cut, my pc started booting itself back up again after completely shutting down (2-3 secs) from Windows 7. I'm also running Windows 8 and this shuts down no problem so after months of putting up with it I re-installed Window 7 and the problem disappeared - pc shut down fine and stayed shut down.

This was about 2 weeks ago and everything had been fine until another power failure today which has seen the problem return, again only in Windows 7. I have tried everything I have found trawling the forums for others with a similar problem, including disabling wake-on LAN in bios, updating bios, unchecking 'automatic restart' under system failure in startup and recovery options and changing the value of PowerdownAfterShutdown from '0' to '1'/'1' to '0' in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

So I'm stumped. The effects of the power cuts definitely seem to be causing these symptoms as both times now this problem has started immediately afterwards. I'm also thinking it's something that should be fixable within Windows 7 since Windows 8 still shuts down without any problems. I really don't want to have to do another re-install, especially since the problem is likely to come back the next time the power goes off.

Any thoughts or ideas would be greatly appreciated!

Cheers
September 30, 2012 3:12:52 PM

There is this option in BIOS which tells the mainboard what to after power loss.
Most likely it is to be found on Power Management page. Look for something like AC power loss restart, AC power failure, PWRON after PWR-failure etc.
Try to disable it.
September 30, 2012 4:16:10 PM

There was an option in BIOS called 'AC Back Function' which was set to 'Soft-Off' which apparently meant that it should stay off when the power comes back on. Changed this to 'Memory' just to see what happened as not sure what this setting does. Anyway problem seems to have gone away for now! Thanks Bejusek
Related resources
!