Sign in with
Sign up | Sign in
Your question

Remote Desktop and Application

Last response: in Windows XP
Share
July 26, 2005 1:01:31 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

I have an application designed in Delphi 7 and runs under Win XP. On the
Main form of the application, there is a Panel with a Image holder which has
a small BMP file. "Company Logo". It displays perfectly each when the
application is running and your viewing it from the local monitor, however,
using Remote Desktop, the image is not there and it's only a black hole
where the image should be. The only thing that fixes it, it to close and
restart the application while remote desktop is open.

This leads me to believe it's a refresh issue, however refreshing or
repainting the panel or image does not work. Since this application
actually runs on a headless system, and remote desktop is the primary means
of performing maintenance, it would be nice to fix this little bug.

Within this application there is a timer that update several items once per
second, I added Application Process Messages and also added the Refresh for
the image with no luck.

Any ideas what I need to do?

Thanks,
Richard
Anonymous
July 26, 2005 1:01:32 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

The only aspect I can think of is if the application is writing the image
directly to your video adapter. In such cases, the item is only visible
within the application. If you try to view the image(s) remotely, I would
expect you to see a black square and nothing more.

You do indicate closing and restarting the application while remote desktop
is open corrects the problem. That suggests soemthing else is the cause,
unless the application can somehow detect remote desktop and automatically
correct the display issue.

If the application is in fact writing directly to the video adpater, try
changing the Display hardware acceleration from Full to None.

--
Cordially,
Wayne H. Wilhelm
Personal Web: http://www.quadracalc.com


"Richard" wrote:

> I have an application designed in Delphi 7 and runs under Win XP. On the
> Main form of the application, there is a Panel with a Image holder which has
> a small BMP file. "Company Logo". It displays perfectly each when the
> application is running and your viewing it from the local monitor, however,
> using Remote Desktop, the image is not there and it's only a black hole
> where the image should be. The only thing that fixes it, it to close and
> restart the application while remote desktop is open.
>
> This leads me to believe it's a refresh issue, however refreshing or
> repainting the panel or image does not work. Since this application
> actually runs on a headless system, and remote desktop is the primary means
> of performing maintenance, it would be nice to fix this little bug.
>
> Within this application there is a timer that update several items once per
> second, I added Application Process Messages and also added the Refresh for
> the image with no luck.
>
> Any ideas what I need to do?
>
> Thanks,
> Richard
>
>
>
>
!