Sign in with
Sign up | Sign in
Your question

can't mount external HDD: mult. drives, OSes,cases

Last response: in Storage
Share
July 10, 2005 3:10:50 PM

tried everything i can think of to get my extra 2.5" drives to work as external devices. i have several 2.5" drives (IBM djsa-210 10Gb, Toshiba mk6021gas 60Gb, Hitachi 80Gb, Toshiba 80Gb), 2 enclosures (AddLogix FireXpress 250 firewire/usb2.0 and Ultra 2.5" USB 2.0), and multiple OS'es (XP Pro SP2, XP Home SP2, and Mac OS 10.4 on 4 different machines).

all of these drives are formatted (most are NTFS but i think one is FAT32) and work properly when i swap them out into my laptop--in fact, the ones that have Windows installed on them boot up fine and everything.

XP
--------------
when i plug in a device to XP, it recognizes the enclosure and the HDD model and installs all drivers as you would expect, giving no errors and finally giving the message "Your new hardware is installed and ready to use." however, nothing shows up in My Computer at all.

the HDD model is listed properly in Device Manager, and the enclosure is listed under USB devices. if i view the Properties of the drive, in the Volumes tab nothing is listed--when i click Populate, it gives me "Type: unknown, Format: Unknown," etc....as if the disk is not partitioned/formatted/etc.

in Computer Management, NOTHING shows up under Drive Management AT ALL. so there is no way to initialize, format, etc. it's as if the drive doesn't exist.

Partition Manager won't start because it says the "Partition Table is bad"--this only happens with one of these drives hooked up (i.e., it starts fine without them). when i run PartInNT or TestDisk it gives me nothing but errors on every sector--but it CAN see that the drive is there and how large it is. but it won't let me erase the MBR, format, etc...

(one of my XP Home machines has very very little installed on it so it's pretty clean and totally free of disk-medling apps--no Partition Manager, no Norton Ghosts/GoBacks, etc...it's just pretty much candy & Quicken.)

the drives are all set to Master (no jumpers), and i've tried setting them to Cable Select (jumpers on B & D, as specified for each model).

this behavior happens with either USB2.0, USB1.1, or Firewire. (however, one of my XP Home systems, which has Norton GoBack on it, does a HARD restart when i plug them in, both 1394 & USB.)

Mac OS 10
----------------------------
nothing. it's as if the drives don't exist AT ALL. nothing in Disk Util, although the USB listing in System Profiler can occasionally tell there's SOMETHING plugged in there.

with the jumpers set to Cable Select, the drives have a cycling access going on that just sounds like it's repeatedly trying to mount them with no success.


Tech Support
---------------------
AddLogix is a couple of years old so they won't even answer my emails.
Ultra (ultraproducts.com) has walked me through everything they can think of (their suggestions included the Cable Select part), and have just decided it's time for me to give up.


The Plea
-----------------------
i could just give up, but i've got so much time invested in this i'm desperate to figure out the solution. at this point it's more about the principle.

ANY ideas at all??
July 10, 2005 3:22:03 PM

Have you tried installing any of them after writing the drive to all 0s? In otherwords, no formatting and as close to a blank drive as you can get. Also, those that have data on them may be trying to list themselves as C:\ and conflicting with your OS drive.

....WW (5.1)
July 10, 2005 3:40:05 PM

thanks for your quick reply _WW_.

yeah i actually did try that, but very quickly--but it still wouldn't explain why a Mac would have trouble with it as well, would it?

i zeroed out a drive (the Toshiba 80 Gb that i mentioned) but had to box it up & mail it off before i was able to thoroughly test it. it didn't appear to be mounting, tho, but i didn't go through all the Device Manager areas, etc--but if you think this is very real possible solution i can try again with another drive. it just takes so long to do that i don't want to go through the trouble if there's only a remote chance that it will work.

the Mac factor makes me think it's not going to help, but i'm definitely not an expert so i'll certainly defer to your opinion.

thanks again.
Related resources
July 10, 2005 3:52:19 PM

I'm no expert either. I have a 3.5 drive in a USB 2.0 external enclosure. Seems to me all I did was reformat the drive to ntfs and install it in the enclosure. Disk management picked it right up and allowed me to assign a drive letter and partition it.

Never tried any of this with notebook drives.

....WW (5.1)
July 13, 2005 9:10:59 PM

oh man--i think i've just figured out the problem. unfortunately i'm no closer to getting it to work.

it's far too obvious: when they were my laptop drives i had put a password on them, and never took them off. it just never occurred to me, since when i boot up with them i just instinctively type in the password.

unfortunately since this comes WEEKS into trying to get the drives to work i think i've somehow managed to corrupt the password, or something similar. not evern sure that's possible.

one of the suggestions i had gotten from another forum was to use TestDisk to wipe it, including the MBR, etc...it never really worked properly (surprise surprise, now that i've figured out why), but is it possible that in doing that i somehow managed to erase any possibilty of getting this thing to work? that is, did i somehow manage to corrupt the HDD password?
!