Sign in with
Sign up | Sign in
Your question

Memory card locked

Last response: in Digital Camera
Share
April 5, 2011 10:59:35 PM

Hello,
I have a Canon Powershot SD1000 Elph. The Canon Memory Card SDC-32M works fine but I also have 3 other cards that all say "Card Locked" ....I've moved the switch but nothing changed..it still says Card Locked ..
Please help

More about : memory card locked

October 3, 2011 4:05:58 AM

It might be a format problem. I don't have the same camera but when I tried to use an SD card in my Finepix S1800 I got the same error. It also wouldn't let me format it in the camera saying "Card Protected" even though I checked the card many times and it wasn't locked.

I searched the internet for a solution and the thing that worked for me was to use a card reader and format the card as NTFS with my desktop (it was originally formatted FAT32). I couldn't do this directly with Windows XP because it would only give me the option for FAT or FAT32, so I used Partition Wizard (other partition managers should work too). PW allowed me to format the SD card as NTFS - this will erase the card (!) so make sure it's empty or you've saved everything on to your computer's hard drive - and after I put it the the camera, it now said something like "Memory card isn't initialized." When I went to the format menu in setup, it let me format the card and it's worked fine ever since.
m
0
l
!