XP SP2 will not install

Archived from groups: microsoft.public.windowsxp.general (More info?)

Running XP Home Edition. I run SP2 setup. It does it's inspections and the
last text I see displayed before it gives me "an internal error occured" is
'checking product ID.' I checked the numerical product ID and it does not
match those as listed as Pirated. This computer has several issues and really
should be reloaded, but the user has 'misplaced' the CD's that came with the
system. Below is the latest attempt at running SP2 according to my
svcpack.log. Anything stand out to anyone else?
svcpack.log:
4.578:
================================================================================
4.578: 2005/07/26 15:28:52.250 (local)
4.578: c:\686eeef5900a09c58a\i386\update\update.exe (version 5.5.1005.0)
4.609: Service Pack started with following command line:
5.062: Return Value From OnACPower = 1
5.062: OnACPower returned value( 0x1 ) which is Equal To 0x1
5.062: Condition succeeded for section OnACPower.Section in Line 1 of
PreRequisite
5.062: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\WindowsFeatures is
not Present
5.062: First Condition in A6Block.Section Succeeded
5.062: Condition succeeded for section A6Block.Section in Line 2 of
PreRequisite
20.843: DoInstallation: CleanPFR failed: 0x2
20.890: SetProductTypes: InfProductBuildType=BuildType.IC
20.937: SetAltOsLoaderPath: No section uses DirId 65701; done.
21.796: IncludeDirectoryIdFromInfSection: No DirId found for:
DontRemoveOnUninst.DirId
21.828: DoInstallation: FetchSourceURL for
c:\686eeef5900a09c58a\i386\update\update.inf failed
22.671: DoInstallation:SetupOpenInfFile for OldUninstallInf file
C:\WINDOWS\$NtServicePackUninstall$\spuninst\spuninst.inf not found: 0x3
22.671: CreateUninstall = 1,Directory = C:\WINDOWS\$NtServicePackUninstall$
36.734: CheckRegistryValue: RegOpenKeyEx for SOFTWARE\Microsoft\Active
Setup\Installed Components\{FDC11A6F-17D1-48f9-9EA3-9051954BAA24} KeyName
failed :0x2
36.750: Conditional load of section WindowsMessenger.Condition succeeded
96.812: BuildCabinetManifest: update.url absent
96.859: Starting AnalyzeComponents
96.875: AnalyzePhaseZero used 16 ticks
96.875: No c:\686eeef5900a09c58a\i386\update\updtblk.inf file.
103.531:
C:\WINDOWS\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem0.CAT
trusts inf c:\windows\inf\oem0.inf of device
PCI\VEN_8086&DEV_244E&SUBSYS_00000000&REV_81\3&172E68DD&0&F0
103.921:
C:\WINDOWS\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem0.CAT
trusts inf c:\windows\inf\oem0.inf of device
PCI\VEN_8086&DEV_24C0&SUBSYS_00000000&REV_01\3&172E68DD&0&F8
104.390:
C:\WINDOWS\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem0.CAT
trusts inf c:\windows\inf\oem0.inf of device
PCI\VEN_8086&DEV_24C3&SUBSYS_01601028&REV_01\3&172E68DD&0&FB
106.328:
C:\WINDOWS\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem1.CAT
trusts inf c:\windows\inf\oem1.inf of device
PCI\VEN_8086&DEV_24CB&SUBSYS_01601028&REV_01\3&172E68DD&0&F9
106.765:
C:\WINDOWS\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem2.CAT
trusts inf c:\windows\inf\oem2.inf of device
PCI\VEN_8086&DEV_2560&SUBSYS_00000000&REV_01\3&172E68DD&0&00
112.156: SetupVerifyInfFile failed with error 0x490 for oem24.inf of device
ROOT\SYSTEM\0002
121.593: OEM file scan used 24718 ticks
152.312: AnalyzePhaseOne: used 55437 ticks
152.312: AnalyzeComponents: Hotpatch analysis disabled; skipping.
152.312: AnalyzeComponents: Hotpatching is disabled.
152.312: Persisted hotfix directory is missing.
152.312: FindFirstFile c:\windows\$hf_mig$\*.*
152.312: Error getting find handle for c:\windows\$hf_mig$\*.*
158.343: AnalyzePhaseTwo used 6031 ticks
158.343: AnalyzePhaseThree used 0 ticks
158.343: AnalyzePhaseFive used 0 ticks
158.625: AnalyzePhaseSix used 282 ticks
160.203: Trying CheckVLKForBlock again
160.781: Error: CheckVLKForBlock failed
160.781: Inventory complete: ReturnStatus=536741199, 138953 ticks
160.781: Num Ticks for invent : 138953
169.328: UnRegisterSpuninstForRecovery, failed to delete SpRecoverCmdLine
value, error 0x2
169.328: DoInstallation: Failed to unregistering spuninst.exe for recovery.
169.375: An internal error occurred.
480.343: Message displayed to the user: An internal error occurred.
480.343: User Input: OK
480.343: Service Pack 2 installation did not complete.
499.296: Message displayed to the user: Service Pack 2 installation did not
complete.
499.296: User Input: OK
499.296: Update.exe extended error code = 0x1ffe054f
499.296: Update.exe return code was masked to 0x643 for MSI custom action
compliance.
6 answers Last reply
More about install
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Aolas wrote:

    > Running XP Home Edition. I run SP2 setup. It does it's inspections and the
    > last text I see displayed before it gives me "an internal error occured" is
    > 'checking product ID.' I checked the numerical product ID and it does not
    > match those as listed as Pirated. This computer has several issues and really
    > should be reloaded, but the user has 'misplaced' the CD's that came with the
    > system. Below is the latest attempt at running SP2 according to my
    > svcpack.log. Anything stand out to anyone else?
    > svcpack.log:

    <snip>

    Installing Service Packs
    http://www3.telus.net/dandemar/xpsp2.htm
    http://www3.telus.net/dandemar/spackins.htm

    Pre-Install, Install, Cleaning Up Afterwards
    http://forum.aumha.org/viewforum.php?f=45

    What to Know Before You Download and Install Windows XP Service Pack 2
    http://www.microsoft.com/windowsxp/sp2/sp2_whattoknow.mspx

    Get the Latest Updates and Information from Your PC Manufacturer Before
    Installing Windows XP Service Pack 2
    http://www.microsoft.com/windowsxp/sp2/oemlinks.mspx

    The hard disk space requirements for Windows XP Service Pack 2
    http://support.microsoft.com/?id=837783

    Free Technical Support for SP2
    http://support.microsoft.com/oas/default.aspx?ln=en-us&x=18&y=6&c1=509&gprid=6794&


    --
    Rock
    MS MVP Windows - Shell/User
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Thx Rock. However, believe it or not I did my research and eliminated
    everything you linked as a possible solution/issue. For sake of time and
    space I chose not to post every detail. I suppose I will just submit this to
    SP2 technical support.
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Aolas wrote:

    > Thx Rock. However, believe it or not I did my research and eliminated
    > everything you linked as a possible solution/issue. For sake of time and
    > space I chose not to post every detail. I suppose I will just submit this to
    > SP2 technical support.

    Ok good luck.

    --
    Rock
    MS MVP Windows - Shell/User
  4. Archived from groups: microsoft.public.windowsxp.general (More info?)

    do you have sp1 installed because that can sometimes be the problem?!?
  5. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Master wrote:

    > do you have sp1 installed because that can sometimes be the problem?!?

    What? SP1 installed can be a problem when trying to update to SP2?
    Nonsense.

    --
    Rock
    MS MVP Windows - Shell/User
  6. Archived from groups: microsoft.public.windowsxp.general (More info?)

    In news:BFB3AE05-DD95-4157-A694-2ACA9172A8CB@microsoft.com,
    Master <Master@discussions.microsoft.com> typed:

    > do you have sp1 installed because that can sometimes be the
    > problem?!?


    Nonsense! That's completely false. The majority of people who
    have installed SP2 installed it over SP1 without a problem.


    --
    Ken Blake - Microsoft MVP Windows: Shell/User
    Please reply to the newsgroup
Ask a new question

Read More

Microsoft Windows XP