Sign in with
Sign up | Sign in
Your question

Dimension4300 Unknown Device for HDD and CD

Last response: in Computer Brands
Share
July 26, 2010 10:31:30 PM

I have been working on my neighbors Dimension 4300 for about 6-8 hours now, and it started off simply with a missing/corrupted "windows/system32/config/system/." All he wanted me to do was to try to recover some pictures and work files, so I tried the following.

I figured trying to booting from my osx leopard which is on an external drive, but the 4300 isn't able to boot from an external USB. Next I tried an Ubuntu live cd, but that gave me a string of errors. Then I built another live cd, NimbleX, and that froze at the load screen. I tried each live cd 3 or 4 times, and after a few restarts of NimbleX, I noticed the Hard Drive C:\ wasn't on the boot list. So I tried letting the computer boot up normally without pressing F12 to get to the boot list, and i get "cannot find primary drive 0" or something to that effect.

Long story short, now in the BIOS under primary drive 0 and 1 i get unknown device, and for secondary drive 0 and 1, where the optical drive should be i get the same unknown device message. the boot list only shows 3 things: "1. diskette drive. 2. cd-rom device (not installed) and 3. MBA UNDI (Bus2 slot10)"

I have already reset the NVRAM a few times by turning caps lock, num lock and scroll lock on and then alt+e then alt+f and a reboot with alt+b. I've also taken out the CMOS battery for a few minutes and put it back in, and when i boot up it tells me its configuring the ide or something. after that it takes me to the BIOS, and nothing changed except for the date and time of course.

ive checked every connection to the hdd and to the optical drives (cd and dvd) and nothing seems to be loose, but i took them out and put them back on anyways.

BIOS is A02, and I thought about flashing it to A06, but i know of some bad things that can happen because of a poor BIOS flash, and really don't want to try that.

so what i really need help with is getting the BIOS to recognize the hdd, and then some tips on data recovery.


thanks in advance for your help

-jyontef
July 26, 2010 11:11:06 PM

Have you tried checking the master slave pins? better yet if you have another desktop take that cable and plug it there it should work.
What version of ubuntu are you using? maybe you should try the DVD version of it to make sure it has all the drivers available. Also make sure you have internet
m
0
l
July 26, 2010 11:29:05 PM

i read on a few forums about the master slave pins, but i have two problems with that. 1: how could they just change for no reason, the case wasn't opened till after i had the hard drive problem. 2: where are they? i saw no switch on the actual drives, are they on the mobo?
and sadly I have no other ide cables.
i have ubuntu 9.4 i believe, and all the live cds work just fine on my inspiron 1525, which im on right now
m
0
l
July 28, 2010 4:01:50 AM

So I understand where and how to set master and slave jumpers after doing a little reaearch, I just cant find any infob on specifics for the jumpers for thr 4300.
m
0
l
!