Sign in with
Sign up | Sign in
Your question

Manually Disable Internal Speakers

Last response: in Laptop General Discussion
Share
October 28, 2009 8:01:43 PM

Asus F50SV
Realtek High Definition Audio
Windows 7


My headphone jack no longer stops the internal speakers automatically. So sound plays on the headphone as well as the speakers, defeating the purpose of headphones.

I would rather not go without my laptop while asus fixes it. So I want to disable sound on the speakers when I have headphones plugged in. I have looked around a fair bit, both on the internet and on my computer and there doesn't seem to be any way to accomplish this with the realtek audio.

I am seriously considering dissembling and physically unplugging the speakers, but I was wondering if you guys have any other, less invasive, suggestions to try before I do?
a b Ĉ ASUS
a b D Laptop
October 28, 2009 9:35:04 PM

Usually there are 2 options in the realtek settings in device manager. I assume one of them may or may not disable the speakers while still allowing the headphone jack to work. Give that a go, it won't hurt to try.
October 28, 2009 11:39:32 PM

buwish said:
Usually there are 2 options in the realtek settings in device manager. I assume one of them may or may not disable the speakers while still allowing the headphone jack to work. Give that a go, it won't hurt to try.


2 options under sound?

I only have one:

Related resources
Anonymous
a b D Laptop
August 18, 2010 8:33:50 PM

For those attempting to disable the RealTek integrated speakers (those in your computer tower itself):

In the RealTek control panel (accessible via Windows Control Panel or double-clicking the RealTek icon in the TaskBar) there should be an option to enable "Multi-Streaming" (in the lower left-hand corner of the dialog).

Once Multi-Streaming has been enabled, double-click the master-volume/mixer control in the TaskBar. With the mixer controls open, take note of what appears in the status bar in the bottom left corner of the dialog. If it says "Realtek HD Audio 2nd Output", this should be the controls for the Headphone Out jack.

To affect the integrated speakers, select Options / Properties / under "Mixer Device", Realtek HD Audio Primary Output / OK

This will open the mixer controls for the "Realtek HDA Primary output". Simply mute this, and you'll be good to go.
September 2, 2012 8:46:36 PM

I managed to fix this on mine. I'm using an old HP DV2000 for my CCTV to NAS interface for recording and despite Windows sounds being turned off it beeps using the internal speaker every time the CCTV triggers its motion detection.

So the fix I found in Windows 7 is:

Go to Sounds in Control Panel.

In the Playback tab I right clicked on "Speaker/HP" and selected disable.

The beep was no more.

Dont worry about thinking that you have killed any drivers because a simple reboot will restore the setting.

Have a play around and see if you can permanently kill it if you want...
May 26, 2014 5:42:45 AM

I have the same problem with my windows xp acer laptop.Can anyone help me ???
!