Sign in with
Sign up | Sign in
Your question

Usb mouse stopped working

Tags:
  • Drivers
  • Mice
  • USB
  • Windows 7
Last response: in Windows 7
Share
October 3, 2012 3:50:46 PM

2 days ago my mouse randomly ceased to work (Razer Imperator). Before preparing an RMA I thought to test it on another system (netbook) to verify it was broke. Turns out it wasn't.

So past 2 days I have been googling my ass off using my drawing tablet as a mouse. I have other USB mice but they all don't work either, other than the tablet. Unfortunately system restore is not an option as for some bizarre reason its not turned on. Using the repair CD, the one from the backup part of the control panel doesn't work as it detects no problems. One thing I did learn from that boot repair CD is that my mouse functions fine at this point. From this im assuming a software fault. First time I saw that I had hope it was fixed. Not to be the case.

So I can give yall a brief overview of the things I have done so far:

Checked that the mouse is working on other systems
Turned off Legacy support for USB on my BIOS
Uninstalled and re installed the product drivers countless times (These were removed properly each time)
Tried all the USB ports on my computer and verified that all my ports work with other devices eg flash drives and the like
Uninstalled the drivers from the devices in the device manager to see if windows could re install them automatically
Transferred several .INF and .PNF from another functional system related to the problem ( also have the originals backed up)
Removed all other USB devices to see if its a power fault
Updated my bios and chipset drivers alongside most other system drivers


So thats where I am at so far. I also have a few observations which may also be relevant

Under the devices and printers and into the properties i get the following
http://img.photobucket.com/albums/v720/Bulletmuncher/Pr...

From that I think its related to a missing PnP HID-compliant Mouse driver or atleast there is a conflict but thats my speculation

System Specs:

Intel i7 975 3.33Ghz
6144MB DDR ram
Geforce GTX 560
Mobo P6X58D-E
PSU 1100 Tagan ( not sure on specifics sorry)

Any questions or suggestions be sure to voice them as this point im up for trying nearlly anything other than formating and reinstalling OS.

P.s Sorry for the wall of text it just seemed easier than giving little information to be asked about it later on with slows the process of fixing down

More about : usb mouse stopped working

a b $ Windows 7
October 3, 2012 4:00:56 PM

Did you completely remove the mouse drivers and then try re-installing a downloaded version? Mice like that usually come with on-board drivers, and although I would assume it would be read only, they have been adding lots of memory functionality onto them, so there is a possibility that the on-board driver has become corrupted. You could do a repair install that will keep all your data and simply re-write the drivers and such. Also, in the other computer that you tested the mouse in did it install any drivers or did it work as soon as you plugged it in?
m
0
l
October 3, 2012 4:09:35 PM

I did completely uninstall the drivers not only from program settings but on the device manager also. As far as on board memory for the mouse goes it has firmware on it which I had updated a long time prior to it breaking and since the break I have updated them. This requires plugging the mouse in during a button press which loads the mouse as a freeloader. When I recently updated the firmware using the products own firmware updater that recognised the mouse during its freeloader state but the drivers from the product wont recognise the mouse when its plugged in.I simply get a Razer imperator is not connect the application will now close. The firmware updater and the configuration tool are separate I should add

When I tested in on the other system which is a cheap netbook I use only from browsing it automatically installed drivers.
m
0
l
Related resources
a b \ Driver
a b $ Windows 7
October 3, 2012 5:33:05 PM

have you tried booting into safe mode and removing add the devices under mouse and keyboard and using a drive sweeper to make sure the mouse drivers was removed from the registry?? alos when the last time you did a malware and anti virus scan on the system..it could be a virus.
m
0
l
October 3, 2012 7:47:52 PM

Currently doing a scan with MSE and Malwarebytes but its gonna take a while. Even if it is a virus if its corrupting a driver im not sure cleaning it will get me anyway as the driver will still be corrupt after.

Also had a problem trying safe mode as my keyboard doesn't seem to have power on the boot menu and the timer goes down and it boots normally. Gonna try a PS/2 keyboard tomorrow after this virus scan is done to see if that works for it.
m
0
l
October 4, 2012 9:08:06 PM

Decided to simply format computer and start anew as its been a while since i done it and its about that time. Thanks for the input.

If someone could close thread that would be grand
m
0
l
!