Sign-in / Sign-up
Your question

Detecting IDE Error

Tags:
  • Hard Drives
  • Slave Drive
  • Storage
Last response: in Storage
August 9, 2005 1:18:16 PM

I normally run two IDE HDD. Last night, as I was trying to reformat, my slave drive starting clicking, and my system froze. Since it didn't have any pertinent data on it I decided to disconnect it completely from the system, leaving my master (the one with the OS installed)...

Now on bootup I get stuck on "Detecting IDE devices." After about 5-7 minutes it'll detect my master and my two input drives, and then it'll crawl for another 5 minutes to get to the boot...

It tells me to insert a boot disc (which is odd, since the OS is on my master drive), and then after another 5-7 minutes it'll tell me it can't detect a hdd installed and then it just restarts the process all over again.

I double checked my IDE cable and everything seems to be fine. The jumpers on my master are reading fine, and I've disconnected both the IDE cable and power supply from the clicking (dead) slave drive.

The thing that gets me is that it detects my master drive on the initial screen (after seven whole minutes), but then asks for my windows boot disc and that it can't install windows because it can't detect an HDD being installed.

More about : detecting ide error

Anonymous
a b G Storage
August 9, 2005 2:43:30 PM

Is there a jumper position for "Single" or soemthing along those line, sometimes, when set to master on the Furthest IDE connectore(not the one in the middle) it will *wait* for the slave drive. Setting the jumper to eith CS(Cable Select) or single or soemthign along those line can fix it...Also try to use the middle connector, that might help.

Finally get into bios and there should be a way to tell the computer not to scan for ide, like putting the one you're not using to "disable" instead of "auto"...

Asus P4P800DX, P4C 2.6ghz@3.25ghz, 2X512 OCZ PC4000 3-4-4-8, MSI 6800Ultra stock, 2X30gig Raid0
a b G Storage
August 9, 2005 4:41:10 PM

if its a western digital drive take the jumper completely off the master drive when it is alone. I had a similar problem.

basicaly like this:
single drive - no jumpers at all
2 drives - master and slave set on each drive.

if its not a WD drive I would still try leaving the jumper off.

I would also go into the bios and set it to not look for a drive on the slave connection. set it to none.
August 10, 2005 6:08:35 AM

I second labbby's post on Western Digital. I had an awful problem with errors on the slave drive on my son's computer untill I noticed the drive had seperate jumper settings for "master single" and "master with slave". Anyway, since the system supports cable select, both drives should have been on cs.

Also, I had a Maxtor that the system kept downgrading to PIO mode. I finally noticed that one of the pins on the drive was bent and wasn't making contact. It is amazing that the drive was usable at all. I straightened the pin and now it runs in UDMA mode 6 just fine.

Windows can freeze up for any reason or no reason, but if you messed with the cable it is always worth checking the connection. If you had the cabble unplugged, check the pins too. A new cable is only a couple of bucks and worth a try.

Good Luck