LG LED TV won't show program information or channel name...

Im not sure i put this under the right category, but anyways... We got a LG LED 55" TV a little while back and just hooked it to Charter, but i have a problem. There is no guide, no Program Information, and no Channel name. I was wondering if I had to buy something else or if this was a problem/bug... I would really like this fixed for it is very annoying when I'm flipping channels and i don't know:

1.) What channel im on
2.) Whats on on the channel im on :)


If anyone has any information on how to fix it or if its just a problem ill have to live with (I'm not paying extra monthly fee for anything extra...).

Thanks Ahead!
19 answers Last reply
More about show program information channel name
  1. Charter is a cable company? Then you need to set up the cable box.
  2. It's all set up. I will get the picture/sound (up to 1080i) but i can't get the TV to display the information (What I'm watching and the channel's name). It used to show all the information (But the guide) when we got our TV from the air... Don't know whats wrong.
  3. When your tv gets signal from the air it is receiving, decoding, and displaying.
    When you hook it to cable the tv is displaying only.
    Are you using the cable box to change channels? or have you just plugged the charter cable into the tv?
  4. Just the cable... So my big screen is upstairs, my cable box is downstairs in the office (So we can keep everything together-Internet, cable box, wifi box, and our only surge protector...) and the other TV is in the family room. Would plugging my big screen somehow into the cable box change this? I'm sorry im new to the TV broadcasting thing :P.
  5. The program info is being decoded by the cable box and displayed. With just the cable you will get the shows only. If it's really important than you can rent an additional box from charter for 2nd Tv. usally ony about $5.00 per month.
  6. Ok so im now thinking the box that is downstairs isnt a cable box... It very well could just be some sort of internet thing (it has a ethernet port, a cable-in-, and two phone plugs [edited]), because it isnt connected to any of my TV's and it doesnt look like it could hook up to a TV. Is it possible not to have any cable boxes to get picture? If so, then would i just call Charter and ask for a box or maybe buy my own...? And if this helps with anything, we have the VERY basic programing, we got it so we could get the bundle with Phone and Internet, but I'm starting to like having TV to watch :P (Like i said we watched it over the air). And without the information it makes it really hard to surf :lol:.
  7. Sorry for being such a newb :P. lol
  8. I think you've got it. Get a box from charter usual charge is around $5.00/month
    Ask them if they know where you can buy a compatable box (if possible)

    I know it nice to see whats on a channel for surfing, but is it worth $5.00/month?
    See if you can find the channel with the channel guide and use it every 1/2 hour.
  9. No, its really not worth it, but i might be able to get a DVR attached to it, so it would be worth 5$ a month. But just for that, no it really isn't worth it.

    Yea i use that channel but its a pain to wait for it to scroll... :)

    Thanks for all your help, you've cleared up a lot :).
  10. I bought a 35" LG TV a few months ago. I have nothing but an outdoor antenna.

    For about the first month or two, when the INFO button was pushed, the TV would display program information (i.e. the name of the show being shown on the selected channel).

    And then, one day when I turned it on and it was (and still is) displaying "No program information" instead of displaying the name of the currently displayed program. All other information about the current channel is displayed OK.

    I've tried everything to make the program information re-display but no luck.

    Have any of you readers been able to figure out how to get the program information back??
  11. I'm the one who posted the above message. After a month or more seeing "No program information" and not being able to solve it.....duhhhh, within minutes of posting the above message I figured out what was wrong.

    When you first set up the TV you have to go into the settings and tell it what TIME ZONE you are in. Well, I remember that I had unplugged the TV around the time the "no program information" problem started.

    I went into the settings a few minutes ago and told the TV that I was in the Eastern Time Zone. Voila!, the TVGOS (i.e. the program information) immediately started working again.
  12. Dude really?? The thread is more than 7 months old and your trying to advertise???
  13. gidgiddonihah said:
    Dude really?? The thread is more than 7 months old and your trying to advertise???

    The bloke is only stating his thoughts gidgidpremodonihah. Who cares how long ago the thread was. People will always have issues and they will be directed to past forums.....so dude....your not really that cool.
  14. No doubt. I came here to find out how to get my program information to work, and Diamonhead's post was exactly what I was looking for. Thanks, dude.
  15. Diamondhead said:
    I'm the one who posted the above message. After a month or more seeing "No program information" and not being able to solve it.....duhhhh, within minutes of posting the above message I figured out what was wrong.

    When you first set up the TV you have to go into the settings and tell it what TIME ZONE you are in. Well, I remember that I had unplugged the TV around the time the "no program information" problem started.

    I went into the settings a few minutes ago and told the TV that I was in the Eastern Time Zone. Voila!, the TVGOS (i.e. the program information) immediately started working again.


    I have an LG LW5600 connected to cable and I still cannot get the program info to show up. Can you walk me through what you did? Thanks!
  16. Diamondhead said:
    I'm the one who posted the above message. After a month or more seeing "No program information" and not being able to solve it.....duhhhh, within minutes of posting the above message I figured out what was wrong.

    When you first set up the TV you have to go into the settings and tell it what TIME ZONE you are in. Well, I remember that I had unplugged the TV around the time the "no program information" problem started.

    I went into the settings a few minutes ago and told the TV that I was in the Eastern Time Zone. Voila!, the TVGOS (i.e. the program information) immediately started working again.


    Thanx alot cuzz. Voila I'm back!!
  17. It is 2016 and diamondhead's answer was exactly what I needed. Thank you. When I set up my LG 55 , I set the time manually and even though the shaded time zone was correct , it didn't activate. I couldn't figure it out for months. The program info was one hour off. I reset the time to auto and everything works perfectly. Diamondhead rocks.
  18. gidgiddonihah said:
    Dude really?? The thread is more than 7 months old and your trying to advertise???


    Anonymous said:
    No doubt. I came here to find out how to get my program information to work, and Diamonhead's post was exactly what I was looking for. Thanks, dude.


    Greetings from the future. In my situation the time option had reset itself to manual after a power failure. Set time to automatic... fixed
  19. 6
    gidgiddonihah said:
    It's all set up. I will get the picture/sound (up to 1080i) but i can't get the TV to display the information (What I'm watching and the channel's name). It used to show all the information (But the guide) when we got our TV from the air... Don't know whats wrong.
Ask a new question

Read More

Digital TV TV LG LED Monitor Home Theatre