Sign in with
Sign up | Sign in
Your question

help with new speakers setup

Last response: in Components
Share
September 12, 2005 6:36:35 PM

Hi guys,

I just bought new speakers: Creative SBS560 5.1 Speakers. However, when I hook them up to my on-board audio (Asus A8N motherboard), only the 2 front speakers work. The two rears and center speakers don’t work at all. Sometimes when I disconnect all the speakers from the sub-woofer and plug them back in, the 2 rear and center speakers will work, but not the front speakers. I checked several times to make sure all the connections were in properly. The box came with no manual or instructions, just diagrams on the cover that show the hook-up. The bottom line is I can’t get all the speakers to work at the same time. Any help or explanation will be helpful.


Ron

More about : speakers setup

September 17, 2005 9:13:31 PM

#1

The first question is, does your motherboard support 5.1 sound? It should have 3 stereo minijack inputs in order for this to happen, since each minijack supports only 2 channels.

#2

Second, are you playing 5.1 source material, or are you just playing CDs (or "downloaded" mp3s). If you don't have multichannel source material, you aren't going to play out of all your channels unless a stereo surround feature is enabled.

#3

Do you have the necessary software to emulate stereo surround? Creative's CMSS is an example of this. If not, use the user-friendly search tool known as "google" to find free stereo surround software.

If none of these help, you need to return your speakers since they are faulty.
!