Sign in with
Sign up | Sign in
Your question
Solved

Can't Turn On ASUS Notebook With Creative Sound Card in USB

Last response: in Laptops & Notebooks
Share
November 14, 2009 11:29:08 AM

I have a new lower end ASUS Notebook. I purchased Creative's SoundBlaster X-Fi Surround 5.1 external sound card that hooks up to the USB. However, if the sound card is hooked up to the USB, I cannot turn on or restart the Notebook, for it only gets as far as the ASUS logo. It is not a boot issue in the Setup, for I disabled that with ASUS's Tech Support help. ASUS thinks that it has something to do with the sound card being grounded. Creative's email Tech support is useless.

One other thing.....I finally got Creative to provide me with the correct Drivers for the sound card. I have not tried to restart my Notebook with the card plugged in the USB since that, as I don't want to keep doing a hard-boot and risk damaging my Notebook. IMHO, that should not solve the problem....Should it? :) 
a b Ĉ ASUS
a b D Laptop
November 16, 2009 1:04:15 AM

Creative's support is probably correct, at least to a degree. I've had usb devices do that to me before, usually ones that are old and worn out, which means they were having a ground issue. A PC will not fire if a plugged in device is not properly grounded, plain and simple. In your case, you have a new device. I'm sure you restarted by now. How did it go?
November 16, 2009 9:43:10 AM

I haven't tried it again, since I am concerned about having to turn it off by holding in the button again, and what it could do to the computer.....Should the right software make a difference? Or does it sound like the sound card has faulty grounding and I should exchange it? Thanks. :) 
Related resources
November 16, 2009 12:15:48 PM

You should go into your BIOS and check the order of boot devices. Change the order so your hard drive has priority over USB. Also, don't worry about just holding the button to turn it off, just make sure you don't have any unsaved information before you do.
November 16, 2009 3:22:00 PM

Thanks.....Did that already....I took a chance that the sound card could be bad, so I am exchanging it for another new one. I'll post what happens then.
November 18, 2009 11:00:33 AM

Got a replacement Creative sound card (same model) and still have the same issue. Creative told me to disable the onboard sound card, which I haven't tried yet, since I'm not sure what to do. They also told me to update my BIOS, however, ASUS told me that there is not need for that. ASUS mentioned downloading newer drivers for my Chipset......Getting all kinds of info, but don't know which to do. I guess I'll just unplug it from the USB each time I restart my Notebook unless someone has a more specific possible solution.....Oh, by the way, I answered before as lordpuffer, as I forgot I signed up as that years ago. I guess I signed back in that time with it and it still worked. Did it by mistake.
November 18, 2009 11:31:18 AM

Have you looked to see if there is an error when booting? There should be an option in bios that instead of showing the logo will show a verbose boot screen. See what the last thing that happens before the freeze is or if you get an error.
November 30, 2009 5:06:24 PM

I'm sorry not to get back to this thread sooner, however, I was pulled away due to personal reasons.

I returned the Creative card, and instead, purchased an M-AUDIO Fast Track Pro. My Notebook still does the same thing. I couldn't find the verbose boot screen you mentioned, and you cannot even get into the Bios when it freezes. ASUS will no longer help me since it is a third party product that is causing the problem. I decided to just unplug the USB upon each restart.

Best solution

November 30, 2009 6:21:10 PM
Share

I isn't called verbose, probably as I think that is a unix term. But there should be an option not to display the Asus logo screen. It will say press ( i think its tab) to show the boot process.
November 30, 2009 9:29:44 PM

Thanks....Let me think about whether or not I want to continue pursuing this. It's getting pretty involved. I can always just unplug the M-AUDIO Fast Track Pro when I'm going to restart the Notebook....I'll get back in two or three days with a decision (some family health issues have arisen)....Either way, thank you for your help. :) 
!