Sign in with
Sign up | Sign in
Your question

Laptop installation problems

Last response: in Windows 7
Share
October 9, 2012 1:07:53 PM

I was trying to fix my parents laptop, a Toshiba Satellite pro T130. It is out of warranty and was running an OEM preloaded WIn 7 pro 64bit.

In diagnostics I found that the hard drive had so many errors Seatools for Dos gave up running the scan.

So I bought a new hard drive and fitted it.

There were no install discs and without the hidden partition on the old hard drive (which held the files required for a reset to factory status) which I did not want to copy as the hard rive had so many errors I needed some install media.

So I down loaded win 7 pro 64 bit sp1 iso from mydigitallife and installed via a usb stick as the laptop has no dvd drive.

This went well, as in no errors, I then downloaded all the toshiba drivers and avast free on my own pc, and then installed them on the laptop. At this point I put it on the net via my wireless and activated windows with no problems.

I then go to do the mountain of windows updates I expected to find but the update service would not run.

I try some fixes, turning it on and off, checking the services are set to start and started. In the process I found windows defender did not work either, and after some searching on the web I found that this problem was caused by windows search and indexing not running properly.

I followed some instructions for reinstalling Windows Search but it fails to install properly. The setupcompletedsucessfully key in the registry remains 0

I'm now stuck as to what to do or what the problem was. When I was checking the services I found a few turned off that needed to be changed to auto start, like the Background Intelligent Transfer service.

Currently windows Search service and windows defender service will not start. They give no errors in the services but in the event log I have plenty.

Search gives the following error:

"The windows Search Service has failed to create the new search index. Internal Error <4, 0x8004117f, Failed to add project c:\ProgramData\Microsoft\Search\Data\ Applications\Windows\Projects>."

If I open indexing options via the run box it says Indexing is not running, despite the services snap in telling me the index service is running.

I have uninstalled the search feature, restarted the laptop, deleted the ProgramData\Microsoft\Search folder, then reinstalled the feature and restarted. on restart I got the windows configure dialogue before log on but the problem remains.

I've followed all suggested on this link:

http://social.technet.microsoft.com/Forums/en-US/w7itpr...

To no avail. If I tell the indexing options to rebuild the index nothing happens.

Firstly should I try to make sure system restore is off and try deleting the windows search folder again?

Other wise what other options are there?

I also have a number of other errors in the event log:

WMI error:

"Event filter with query "SELECT * FROM _InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected."


CAPO2 error:
event ID 257

"The cryptographic Services service failed to initialize the Catalog Database. The ESENT error was : -583."

I followed the instructions here but still have the same error in the events log on restarting the service:

http://social.technet.microsoft.com/wiki/contents/artic...

esentutl told me that I did not have permissions to the file, so I emptied the catroot2 directory as instructed restarted the service and got a file does not exist message when I tried to run the verify section. I was surprised there was no request to restart.

Service control manager errors:
Event ID 7023 "The Windows Defender Service terminated with the following error: %%-1906441657"
Event ID 7024 "The Windows Search Service terminated with service-specific error %%-2147217025

I have the feeling that something very fundamental is wrong, almost like my OS doesn't have permissions to my own Hard Drive.

Any ideas before I start the install again from scratch and lose two days worth of plodding at it? I also have no idea how a reinstall would help, it was a clean brand new hard drive before the install took place. Is there perhaps a problem with having let the USB installer format the hard drive?

Any ideas?
October 9, 2012 1:32:32 PM

I have just found this:

http://social.technet.microsoft.com/Forums/en-GB/w7itpr...

I have no idea what do no now, I have downloaded and I thought successfully installed all the Toshiba Drivers from their website. The Storage ones are all Intel Chipsets. Should I try to install updated drivers form intel or stick with the toshiba ones?

October 9, 2012 2:02:51 PM

Intel driver utility finds the latest chipset driver is installed. Any Ideas?
Related resources
October 9, 2012 2:18:33 PM

I'm also plagued with unsigned drivers pop up saying the driver was NOT installed and not giving me any options to install anyway.

Any work around for this? The drivers on the toshiba site claim to be digitally signed does the laptop need internet access to check this stuff?
October 9, 2012 2:23:22 PM

It's hard to say without having hands on, but reading your issue it sounds like the .iso itself might have some issues.
Basic Windows services like index not starting seems to indicate more than a driver issue; your drives and such not installing are probably also a symptom--not the cause. (this is speculation though; I could be wrong)

There may also be other faulty hardware components; I'm not sure how old the laptop is, but if the original hard drive was as messed up as you implied, then I'd check the hardware first.
October 9, 2012 2:36:01 PM

I had run memtest86 and prime95 several times before finding the hard drive was the problem. I'm not sure what other components I can test as most are inbuilt.

The chipset is intel I'll have a look for diagnostics however Toshiba's diagnostics finds no problems.

The laptop is a 2010 model about 12 months out of warranty and little used.

Should I download the iso again from scratch? or try another install with what I currently have first?

If I start the install form within windows it offers to download extra updates first, and asks for an internet connection all though install to do it. However, the internet connection is via a wireless device and would be lost once the system restarted as the driver would not be available?

Sigh.

What a way to lose a couple of days...

EDIT: I thought they did not start until I had activated windows? The other issue is that everything says Indexing is started. Except that it isn't!
October 9, 2012 3:34:21 PM

As many issues are you're describing, I'd re-install Windows from a secondary iso to rule out OS corruption if you're certain the hardware is fine.

As far as your issue with the wireless driver, I'd download the driver and keep it on a usb drive or somewhere on your hard drive, so if updates or whatever else does disable your wireless, you have an easy means to re-install it.

From personal experience, most people choose to disable indexing, so it seems a little strange to me that anything is saying that you would require it to be active just to use the laptop.
That's what makes me think that there's a problem with a core function (either the OS or hardware).
October 9, 2012 4:30:29 PM

Well I've checked the hash key on the iso file so it downloaded perfectly.

I think this is something to do with an ide/sata controller, the main problem isn't that indexing wont work, but that Windows Search and the Crypt service wont work either. This prevents Defender and then Windows update working....

I also think that there is a problem as the many of the drivers give me the unsigned driver box. Most I uninstalled and went to extra lengths to ensure the installer was run as an admin. Which then did not give me the unsigned driver error for some reason.

In all other respects the laptop works just fine.

I fear OEM copy of windows was actually just a hard drive image and so restored windows with all the drivers installed in one hit. I think the problem maybe having to use Microsoft drivers during the OS install. How I'd get around that I have no idea at all... :( 

maybe if I let it download installation updates from a set up run from within the faulty windows it could work, but I can't format the drive at the same time then either...

Nothing's ever easy huh?
October 9, 2012 5:08:38 PM

If the issue if needing drivers for an OS install, you could always try slipstreaming them.

If you still have access to the old hard drive, why not just create an image of that and load it onto the new one?
Just because the drive itself is having issues doesn't mean that the data on it is corrupted.
October 9, 2012 5:25:56 PM

I'm thinking I may have to try that even if all I do is recreate the partitions and image the system restore one. Just have to put them both in another machine to do it don't I?
October 9, 2012 7:17:31 PM

There are any number of ways to do it.
You could put it in another machine, external case, or even use the same laptop as long as it's still bootable.

I recommend using a program like Acronis; it does a wonderful job, and they have free trials although I don't know if it'll let you do a full backup and restore.
October 10, 2012 10:12:25 AM

aramisathei said:
There are any number of ways to do it.
You could put it in another machine, external case, or even use the same laptop as long as it's still bootable.

I recommend using a program like Acronis; it does a wonderful job, and they have free trials although I don't know if it'll let you do a full backup and restore.



The problem is that I am using a 4k per sector hard rive. Doh!

so I need this:

http://support.microsoft.com/kb/2510009

But it wont install. Gives me an error:
However the installer wont run it gives this error: "Installer encountered an error: 0xc8000247"

and

http://www.technoyl.com/how-to-fix-0xc8000247-windows-u...

doesn't fix that so I'm think i'm looking to slipstream in the 4k fix and start again... grrr


October 10, 2012 11:53:30 AM

Is there a tutorial for adding drivers in RT 7 lite?

Ah many of the toshiba drivers install from an exe and I can't get to the .inf files so I guess there goes that idea! Extracting them all would probably take as long as loading them all lol!
October 10, 2012 5:34:31 PM

I had already started the slipstream installation.

It was all fine. Everything looked good, no errors in the logs, so I started installing the toshiba drivers and now I've finished the log is full of the same -583 error.

KB982018 is in the list of installed updates.

All the drivers installed fine, except one, which Windows said was not digitally signed and threw it out, the generic IO memory. But the errors started much sooner than that. They started with a

WMI error:

"Event filter with query "SELECT * FROM _InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected."

But I've looked for solutions to that before and have only found instructions to simply stop them being reported. It happens once on start up.

20 mins later I get my first CAPI2 error:

EventId: 4107
"Failed to extract third-party root list from auto update cab at: <http://www.download.windowupdate.com/msdownload.update/...; with error: A required certificate is not within its validity period when verifying against the current system clock or the timestamp in the signed file."

The laptop at this time was not attached to teh web and did not even have lan or wlan drivers installed.

Tens mins later the good old CApI2 Event 257 error starts up again
"The Cryptographic Services service failed to initialize the Catalog Database. The ESENT error was : - 583."

The bas windows 7 iso I used was downloaded from mydigitallife and passed it's hash checks.

What do I do now.. :S

I know have errors for the windows search service. "Cannot open the Jet property store." and then the "Failed to add project to C;\ProgramData\..."

So I'm back where I was, but I do have that 4k hotfix! What else can this be? A bad sata controller on the Mainboard?

The first driver I installed was the intel chipset downloaded from the toshiba website before hand.

Sigh. Any ideas?
October 10, 2012 6:14:40 PM

I'd still try using a different iso to rule out any installation or OS corruption issues.
The errors your seeing indicate either a hardware problem, or an issue within Windows itself; not necessarily the drivers or whatever else.
It could be the sata controller, but if your other hard drive worked fine (sans the issue with the hdd itself) then that likely isn't it.
October 10, 2012 6:22:05 PM

Actually i think the old hard drive did not have any of these errors in the event log!

Could having bought a 4k per sector HDD simply be incompatible with the intel sata drivers?
October 11, 2012 11:47:59 AM

Right, well the os is reinstalled no drivers, just the hotfix.

I had been told it could take a hour or so for the os to build the catroot2 database so I left fit all morning. No errors in the event log. (other than the WMI one on start up)

So now i have to install drivers for a whole bunch of unidentified components. Including the chipset.

I'm tempted to download the WLAN drivers first and let a program like pcmatic find drivers for the rest?

Or should I plod my way through them all individually. Also terrified it will mes sup again at the last moment!
any advice?
October 11, 2012 3:15:37 PM

Make an image of the fresh install without any errors. That way you have a solid restoration point (system restore is iffy at best) and you can easily trace the root problem if one develops.
October 11, 2012 6:09:36 PM

Yeah I'm thinking of doing that, in the morning. I installed Avast free and downloaded the WLAN driver form manufacturers website instead of toshiba's. Then went only, windows update went at it, 94 updates. But everything is installed, no unknown devices and no errors in the log so I'm happy with that!

I don't know which one made the thing mess up, but one of Toshiba's drivers really didn't want to work without a Toshiba hard drive.
October 11, 2012 7:01:55 PM

I'm pretty sure it was just an error during your original re-install of Windows.
Can always test out Toshiba's drivers again if you're curious.

Like you, I prefer to go straight with the manufacturer on most drivers myself.
Either way, glad to hear it's working out now!
!