Closed

Parameter format not correct in command Prompt - Read Only..

Archived from groups: microsoft.public.windowsxp.general (More info?)

Parameter format not correct in command Prompt - Read Only attribute

I am trying to change the Read Only attribute in command prompt, After I
type the following command, Parameter format not correcet - Error messege
comming up as follows,

C:\Documents and Settings\My Name>attrib -r +s c:\documents and
settings\Myname\favorites
Parameter format not correct -

What is wrong, How the format should be?

Please help me, is there any easy ways to change all the folders from read
only to Normal?
7 answers Last reply
More about parameter format correct command prompt read only
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    "Samshun" <Samshun@discussions.microsoft.com> wrote:

    |>Parameter format not correct in command Prompt - Read Only attribute
    |>
    |>I am trying to change the Read Only attribute in command prompt, After I
    |>type the following command, Parameter format not correcet - Error messege
    |>comming up as follows,
    |>
    |>C:\Documents and Settings\My Name>attrib -r +s c:\documents and
    |>settings\Myname\favorites
    |>Parameter format not correct -
    |>
    |>What is wrong, How the format should be?
    |>
    |>Please help me, is there any easy ways to change all the folders from read
    |>only to Normal?

    First attrib is a path command so it would be like:
    attrib -r c:\path to files *.*

    What I do is go to the root of a drive (partition) (cd \) and type in
    attrib -r /S *.*

    This will remove the read only bits from all files, makes a defrag
    more useful.

    You will see a lot of error messages, don't worry about it, just says
    you can't remove it from hidden or system files.

    To see the switches allow'd with attrib type in: attrib /?
    --
    Ever wonder what the rest of the world is searching for?
    http://tinyurl.com/6ow99
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Hi,
    In command prompt: the OLD "8.3" (Dos Style) applies.
    A max. of 8 letters before a period (.) and 3 after same. Takes time to
    master.

    Why don't you just navigate using "My Computer"
    to: C drive
    to: Documents and Settings
    to: Your Name
    to: Favorites
    Hi-light, Right-click the folder(s) and/or file(s)
    Properties
    Untick the Offender(s)
    Mikey S.
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Samshun <Samshun@discussions.microsoft.com> wrote:

    > C:\Documents and Settings\My Name>attrib -r +s c:\documents and
    > settings\Myname\favorites
    > Parameter format not correct -
    >
    > What is wrong, How the format should be?

    You may want to use the short pathname instead. Use DIR /x
    in order to see them. Therefore, the command should read:
    ATTRIB -r +s C:\DOKUME~1\Myname\FAVORI~1 (example).
    Anyway, setting these attributes doesn't make too much sense.

    --
    d-d
  4. i tried to fixed it using My Computer toolbar -folder option but it didnt work.
    how can i see the hidden folders using command prompt? the file name of the folder is <job sheets>
  5. To see hidden folders in command prompt, you have to issue /a command.
    Here's an example to show all the hidden files/folders in root of C:\ drive.

    C:\>dir /a
  6. Here is the solution to your problem: Surround the filename with double quotes. Otherwise the command prompt will think each embedded space in the filename separates another parameter. Here is how you issue the command in the original post:

    attrib -r +s "c:\documents and settings\Myname\favorites"
  7. This topic has been closed by Mousemonkey
Ask a new question

Read More

Read Only Command Prompt Format Windows XP