Dell Latitude D630

Hi, I have a dell D630 laptop, after replacing the motherboard, when I power it on, it runs a few seconds and shuts down, It doesn't appear to be hot. The fan spins nicely. I have changed the cpu, ram and even removed the wireless card, modem and disconnected the cmos battery and nothing seems to help, any ideas. Thanks in advance.
7 answers Last reply
More about dell latitude d630
  1. Remove the battery and unplug the AC adapter. Press and hold the power button for no less than 30 seconds. Reinstall the battery and AC adapter and try again.
  2. Thanks for the advice, ut it didn't help
  3. Hi :)

    I own a laptop repair company...

    A D630 is a VERY old lappy...

    Let me guess... when you say you replaced the motherboard, you DIDNT use a NEW one... you put in an old second hand one ???

    What makes you think that one works ???

    All the best Brett :)
  4. Wellllll, it's refurbished an theres a warranty, so ifI can't get it o work, I can return it, just hopeing it was a simple poblem. Guess not??
  5. guess need new fingers or new keyboard, sorry for the typos
  6. Most likey the motherboard Dell sent to you is defective. I seen this many of times with their service.
  7. judymac307 said:
    Wellllll, it's refurbished an theres a warranty, so ifI can't get it o work, I can return it, just hopeing it was a simple poblem. Guess not??



    Hi :)

    From whom did you get the refurb board ? and just out of interest what did it cost ?

    By the way, a motherboard CANNOT be refurbished...it either works (in which case its second hand) or its new (and you wont find a new 630 board for sale anywhere)

    All the best Brett :)
Ask a new question

Read More

Configuration Dell Windows 7