Sign in with
Sign up | Sign in
Your question

Destroyed DX9 with AMD driver :l

Last response: in Windows 7
Share
October 12, 2012 9:45:56 PM

so well uh..my problem is one of a kind a mess :D  Last night i was trying to find a way to remove DX9 from windows 7 so i kept going to alot of sites...SO what i did is i just went to Registry and Deleted both DirectX folders with binaries and strings in both Microsoft and Wow64node/MS but then i discovered that i had just done a big mistake

So i couldn't install DX anymore..even with full redist but the DxDiag still says i have DirectX11 lol how? :heink:  anyways i followed someone's guide to restore DX9 but using XP way and it worked but i discovered it has ruined my AMD Catalyst Driver 12.9 beta..i no longer can adjust Tessellation and some settings went away from the graphic card

i even tried reinstalling with Redist and web and they do install but they do not change registry and still i have problems in the driver so Please any help?! i do not want to reinstall whole windows again :(  :( 



Edit:Games are still working fine somehow but i didn't try DX11 games yet
a b $ Windows 7
October 12, 2012 11:33:50 PM

Uninstall and reinstall the video driver yet?
a b $ Windows 7
October 12, 2012 11:40:27 PM

I need to know what made you think you needed to remove DX9 anyways ? I really do.
Related resources
October 12, 2012 11:49:46 PM

Games that support DX10+ should allow to pick which DX version you want to run, or defaults to 10/11. No point in removing DX9 since the risks, OS/driver corruption and incompatibility with DX9-only software, is too great to be worth it.

And if you can still run DX9 games supposedly without DX9 files, your uninstall was incomplete and only accomplished in breaking your driver.

I would recommend using System Restore and undo your mess.
October 13, 2012 6:22:09 AM

@BadDay i am sorry mate .. no system restore point :l

@Edogawa..look since i got my Graphic Card (ATi 7770) i was having huge artifacts and still so i thought maybe it was corruption in DirectX files


EDIT:i reverted back to 12.8 but still Tessellation and other options are gone :( 
October 13, 2012 6:38:56 AM

First off, HORRIBLE title for this question, its not AMD's fault!
Second, you should not be allowed near a keyboard!
a b $ Windows 7
October 13, 2012 6:52:51 AM

Wow, bookmarking this one. For the record OP DX levels are backwards compatible. So if something says you have DX11, you can also run DX10, DX9, etc. If you only have DX9, then you can't run 10 or 11.

If you were poking around in the reg, then I would do a repair install at this point. Not sure how to do it with Win7.
October 13, 2012 8:05:11 AM

@Cobra...your super idiot..i did not blame AMD

@474545b lol i know about backward compatible but seems i ruined something so both of them intersected well gonna try Repair Disc
October 13, 2012 8:13:44 AM

put your windows 7 disk in and make a repair install?
a b $ Windows 7
October 13, 2012 8:19:14 AM

If that does not work, I think the easiest option is for him to just reinstall Windows, god knows what else he did.
October 13, 2012 8:49:10 AM

+1 reinstall windows
October 13, 2012 10:00:22 AM

lol fixed it..the problem was in the root of AMD drivers..they intersected with new reinstalled driver..so used Driver Fusion..works good now :) 
a b $ Windows 7
October 13, 2012 11:53:03 AM

You blamed AMD in the title of the thread. It wasn't their fault, "someone" went into the registry and deleted things... Glad you got it fixed.
October 13, 2012 2:13:16 PM

4745454b said:
You blamed AMD in the title of the thread. It wasn't their fault, "someone" went into the registry and deleted things... Glad you got it fixed.

i think he meant "Destroyed DX9 AND AMD driver"
!