Sign in with
Sign up | Sign in
Your question

Plz help- "Video device already in use"

Last response: in Applications
Share
August 17, 2002 12:06:54 AM

Hi,

I have a problem with capturing video. I'm using the Video-In feature of my Asus V8200 Deluxe (GeForce3, 64MB).
I'm using the latest Display/WDM nVidia Drivers, on WindowsXP Pro.

When trying to capture video in programs like VirtualDub, freeVCR, I get this error:
"Video device already in use. You cannot use this device when another video application...." Then a "Video Source" window opens, and I need to select a video source. The only thing I can choose is "ASUS WDM Video Captrue (universal)". both VirtualDub and freeVCR result the exact same error (same text, same error window), so I can assume that my problem is not an application-specific problem.
An exception to my problem is "Asus Digital VCR", since in that application, I got no error. My guess is that the "Asus Digital VCR" is not using the "ASUS WDM Video Captrue (universal)" driver. I should mention that no TV-related applications are running in the
background... I even tried to capture right after a reboot, and I got the same error...
I searched my Task Manager for suspicious applications, I closed many things, and it didn't help... I also looked at the Services window, nothing suspicious there...

The problem started when I accidently tried to delete the VirtualDub directory while the program was running (I wanted to replace it with a new version). I got an error saying that some files couldn't be deleted, so I closed the application, deleted the directory, and replaced it with a new version of VirtualDub (1.4.10). Since then, I
get the error... (Keep in mind that VirtualDub has no install/uninstall abilities. You simply extract it to a directory.) Putting the old VirtualDub in place, doesn't affect anything...

I tried uninstalling and reinstallting the WDM & the Display
drivers... It didn't work...

I also deleted everything named "VirtualDub" from my registry... again, it didn't help...

Pleaseee help me
Thank you,
Eyal

More about : plz video device

August 17, 2002 2:47:21 PM

Really, really, *really* soundz like a msft f*ckup.

Media player or something has the card locked in video mode, playing some movie. I've had it (the os, not just media player) lock a file on me. I manage to fix it nowadays by opening it with whatever player I was using, and manually close the file, then close the media player.

That worx on a file, not sure about the card. If it was pissing me off this much, at this point, I would definately backup all my filez and just nuke windoze. "Clean install" is the keyword here; as in "format /u c:".

I tell you right now, I'd rather have 1,000,000 college kids hacking out source code on a daily basis, than a team of 100 grads trying to figure out what the problem is while still keeping their stock prices up.

Conflict of interests suck...
!