Force Drive Letters ??

Archived from groups: microsoft.public.windowsxp.general (More info?)

I have 2 USB hard drives which i use for storage. I have a backup program
which automatically backs up my mp3s and digital camera pictures.

When i plug in the USB hard drives they show up as C (80Gb HD) and D (160Gb
HD) - (my main Hard Drive is 'J').

problem is that if my digital camera is plugged into my USB port before any
of the USB hard drives are plugged in, the digital camera then takes up
Drive Letter 'C'. Then if i plug my USB Hard Drives in they now become D and
E !!. See my problem ?? The backup program no longer recognises that the USB
hard drives have moved up a letter and so won't back up until i restart with
only the USB hard drives in tomake them C and D again !!

So my question is, how do i force WinXP to make sure that my 80Gb HD is the
only thing to ever be allocated 'C', and my 160Gb HD is the only thing to
ever be allocated the letter 'D' ?. i.e. I want to make WinXP automatically
recognise which HD i am plugging in and always allocate it the Drive Letter
i want ?

Kinda hard to explain in writing !


Cheers
Andy
8 answers Last reply
More about force drive letters
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    I don't think you can force this. A new drive will always be given the next
    available letter. You could change them after the fact though. Change C: to
    E: then D: to C: then E: to D:(if needed). Or you could just make sure you
    plug them in in the same order each time.

    "Andy100" wrote:

    > I have 2 USB hard drives which i use for storage. I have a backup program
    > which automatically backs up my mp3s and digital camera pictures.
    >
    > When i plug in the USB hard drives they show up as C (80Gb HD) and D (160Gb
    > HD) - (my main Hard Drive is 'J').
    >
    > problem is that if my digital camera is plugged into my USB port before any
    > of the USB hard drives are plugged in, the digital camera then takes up
    > Drive Letter 'C'. Then if i plug my USB Hard Drives in they now become D and
    > E !!. See my problem ?? The backup program no longer recognises that the USB
    > hard drives have moved up a letter and so won't back up until i restart with
    > only the USB hard drives in tomake them C and D again !!
    >
    > So my question is, how do i force WinXP to make sure that my 80Gb HD is the
    > only thing to ever be allocated 'C', and my 160Gb HD is the only thing to
    > ever be allocated the letter 'D' ?. i.e. I want to make WinXP automatically
    > recognise which HD i am plugging in and always allocate it the Drive Letter
    > i want ?
    >
    > Kinda hard to explain in writing !
    >
    >
    > Cheers
    > Andy
    >
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Andy100 wrote:
    > I have 2 USB hard drives which i use for storage. I have a
    > backup program which automatically backs up my mp3s and
    > digital camera pictures.
    >
    > When i plug in the USB hard drives they show up as C (80Gb
    > HD) and D (160Gb HD) - (my main Hard Drive is 'J').
    >
    > problem is that if my digital camera is plugged into my USB
    > port before any of the USB hard drives are plugged in, the
    > digital camera then takes up Drive Letter 'C'. Then if i
    > plug my USB Hard Drives in they now become D and E !!. See
    > my problem ?? The backup program no longer recognises that
    > the USB hard drives have moved up a letter and so won't back
    > up until i restart with only the USB hard drives in tomake
    > them C and D again !!
    >
    > So my question is, how do i force WinXP to make sure that my
    > 80Gb HD is the only thing to ever be allocated 'C', and my
    > 160Gb HD is the only thing to ever be allocated the letter
    > 'D' ?. i.e. I want to make WinXP automatically recognise
    > which HD i am plugging in and always allocate it the Drive
    > Letter i want ?
    >
    > Kinda hard to explain in writing !
    >
    >
    > Cheers
    > Andy

    If you want drives to retain certain letters, your best option
    is to start at the end of the alphabet. Go into Disk
    Management, (Start -> Run -> diskmgmt.msc), and right click
    your USB drives and select "Change Drive Letters and Paths...".
    Make one Y and the other Z. Windows should reassign the
    appropriate letter whenever you plug in your USB drives. Make
    sure to adjust your backup program accordingly.

    Good luck

    Nepatsfan
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Yeah, was beginning to think that was the case, just wondered if it was
    possible. Cheers for the info anyway !

    Regards
    Andrew

    "CD" <CD@discussions.microsoft.com> wrote in message
    news:8F414F61-198F-4910-AD73-453651B6C0D1@microsoft.com...
    > I don't think you can force this. A new drive will always be given the
    next
    > available letter. You could change them after the fact though. Change C:
    to
    > E: then D: to C: then E: to D:(if needed). Or you could just make sure
    you
    > plug them in in the same order each time.
    >
    > "Andy100" wrote:
    >
    > > I have 2 USB hard drives which i use for storage. I have a backup
    program
    > > which automatically backs up my mp3s and digital camera pictures.
    > >
    > > When i plug in the USB hard drives they show up as C (80Gb HD) and D
    (160Gb
    > > HD) - (my main Hard Drive is 'J').
    > >
    > > problem is that if my digital camera is plugged into my USB port before
    any
    > > of the USB hard drives are plugged in, the digital camera then takes up
    > > Drive Letter 'C'. Then if i plug my USB Hard Drives in they now become D
    and
    > > E !!. See my problem ?? The backup program no longer recognises that the
    USB
    > > hard drives have moved up a letter and so won't back up until i restart
    with
    > > only the USB hard drives in tomake them C and D again !!
    > >
    > > So my question is, how do i force WinXP to make sure that my 80Gb HD is
    the
    > > only thing to ever be allocated 'C', and my 160Gb HD is the only thing
    to
    > > ever be allocated the letter 'D' ?. i.e. I want to make WinXP
    automatically
    > > recognise which HD i am plugging in and always allocate it the Drive
    Letter
    > > i want ?
    > >
    > > Kinda hard to explain in writing !
    > >
    > >
    > > Cheers
    > > Andy
    > >
    > >
    > >
  4. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Nepatsfan, you are a genius ! - yes that works great. Never knew of that
    "diskmgmt.msc" trick !!

    Many Thanks
    Andrew


    "Nepatsfan" <nepatsfan@SBXXXIX.com> wrote in message
    news:2-qdnfSvFYXoXm7fRVn-rA@comcast.com...
    > Andy100 wrote:
    > > I have 2 USB hard drives which i use for storage. I have a
    > > backup program which automatically backs up my mp3s and
    > > digital camera pictures.
    > >
    > > When i plug in the USB hard drives they show up as C (80Gb
    > > HD) and D (160Gb HD) - (my main Hard Drive is 'J').
    > >
    > > problem is that if my digital camera is plugged into my USB
    > > port before any of the USB hard drives are plugged in, the
    > > digital camera then takes up Drive Letter 'C'. Then if i
    > > plug my USB Hard Drives in they now become D and E !!. See
    > > my problem ?? The backup program no longer recognises that
    > > the USB hard drives have moved up a letter and so won't back
    > > up until i restart with only the USB hard drives in tomake
    > > them C and D again !!
    > >
    > > So my question is, how do i force WinXP to make sure that my
    > > 80Gb HD is the only thing to ever be allocated 'C', and my
    > > 160Gb HD is the only thing to ever be allocated the letter
    > > 'D' ?. i.e. I want to make WinXP automatically recognise
    > > which HD i am plugging in and always allocate it the Drive
    > > Letter i want ?
    > >
    > > Kinda hard to explain in writing !
    > >
    > >
    > > Cheers
    > > Andy
    >
    > If you want drives to retain certain letters, your best option
    > is to start at the end of the alphabet. Go into Disk
    > Management, (Start -> Run -> diskmgmt.msc), and right click
    > your USB drives and select "Change Drive Letters and Paths...".
    > Make one Y and the other Z. Windows should reassign the
    > appropriate letter whenever you plug in your USB drives. Make
    > sure to adjust your backup program accordingly.
    >
    > Good luck
    >
    > Nepatsfan
    >
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.general (More info?)

    You're welcome, but I'll have to pass on that genius label. I'm
    simply sharing knowledge I've gained from others. Good memory,
    yes. Genius, no!

    Nepatsfan

    Andy100 wrote:
    > Nepatsfan, you are a genius ! - yes that works great. Never
    > knew of that "diskmgmt.msc" trick !!
    >
    > Many Thanks
    > Andrew
    >
    >
    > "Nepatsfan" <nepatsfan@SBXXXIX.com> wrote in message
    > news:2-qdnfSvFYXoXm7fRVn-rA@comcast.com...
    >> Andy100 wrote:
    >>> I have 2 USB hard drives which i use for storage. I have a
    >>> backup program which automatically backs up my mp3s and
    >>> digital camera pictures.
    >>>
    >>> When i plug in the USB hard drives they show up as C (80Gb
    >>> HD) and D (160Gb HD) - (my main Hard Drive is 'J').
    >>>
    >>> problem is that if my digital camera is plugged into my USB
    >>> port before any of the USB hard drives are plugged in, the
    >>> digital camera then takes up Drive Letter 'C'. Then if i
    >>> plug my USB Hard Drives in they now become D and E !!. See
    >>> my problem ?? The backup program no longer recognises that
    >>> the USB hard drives have moved up a letter and so won't
    >>> back up until i restart with only the USB hard drives in
    >>> tomake them C and D again !!
    >>>
    >>> So my question is, how do i force WinXP to make sure that
    >>> my 80Gb HD is the only thing to ever be allocated 'C', and
    >>> my 160Gb HD is the only thing to ever be allocated the
    >>> letter 'D' ?. i.e. I want to make WinXP automatically
    >>> recognise which HD i am plugging in and always allocate it
    >>> the Drive Letter i want ?
    >>>
    >>> Kinda hard to explain in writing !
    >>>
    >>>
    >>> Cheers
    >>> Andy
    >>
    >> If you want drives to retain certain letters, your best
    >> option is to start at the end of the alphabet. Go into Disk
    >> Management, (Start -> Run -> diskmgmt.msc), and right click
    >> your USB drives and select "Change Drive Letters and
    >> Paths...". Make one Y and the other Z. Windows should
    >> reassign the appropriate letter whenever you plug in your
    >> USB drives. Make sure to adjust your backup program
    >> accordingly.
    >>
    >> Good luck
    >>
    >> Nepatsfan
  6. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Nevertheless, you sorted out this problem ! - Cheers for removing the big
    headache !!

    Regards
    Andrew


    "Nepatsfan" <nepatsfan@SBXXXIX.com> wrote in message
    news:Duydnc6mObwtVm7fRVn-tw@comcast.com...
    > You're welcome, but I'll have to pass on that genius label. I'm
    > simply sharing knowledge I've gained from others. Good memory,
    > yes. Genius, no!
    >
    > Nepatsfan
    >
    > Andy100 wrote:
    > > Nepatsfan, you are a genius ! - yes that works great. Never
    > > knew of that "diskmgmt.msc" trick !!
    > >
    > > Many Thanks
    > > Andrew
    > >
    > >
    > > "Nepatsfan" <nepatsfan@SBXXXIX.com> wrote in message
    > > news:2-qdnfSvFYXoXm7fRVn-rA@comcast.com...
    > >> Andy100 wrote:
    > >>> I have 2 USB hard drives which i use for storage. I have a
    > >>> backup program which automatically backs up my mp3s and
    > >>> digital camera pictures.
    > >>>
    > >>> When i plug in the USB hard drives they show up as C (80Gb
    > >>> HD) and D (160Gb HD) - (my main Hard Drive is 'J').
    > >>>
    > >>> problem is that if my digital camera is plugged into my USB
    > >>> port before any of the USB hard drives are plugged in, the
    > >>> digital camera then takes up Drive Letter 'C'. Then if i
    > >>> plug my USB Hard Drives in they now become D and E !!. See
    > >>> my problem ?? The backup program no longer recognises that
    > >>> the USB hard drives have moved up a letter and so won't
    > >>> back up until i restart with only the USB hard drives in
    > >>> tomake them C and D again !!
    > >>>
    > >>> So my question is, how do i force WinXP to make sure that
    > >>> my 80Gb HD is the only thing to ever be allocated 'C', and
    > >>> my 160Gb HD is the only thing to ever be allocated the
    > >>> letter 'D' ?. i.e. I want to make WinXP automatically
    > >>> recognise which HD i am plugging in and always allocate it
    > >>> the Drive Letter i want ?
    > >>>
    > >>> Kinda hard to explain in writing !
    > >>>
    > >>>
    > >>> Cheers
    > >>> Andy
    > >>
    > >> If you want drives to retain certain letters, your best
    > >> option is to start at the end of the alphabet. Go into Disk
    > >> Management, (Start -> Run -> diskmgmt.msc), and right click
    > >> your USB drives and select "Change Drive Letters and
    > >> Paths...". Make one Y and the other Z. Windows should
    > >> reassign the appropriate letter whenever you plug in your
    > >> USB drives. Make sure to adjust your backup program
    > >> accordingly.
    > >>
    > >> Good luck
    > >>
    > >> Nepatsfan
    >
    >
    >
  7. Archived from groups: microsoft.public.windowsxp.general (More info?)

    In message <2-qdnfSvFYXoXm7fRVn-rA@comcast.com>, Nepatsfan
    <nepatsfan@SBXXXIX.com> writes
    >
    >If you want drives to retain certain letters, your best option
    >is to start at the end of the alphabet. Go into Disk
    >Management, (Start -> Run -> diskmgmt.msc), and right click
    >your USB drives and select "Change Drive Letters and Paths...".
    >Make one Y and the other Z. Windows should reassign the
    >appropriate letter whenever you plug in your USB drives. Make
    >sure to adjust your backup program accordingly.

    I have a variation on the OP's setup and I have been considering
    re-allocating drive letters as follows -

    Current setup

    C and F -Internal HDD partitioned
    D DVDRW
    E CDRW
    G HDD in external USB enclosure *
    H,I,J and K - 7-in-1 Card Reader

    * there are actually 2 external USB enclosures but as these are never in
    use simultaneously I change the power lead and USB cable as necessary.
    Each HDD therein is partitioned differently and used primarily for
    backups including imaging.
    ----------------------------------------------------------
    Proposed setup

    C and D - Internal HDD partitioned
    X DVDRW **
    Y CDRW **
    T,U,V and W - 7-in-one Card Reader **
    leaving WinXP to allocate E onwards whenever the appropriate external
    USB enclosure is plugged in.

    ** these drive letters would be allocated using diskmgmt.msc
    ----------------------------------------------------------
    Any comments, put-downs, re-assurances that this proposed arrangement
    should work satisfactorily?


    --
    squire
  8. Archived from groups: microsoft.public.windowsxp.general (More info?)

    squire wrote:
    > In message <2-qdnfSvFYXoXm7fRVn-rA@comcast.com>, Nepatsfan
    > <nepatsfan@SBXXXIX.com> writes
    >>
    >> If you want drives to retain certain letters, your best
    >> option is to start at the end of the alphabet. Go into Disk
    >> Management, (Start -> Run -> diskmgmt.msc), and right click
    >> your USB drives and select "Change Drive Letters and
    >> Paths...". Make one Y and the other Z. Windows should
    >> reassign the appropriate letter whenever you plug in your
    >> USB drives. Make sure to adjust your backup program
    >> accordingly.
    >
    > I have a variation on the OP's setup and I have been
    > considering re-allocating drive letters as follows -
    >
    > Current setup
    >
    > C and F -Internal HDD partitioned
    > D DVDRW
    > E CDRW
    > G HDD in external USB enclosure *
    > H,I,J and K - 7-in-1 Card Reader
    >
    > * there are actually 2 external USB enclosures but as these
    > are never in use simultaneously I change the power lead and
    > USB cable as necessary. Each HDD therein is partitioned
    > differently and used primarily for backups including imaging.
    > ----------------------------------------------------------
    > Proposed setup
    >
    > C and D - Internal HDD partitioned
    > X DVDRW **
    > Y CDRW **
    > T,U,V and W - 7-in-one Card Reader **
    > leaving WinXP to allocate E onwards whenever the appropriate
    > external USB enclosure is plugged in.
    >
    > ** these drive letters would be allocated using diskmgmt.msc
    > ----------------------------------------------------------
    > Any comments, put-downs, re-assurances that this proposed
    > arrangement should work satisfactorily?

    A few comments:

    If your current F drive contains anything other than data,
    leave it be.

    Others may disagree but I'm not a big fan of changing the
    letters on optical drives (currently D and E). Quite a few of
    your applications, as well as Windows, will look for a CD in
    the old location and you'll find yourself having to browse to
    the new location.

    The same can be said, to some degree, of your card reader. Any
    application that interacts with the reader would have to be
    pointed to the new location. I've never changed the drive
    letters on a card reader so I can't speak from personal
    experience. You're on your own with this.

    My personal preference is to leave anything within the computer
    (internal HD's and optical drives) the letters at the begining
    of the alphabet. I'll assign external items (USB drives, flash
    drives, zip drives, etc.) letters at the end.

    That said, why not test your proposed setup in stages? Start
    with recording your current drive arrangement and save it just
    in case you need to restore that setup. Next, change the card
    reader lettters. Work with that for a week or so and see what
    happens. If all goes well, change the letters on the optical
    drives and your F partition. If any problems arise, you can
    always restore the original drive letters.

    Good luck

    Nepatsfan
Ask a new question

Read More

Cameras Hard Drives USB Windows XP