Compaq presario 17XL4W OS reload

I tried to add memory to my old Compaq Presario 1700 and during the process the OS WinXP got trashed. Specifically; on boot-up I get a "...PCI.sys is missing or corrupt..."

Tried to reload WinXP from CD, but it "hangs" after "Press 2 for ASR" and "Press 6 to load SCSI or RAID driver".

Tried the old Compaq "restore" disk, but it also "hangs" after loading Win98, EMM386, showing some "start-up" messages and warnings "this will erase all of the HD...". It hangs after the "if you are really sure ...press 1 and Enter".

Ideas? I don't mind a total reload since I haven't used it in years anyway.

It was working OK before I swapped out the 2 64MB memory boards for 2 512MB. This didn't work (now I check a little further and see it only supports 512 max ...).

Put the 2 64s back ... still worked. Tried 1 64 ... still worked. Tried 512 in 1 slot...no joy. Tried the other slot...no joy. Now won't work on the 64s.

I'm sure I did something silly like maybe swapped memory with power on ... but I tried not to do this. Had the battery out and AC unplugged each time I think.

Ken
2 answers Last reply
More about compaq presario 17xl4w reload
  1. What sort of memory does it take? DDR or DDR2? If you tried to put DDR2 in and it takes DDR, you may have ruined the memory modules.
  2. I'm sure it was DDR. I t doesn't really say on the module. but I ordered it specifically for the Presario.

    The invoice lists it as " 512MB SDRAM SODIMM (144 Pin) LD 133MHz PC133 FOR Compaq Presario 1700T"

    How can I get to the "Setup Menu" ? It "boots" to the Compaq "flash" screen, but there is no "Press F1 [F2, F10, etc) for Set-up message that I can see.
Ask a new question

Read More

Presario Compaq Memory Laptops