Solved

Splitting Audio for headset and speakers

Ok so its best I first describe my setup: Realtek HD audio manager. motherboard evga X58 SLI. onboard audio. I have a back audio panel for the following: subwoofer out, rear speaker out, side speaker out, line in, front speaker out, mic in. But also on the top of my case/front panel I have a mic in / headphone out. They all are connected to the same onboard sound card. The headphone jack is the same as the front speaker out.

The speaker is connected to the back panel front speaker out. The headset / mic is connected to the front panel mic in and headphone out.

My headset is a mic/headset I bought for gaming. What Im trying to accomplish is send my audio for music/gaming/window sounds etc all to the speakers, which currently works. The problem is my microphone/headset I only want to out sounds from 1 program. I want my headset to only have audio from a program called ventrillo. This way when im playing a video game I can hear my friends in my ear without the annoying noise from the game interupting my friends talking to me. In both programs the video game Battlefield bad company 2 there is no option to select the output device, they just have different options that alter the sounds for your setup. In ventrillo I can easyily setup the output device and input device but the problem is the headset and speakers are both connected to an onboard audio device and after a few tests I know for a fact the front speaker in(back panel) and headset out(front panel) are both the same. I cant change the setting for them individually, without effecting both.

How can I change my setup so my headset is getting audio ONLY from the program ventrillo and my speakers pick up all my other sounds. Does this require 2 sound cards?
9 answers Last reply Best Answer
More about splitting audio headset speakers
  1. Best answer
    Just now tried this. Make sure you have the most updated version of Realtek HD Audio Manager.

    Go into your Realtek manager. Click on "Device Advanced Settings" (Top right corner). Select "Make front and rear output devices playback ... ".

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_Step1.png

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_Step2.png

    Then click on the little folder under "Device Advanced Settings" and select "Disable front panel detection"

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_Step3.png

    You should now have what you see in the following picture. Right click on Speakers (circled) and select "Set Default Device" Also make sure that your microphone is your default device and that the volume is turned up.

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_Step4.png


    Now go into Ventrilo and set it up as follows:

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_VentStep.png
  2. Okay I am trying to do this exact thing. Only thing is I don't get the "Device Advanced Settings" as shown in the picture. I do have a tiny folder that has "Disable front panel jack detection" that now plays the same audio through both devices.

    I have already tried installing the newest drivers with no luck. I just want to be able to playing music and game sounds with the speakers and have vent in my ears that way I am not having a confusion of 3 audio files in my ears causing headaches.

    Here are my specs:

    HT2000 Motherboard
    Windows 7 Home Prem (64-bit)
    Zotac GeForce 9800GT
    Realtek High Definition Audio (onboard sound)
    Audio Driver Verison: 6.0.6.6151
    DirectX Verison: DirectX 11.0
    Audio Controller: HD Audio
    Audio Codec: ALC888S

    If you need any other information I will provide it. Please if you are able to help me get rid of these headaches, I would be grateful.
  3. Hey Wetmelon....

    Thank you so much. I had been scouring the internet trying to get virtual audio drivers and such. I even put a couple old sound cards in, but couldn't get drivers for win7.

    This worked perfectly! In my case, I play my music over one channel, and my games over the other... then both cables plug into a dual volume splitter. The dual volume splitter's other end goes into my speakers. That way I can adjust the music to game noise ratio using separate volume knobs.

    Your post was the final link in the chain! Thanks again.
  4. Best answer selected by buwish.
  5. im really interested in learning to do this but i dont seem to have the realtek HD audio manager. tried to find it to download it but alas nothing.
  6. You would have to have a realtek sound card or on-board realtek sound chip to use their control manager. Interestingly enough windows default drivers already have the outputs separately, but didn't seem to have an equalizer for me or i just didn't notice it under enhancements. I was really annoyed that I couldn't reduce the bass on default system output so I finally tracked down the DP55WG intel board high definition audio is actually an ALC889 realtek and the sound manager they had had an equalizer but then I couldn't use separate outputs like before. This option is definitely kind of hard to notice and helped me thanks.
  7. I'm coping with the same problem here. The way it's explained above makes sense but my problem is that even after installing all the realtek drivers I don't have Realtek audio manager. Ive been searching on the net for an answer for a long time, but I've got nothing here, any help will be appreciated
  8. Wetmelon, I want to thank you very much for this. I have been fiddling around, trying to do this exact thing myself, only I had a Creative XFi Titanium HD card, in addition to the Realtek onboard audio. I couldn't get it to work the way I like it, which is the same way Juv3nile describes his setup (Game sounds out speakers, voice like ventrilo and skype over headphones) Eventually I came to the conclusion something was just messed up with the Creative card and removed it, but still couldn't get my setup to work exactly the way I wanted.... Until I ran across your post. This appears to be working exactly the way I want it now.

    I seem to have some hearing issues that cause voices to get 'lost' in background noise. So for me, if I'm gaming and the voice program is coming over the same speakers as the games, I often can't quite make out what is being said. I can hear that my friends are talking, but the words get jumbled up in the game sounds. And of course, game sounds are really important too. So this was very important issue for me to solve.

    Many thanks Wetmelon!
  9. Hey Wetmelon.
    I'm sitting here with the same problem, and when i do as u have done i still cant split up my sound to my headset and my second monitor speakers.
    Got a solution for that?

    Wetmelon said:
    Just now tried this. Make sure you have the most updated version of Realtek HD Audio Manager.

    Go into your Realtek manager. Click on "Device Advanced Settings" (Top right corner). Select "Make front and rear output devices playback ... ".

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_Step1.png

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_Step2.png

    Then click on the little folder under "Device Advanced Settings" and select "Disable front panel detection"

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_Step3.png

    You should now have what you see in the following picture. Right click on Speakers (circled) and select "Set Default Device" Also make sure that your microphone is your default device and that the volume is turned up.

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_Step4.png


    Now go into Ventrilo and set it up as follows:

    http://i55.photobucket.com/albums/g122/wetmelon/Vent%20Setup/th_VentStep.png
Ask a new question

Read More

High-End Audio Gaming Headsets Speakers Audio