Sign in with
Sign up | Sign in
Your question

Computer doesn't find usb printer

Last response: in Computer Peripherals
Share
November 10, 2009 1:06:26 AM

Hello,
I had to change out the mboard on my computer. My computer does not recognize the usb printer. Win XP, Canon MF4150. What I have tried so far to no avail:

Plug printer into every USB port.
Use different USB cable.
Uninstall and reinstall the printer driver.

The computer will recognize other devices plugged into the USB ports.

Thanks in advance for your help.
November 10, 2009 2:56:48 PM

Do you install the lasted driver? or the cd driver.
November 10, 2009 5:19:31 PM

I downloaded the latest driver and installed that. Also, I spoke with Asus tech support RE the bios for the mboard. They suggested to set legacy support to disable, and plug and play OS to yes. Prior to that, the legacy support was set to auto, and Plug and Play OS was set to no. Still don't have it working, but am about uninstall and reinstall the driver again.
Related resources
November 10, 2009 5:38:42 PM

Uhmm, maybe the unsigned drivers.

Right click on my PC, properties, hardware tab, drivers, signed drivers, and select the first one. "Nothing: Install the software without ask for authorization"
November 10, 2009 11:24:40 PM

Well, the bios changes and your suggestion have not worked. I'm continuing to try things. I right clicked on the USB root hubs and made sure that they will not be turned off in power management. still no change.
November 11, 2009 7:24:04 PM

I hate to ask the obvious, but did you turn the printer on after you plugged it in? It won't recognize the hardware until it's on.
!