Sign in with
Sign up | Sign in
Your question
Solved

Computer freezing after exiting games. Help

Last response: in Windows 7
Share
October 15, 2012 11:53:46 PM

Hello.

My system is a Toshiba laptop p850-057

i7-3610QM
8GB DDR3,
750GB HDD S-ATA
NVIDIA® GeForce GT 630M
Genuine Windows® 7 Home Premium 64bit

More specs are listed here :
http://support.toshiba.ca/support/isg/center/en/index.a...



MY PROBLEM:

Ever since i bought this laptop, it has been running desktop applications very fine for countless hours, but when it comes to gaming, I have had all sorts of troubles, the main problem being :

1. The whole system freezes (video lock-up, nothing to do but hold power button for a hard reset) shortly after exiting games that I have played for 30mins to 2-3 hours. I can use the desktop for 0-45 seconds before the freeze happens. It mostly happens after exiting games like Diablo3 or Heroes VI.

2. In other cases, in games like Skyrim or Max Payne 3, the freeze happens in-game. Max Payne freezes during the cutscenes (which often the video becomes out of sync with the audio). Skyrim freezes have been random. I initially suspected GPU overheating, but after running a series of tests like a video card stress test that ran without a freeze for hours, playing the games with the lowest gfx settings, I've concluded that overheating wasn't causing the freezes.

All my video card drivers are up to date as well as the bios.


I contacted Toshiba tech support to be answered by, excuse my lack of respect here, total idiots who didn't know the first thing about computers (ie, claiming a GeForce 7800 was so much better than the GeForce GT 630M just because of the higher number). Aslo their ultimate conclusion (after speaking to senior tech support) was that I shouldn't be playing those games on my pc because it is not good enough!!!!!!!!!

I am pretty hopeless and seeking great wisdom here.

Best solution

a b $ Windows 7
October 16, 2012 9:16:36 AM

In a way the tech is right.
But you can try this:
One thing is to make sure that the priority of the game is highest, there maybe other processes running that have priority over the game.
Including for instance security programs and antivirus. The latest of which have gaming modes.
If there is not a gaming mode on the security try turning it OFF.

Another good thing is to eliminate as many unused / junk / UN-needed applications.
turn off the screen saver
Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.
Share
October 16, 2012 9:39:26 AM

Try accessing msconfig and disable those apps you don't want to be running upon startup. I forgot the tab's name but I think it's the third one. Be careful disabling though, you might disable some system application, just those unnecessary ones
m
0
l
Related resources
October 16, 2012 12:54:55 PM

Another good thing is to eliminate as many unused / junk / UN-needed applications. done...

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.
... Couldn't do it... Can't access my bios b/c it is set in quick boot mode and I don't know how to acesss it anymore.

Now open the hardware manager profiles... done....

Try accessing msconfig and disable those apps you don't want to be running upon startup. I forgot the tab's name but I think it's the third one. Be careful disabling though, you might disable some system application, just those unnecessary ones done...

Off to a few days of testing.

Now from what I understand, it would be a power management issue??? Note that i always leave the AC power plugged in.
m
0
l
October 23, 2012 12:31:11 AM

After a couple days of testing, I've come to the conclusion that the power management options are the key to my problem....

Apparently the most economic power option like "eco" or "power saver" has my system running stable, and the more i tend towards "Maximum performance" power management options, the more my system freezes.

I've been able to play max payne 3 for 3 hours without a single freeze on "eco"... which b4 i couldn't finish a isngle level without a freeze.

So I guess i can say its a SOLVED issue... althought I really don't understand the reasons... thanks for your answers ... you guys put me in the good track... I would've never suspected power management to be an issue... expecially that I keep the laptop plugged in with AC power. Anyhow... thanks alot, you've been more efficient than the completely incompetent Techhies from Toshiba.


soundguruman said:
In a way the tech is right.
But you can try this:
One thing is to make sure that the priority of the game is highest, there maybe other processes running that have priority over the game.
Including for instance security programs and antivirus. The latest of which have gaming modes.
If there is not a gaming mode on the security try turning it OFF.

Another good thing is to eliminate as many unused / junk / UN-needed applications.
turn off the screen saver
Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.

m
0
l
October 23, 2012 12:31:55 AM

Best answer selected by Nytefury099.
m
0
l
!