Sign-in / Sign-up
Your question
Closed

Switch language by keyboard shortcut

Tags:
  • Switch
  • Japanese
  • Keyboards
  • Windows XP
Last response: in Windows XP
August 9, 2005 4:41:12 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Hi,

I've installed the Japanese input method so I could type Japanese in my
email.

My emails are always a mix of English and Japanese, so I need to switch back
and forth both language usually. My trouble is every time I switched to
Japanese, it's default to inputting English, so I need to grab my mouse and
change the input mode to Hiragana before I could type Japanese. I had
changed the default input mode to Hiragana but it still start from the
English (Romanji) input mode.

I know how to switch from English to Japanese by pressing Alt + Shift, but
once I'm in Japanese, does someone knows how to change the input mode from
Romanji to Hiragana?

Thanks.

More about : switch language keyboard shortcut

Anonymous
August 9, 2005 4:41:13 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Windows XP Japanese Input
http://greggman.com/japan/xp-ime/xp-ime.htm

(Select "Switch between input languages" and pick "Change Key Sequence...")

What is an IME (Input Method Editor) and how do I use it?
http://www.microsoft.com/globaldev/handson/user/IME_Pap...

--
Carey Frisch
Microsoft MVP
Windows XP - Shell/User
Microsoft Newsgroups

-------------------------------------------------------------------------------------------

"lee" wrote:

| Hi,
|
| I've installed the Japanese input method so I could type Japanese in my
| email.
|
| My emails are always a mix of English and Japanese, so I need to switch back
| and forth both language usually. My trouble is every time I switched to
| Japanese, it's default to inputting English, so I need to grab my mouse and
| change the input mode to Hiragana before I could type Japanese. I had
| changed the default input mode to Hiragana but it still start from the
| English (Romanji) input mode.
|
| I know how to switch from English to Japanese by pressing Alt + Shift, but
| once I'm in Japanese, does someone knows how to change the input mode from
| Romanji to Hiragana?
|
| Thanks.
December 10, 2008 11:00:36 PM

That really doesn't answer the question. Neither of those pages gives a solution to what was asked.

The "Change Key Sequence..." setting affects the Alt-Shift the OP mentions using to switch from English to Japanese.

I know it's a really old post, but does anyone have a real answer?
Related resources
December 10, 2008 11:18:55 PM

K, I found one solution that hopefully can help in the majority of cases.

http://forum.japantoday.com/viewtopic.php?f=10&t=930296

Essentially once the Japanese keyboard is selected (through Alt-Shift, e.g.) you can change the input mode to hiragana by pressing Ctrl-CapsLock. That just goes TO hiragana; i.e. it's not a toggle. And through experimentation I just found that Alt-CapsLock goes to katakana.

...but this guy knew that already:

http://forum.soft32.com/win4/changeing-japanese-charcte...

And he says that Shift-CapsLock goes to half-width alphanumeric. I found if you do that, and then Alt-CapsLock, you get half-width katakana. So the only mode left undiscovered is full-width alphanumeric, but that's ugly as heck anyway so who cares?
May 28, 2009 2:27:18 PM

Hello,

Try this in order to switch between languages:

http://www.LangOver.com

With LangOver 5.0 youll be able to convert your text quickly
between languages. Just click F10 and your text will be fixed!


If keyboard layout was in a wrong language,
and you forgot to use "ALT+SHIFT"... you can use langover to fix it.


LangOver is free and Supports ANY language!

thanks,
Joe

Anonymous
November 19, 2009 12:19:29 AM

I was looking for this as well. It seems Alt+~ works once you're in Japanese mode. Just be careful if you have the stumbleupon toolbar...
May 16, 2010 4:21:40 PM

thank you! this is very useful!

Shift + capslock seems to have helped go from English to Hiragana on 64bit Windows 7 Ultimate.

Does anyone know if it's possible if I could set Hiragana to load by default when going into Japanese mode? It makes no sense to me that English is being loaded by default as I've just changed from English mode over.