Sign in with
Sign up | Sign in
Your question

The Network and Sharing Center is not recognizing the installed NIC

Last response: in Windows 7
Share
October 17, 2012 12:54:23 PM

Hay to all :-)
My name is Shay and I'm an IT guy for several SMB companies.
Recently I have encounters a problem with a client's windows 7 64Bit Computer.

The network is connected and working fine (well not fine, but will get there).
Bat the Network and Sharing Center is not recognizing that it is connected or that there even is a NIC installed.
I can surf the net and connect to other computers, but, any program that depends on the information from that specific component Seams to not be able to connect (IE Logmein) and also I'm unable to configure my network as a "work network" so I had to remove the windows firewall so I will be able to connect 2 my SQL server and network shares from other computers on the company's network.
Solutions I have already tried:
1. Reinstall NIC driver from gigabyte website.
2. Install Realtek Ethernet Diagnostic Utility
3. Installed FixItCenter from Microsoft.
4. Netsh winsock reset (As admin)

System:
OS: Windows 7 pro 64 bit SP1
MB: Gigabyte H61MA-D3V
RAM : 8GB
NIC: Realtek RTL8168/8111 PCIe Gigabit Ethernet Adapter
Connection type: Wired LAN

Please see pics below (It is written in Hebrew but I believe that you'll get the jest)

















October 22, 2012 6:56:50 AM

Hi Shay. I'm a IT guy myself, hehe. Believe it or not, sometimes the latest drivers can actually BE the cause of issues like these. You might try rolling back the driver to a previous version if possible. If that doesn't work, you may have to tinker with the Windows registry a bit (just be sure to back it up first) as it could easily be a corrupted value there. Did your client specify at what point this issue arose or what activities were performed (software installed, etc) just prior to this happening? Have you tried looking at the Device Manager to see if there are any yellow alert flags? Have you tried restarting the computer in Safe Mode WITH Networking? Hopefully that gets you started toward finding a resolution. Cheers! ;) 
m
0
l
October 22, 2012 12:47:08 PM

Hi DevITIS :-)
And thanks for your reply.
It is a newly Installed computer with SQL Express server (For Hashavshevet http://www.hashavshevet.co.il/default.asp it is an accounting software)

It has started after the import of the Hashavshevet databases, and the uninstall process of the Hashavshevet software from this computer.
I have also tried to do a clean boot (msconfig) and roll back to the NIC driver, but no dice…
:-$
m
0
l
October 23, 2012 8:19:24 AM

Hmmm... could be a corrupt registry from a bad install? Maybe give CCleaner a go to do a thorough scan of the registry. Also, a clean boot is good to try, but for this problem, specifically try booting in Safe Mode WITH Networking. See if your connection becomes available then. :) 
m
0
l
!