ASUS EEEPC 1005

Problem...
1 yr old (no physical damage) n450, 2gb ram, Win 7 netbook was stuck in startup repair loop. Would boot to safe mode, and safe mode w/ networking. Now after attempting an F9 factory system resore it gets to loading drivers, then fails, says it has to restart then fails again.

Things I've done...
System restore to several point-all successful, no change in problem
chkdsk- no problems
Windows memory diagnostic- no problems
Tried repairing with a full Win 7 disk in an ext DVD drive. Failed.
Windows

I'm thinking a hardware issue...but where do I start?

My wife LOVES this little machine, so any help is much appreciated!!
11 answers Last reply
More about asus eeepc 1005
  1. Hard-drive is a very probable cause, so is RAM. The Windows checkdisk is useless to find hardware issues on the drive. It checks the file system, but is not good at all with finding physical issues.

    Try running with 1 gig of RAM if it has two sticks, try both, one at a time.
    If that still causes crashing, buy a new hard-drive and install windows on that see if that helps. Although you either need to boot it enough to create a restore DVD set, or use your own Windows disks, or contact ACER and have them send you a disk set, or buy a drive from them directly with the thing setup already.
  2. Thanks for the reply. I changed back to original 1gb stick. No difference.

    I'm going to try some hd check utilities run from the ext dvd drive, and see what's up.

    In your opinion what is the best/easiest hd utility?
  3. ASUS may have one, either in the BIOS of the laptop as an option or from a downloadable utility.
  4. I used Seagate's hard drive diagnostic utility since that's the HD that's in it. Both short and long tests confirm a good hard drive.

    RAM- eliminated
    HD-eliminated

    Any other ideas?

    A suggestion for a general hardware diagnostic tool to go beyond RAM and HD?
    In a desktop, I would just start pulling parts until I found the culprit, but I can't do that with a netbook.

    Thanks for any help in advance...
  5. If the hard-drive tested as good, could be any other hardware, motherboard, ram (or ram socket), etc...

    Try running a Linux Live boot see if it starts up OK, or install Linux right on the drive see if that works.

    Maybe something is up with the drive anyway, I have not see a low-level drive test utility give a false report, but I have seen other test utilities do that.
  6. OK, I used Mini XP on a flash drive to fully(slow) reformat the drive. Reloaded win 7 from the recovery partition. SUCCESS!!!!

    I let Windows do it's updates. After it installs the updates, BAM!! BSOD!
    STOP 0x0000007F (0x00000000,0x00000000,0x00000000)
    -divide by zero fault

    What about this idea...
    Would Windows updates try to install a generic driver that is incompatible with at netbook?

    If so, how do I find the offending update?

    How do I prevent further install in the future?
  7. Try installing Windows 7, run all of the drivers and patches from ASUS, then let Windows do the updates.

    I have not seen Windows 7 mess up drivers if it did not know what they were. I ran a few laptops that did not have Windows 7 drives, the hardware Windows 7 could not find it left as Generic VGA and such, but they worked fine.

    Could be CPU, could be RAM here. Try a BIOS update also, maybe some CPU instruction is having issues.
  8. Loading Dump File [C:\Users\Mike\Downloads\BSODDmpFiles\mraimondi\Windows_NT6_BSOD_jcgriff2\123011-59217-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available

    Symbol search path is: SRV*c:\users\mike\documents\symbols*http://msdl.microsoft.com/download/symbols
    Executable search path is:
    Windows 7 Kernel Version 7600 MP (2 procs) Free x86 compatible
    Product: WinNt, suite: TerminalServer SingleUserTS Personal
    Built by: 7600.16905.x86fre.win7_gdr.111025-1503
    Machine Name:
    Kernel base = 0x81a43000 PsLoadedModuleList = 0x81b8b810
    Debug session time: Fri Dec 30 13:30:51.409 2011 (UTC - 7:00)
    System Uptime: 0 days 0:00:47.221
    Loading Kernel Symbols
    ...............................................................
    ..............................................
    Loading User Symbols
    Loading unloaded module list
    .
    *******************************************************************************
    * *
    * Bugcheck Analysis *
    * *
    *******************************************************************************

    Use !analyze -v to get detailed debugging information.

    BugCheck 7F, {0, 0, 0, 0}

    Probably caused by : monitor.sys ( monitor!BrightnessTargetToPercentage+32 )

    Followup: MachineOwner
    ---------

    0: kd> !analyze -v
    *******************************************************************************
    * *
    * Bugcheck Analysis *
    * *
    *******************************************************************************

    UNEXPECTED_KERNEL_MODE_TRAP (7f)
    This means a trap occurred in kernel mode, and it's a trap of a kind
    that the kernel isn't allowed to have/catch (bound trap) or that
    is always instant death (double fault). The first number in the
    bugcheck params is the number of the trap (8 = double fault, etc)
    Consult an Intel x86 family manual to learn more about what these
    traps are. Here is a *portion* of those codes:
    If kv shows a taskGate
    use .tss on the part before the colon, then kv.
    Else if kv shows a trapframe
    use .trap on that value
    Else
    .trap on the appropriate frame will show where the trap was taken
    (on x86, this will be the ebp that goes with the procedure KiTrap)
    Endif
    kb will then show the corrected stack.
    Arguments:
    Arg1: 00000000, EXCEPTION_DIVIDED_BY_ZERO
    Arg2: 00000000
    Arg3: 00000000
    Arg4: 00000000

    Debugging Details:
    ------------------


    BUGCHECK_STR: 0x7f_0

    TRAP_FRAME: 87453590 -- (.trap 0xffffffff87453590)
    ErrCode = 00000000
    eax=00002710 ebx=00000000 ecx=00000000 edx=00000000 esi=907dea88 edi=6f821738
    eip=8bfbf64a esp=87453604 ebp=87453604 iopl=0 nv up ei pl zr na pe nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010246
    monitor!BrightnessTargetToPercentage+0x32:
    8bfbf64a f7f1 div eax,ecx
    Resetting default scope

    CUSTOMER_CRASH_COUNT: 1

    DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

    PROCESS_NAME: System

    CURRENT_IRQL: 0

    LOCK_ADDRESS: 81ba8f60 -- (!locks 81ba8f60)

    Resource @ nt!PiEngineLock (0x81ba8f60) Available

    WARNING: SystemResourcesList->Flink chain invalid. Resource may be corrupted, or already deleted.


    WARNING: SystemResourcesList->Blink chain invalid. Resource may be corrupted, or already deleted.

    1 total locks

    PNP_TRIAGE:
    Lock address : 0x81ba8f60
    Thread Count : 0
    Thread address: 0x00000000
    Thread wait : 0x0

    LAST_CONTROL_TRANSFER: from 8bfbf64a to 81a872eb

    STACK_TEXT:
    87453590 8bfbf64a badb0d00 00000000 00002004 nt!KiTrap00+0x8b
    87453604 8bfbf95a 6f821738 6f821764 8bfbd248 monitor!BrightnessTargetToPercentage+0x32
    87453620 8bfc0343 6f821764 860634c8 8ce29ec8 monitor!BrightnessInit+0x98
    8745373c 860352c3 731d6180 87453778 860634c8 monitor!EvtDriverDeviceAdd+0x3c3
    87453758 86035755 731d6180 87453778 8da6b910 Wdf01000!FxDriverDeviceAdd::Invoke+0x28
    87453964 86035821 91ff04b0 8745398c 81a57767 Wdf01000!FxDriver::AddDevice+0xc1
    87453970 81a57767 8da6b910 91ff04b0 8fbfb3e8 Wdf01000!FxDriver::AddDevice+0x1b
    8745398c 81bf27cf 91ff04b0 86035806 00000004 nt!PpvUtilCallAddDevice+0x19
    874539d4 81beb306 8da6b910 86035806 00000002 nt!PnpCallAddDevice+0xb9
    87453aa8 81bea892 8fbfb3e8 87453cd0 8d80b538 nt!PipCallDriverAddDevice+0x565
    87453ca4 81be4636 83191208 8d80b538 87453cd0 nt!PipProcessDevNodeTree+0x15d
    87453cd8 81a56f7f 81ba6e80 831ca798 81b7d5bc nt!PiProcessReenumeration+0x74
    87453d00 81ab106b 00000000 00000000 831ca798 nt!PnpDeviceActionWorker+0x224
    87453d50 81c51a55 00000001 9eee4584 00000000 nt!ExpWorkerThread+0x10d
    87453d90 81b03219 81ab0f5e 00000001 00000000 nt!PspSystemThreadStartup+0x9e
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19


    STACK_COMMAND: kb

    RAM- same behavior with different physical sticks- ruled out
    Bios- updated to latest moths ago- never had a problem- no new version out

    This is an analyses of my BSOD dumo from another forum...

    "This was caused by the generic monitor.sys that Windows loads for your monitor, and it appears to be related to the brightness calculation causing a divide by zero fault."

    FOLLOWUP_IP:
    monitor!BrightnessTargetToPercentage+32
    8bfbf64a f7f1 div eax,ecx

    SYMBOL_STACK_INDEX: 1

    SYMBOL_NAME: monitor!BrightnessTargetToPercentage+32

    FOLLOWUP_NAME: MachineOwner

    MODULE_NAME: monitor

    IMAGE_NAME: monitor.sys

    DEBUG_FLR_IMAGE_TIMESTAMP: 4a5bc286

    FAILURE_BUCKET_ID: 0x7f_0_monitor!BrightnessTargetToPercentage+32

    BUCKET_ID: 0x7f_0_monitor!BrightnessTargetToPercentage+32

    Followup: MachineOwner
    ---------
  9. Could be possible to find out from the MS site which update has a monitor.sys file with it, and set it so it never downloads.
  10. How can I find this out?

    I got it up and running again, updated ALL ASUS software and driver, but every time I do a Windows update, the problem returns, then it's HOURS to get it cleared up.
  11. Something funny I just notices, the crash file talks about a Vista driver.

    CUSTOMER_CRASH_COUNT: 1

    DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT


    Don't run the full Windows update, try manually downloading SP1 and run that.
Ask a new question

Read More

Hewlett Packard Computers