Closed Solved

Can't download Windows 7 Home ISO file on a USB?

It only gives me the options to burn the disk, and I can't find an option to install it to a USB drive.

What am I doing wrong?
70 answers Last reply Best Answer
More about download windows home file
  1. Because you can't do that. You need a disc.
  2. You need the windows disk? I asked in another thread about whether I need one and somebody gave me a link to download the ISO files for it O_o. Are you telling me it was a fake?

    I saw that link before dodger, but I don't get it; isn't it saying I can download the file from the download manager onto a usb? Another poster said that I only need the access key and didn't need to make the purchase online to download the file.

    I'm so confused >.<
  3. http://www.mydigitallife.info/windows-7-iso-x86-and-x64-official-direct-download-links-ultimate-professional-and-home-premium/

    Make sure you download the correct version of home, e.g. home premium.


    Download the ISO then use a tool to put it on to a USB drive.
    http://www.isotousb.com/
  4. You have to make the usb bootable which is what the tool is for.
  5. Well I got the correct version of windows from the site but it only gives me the option to burn a DVD.
    I don't understand, do I actually have to burn windows?
    Sorry for the stupid questions, I'm a complete idiot :p.
  6. Just use the link aaab gave you, and run the software. Find the ISO you downloaded (Should be in Downloads) then where it says ISO Browse find your ISO and make sure your USB device has been found and the correct letter eg F is displayed. Check 'Bootable' and then Burn
  7. Ok, I downloaded the windows isotousb program and the ISO, however after the half hour and of it putting windows on the USB it says it's not bootable?
  8. Taken from: http://www.intowindows.com/how-to-install-windows-7vista-from-usb-drive-detailed-100-working-guide/

    No tools required works with official downloads or possibly less offical ones.

    1. Plug-in your USB flash drive to USB port and move all the contents from USB drive to a safe location on your system.
    2. Open Command Prompt with admin rights. Use any of the below methods to open Command Prompt with admin rights.
    *Type cmd in Start menu search box and hit Ctrl+ Shift+ Enter.
    Or
    *Go to Start menu > All programs > Accessories, right click on Command Prompt and select Run as administrator.
    3. You need to know about the USB drive a little bit. Type in the following commands in the command prompt:
    First type DISKPART and hit enter to see the below message.

    Next type LIST DISK command and note down the Disk number (ex: Disk 1) of your USB flash drive. In the below screenshot my Flash Drive Disk no is Disk 1.
    4. Next type all the below commands one by one. Here I assume that your disk drive no is “Disk 1”.If you have Disk 2 as your USB flash drive then use Disk 2.Refer the above step to confirm it.
    So below are the commands you need to type and execute one by one:
    SELECT DISK 1
    CLEAN
    CREATE PARTITION PRIMARY
    SELECT PARTITION 1
    ACTIVE
    FORMAT FS=NTFS
    (Format process may take few seconds)
    ASSIGN
    EXIT
    Don’t close the command prompt as we need to execute one more command at the next step. Just minimize it.

    5. Next insert your Windows7/Windows 8 DVD into the optical drive and check the drive letter of the DVD drive. In this guide I will assume that your DVD drive letter is “D” and USB drive letter is “H” (open my computer to know about it).
    6. Maximize the minimized Command Prompt in the 4th step.Type the following command now:
    D: CD BOOT and hit enter.Where “D” is your DVD drive letter.
    CD BOOT and hit enter to see the below message.
    7. Type another command given below to update the USB drive with BOOTMGR compatible code.
    BOOTSECT.EXE /NT60 H:

    Where “H” is your USB drive letter. Once you enter the above command you will see the below message.
    8. Copy your Windows 7 or Windows 8 DVD contents to the USB flash drive.
    9. Your USB drive is ready to boot and install Windows 7 or Windows 8. Only thing you need to change the boot priority at the BIOS to USB from the HDD or CD ROM drive. I won’t explain it as it’s just the matter the changing the boot priority or enabling the USB boot option in the BIOS.
    Note: If you are not able to boot after following this guide means you haven’t set the BIOS priority to USB. If you got any problem in following this guide feel free to ask questions by leaving comment.
    Update on Jan 11, 2012: If you find this guide difficult to follow, please use the easy-to-use guide to create a bootable USB to install Windows 7 or Windows 8 using official tool.
    This guide works 100% for Windows 8 as well. Make sure you follow all steps correctly and launch the Command Prompt with admin rights (as given in the guide) to avoid errors. Good luck!


    For Step 5 to 8. If you only have an ISO or IMG file of the Windows Disc then use http://www.slysoft.com/en/virtual-clonedrive.html to mount the ISO and copy the contents from the virtual CD drive over to the USB stick. Or you can grab 7zip (7zip.org) and just extract the ISO.
  9. ^ Uh....wait, what?

    O_o

    Do I have to do all that just to make the ISO bootable from the USB?
  10. Well I just downloaded the ISOtoUSB freeware and now my flash drive isn't working at all >.<
  11. Not the software's fault I guess, at 1st I thought mebbe you'd downloaded from a dodgy site, but it's the same software from CNET. Just your luck the drive failed...
    EDIT... Oh dear, read the CNET reviews
    http://download.cnet.com/ISO-to-USB/3000-2094_4-12178301.html
    Link to EaseUs in case you need it
    http://download.cnet.com/EaseUS-Partition-Master-Home-Edition/3000-2248_4-10863346.html
    http://download.cnet.com/Easeus-Partition-Recovery/3000-2248_4-75279786.html

    Perhaps it would be safer to use M'soft Download tool after all...
  12. Dangit...
    This whole making your own computer thing has been quite an experience for me...guess its off to best buy tomorrow for another flash drive.
  13. On a side note, it seems as if the space on the flash drive is still recognized in disk manager. On top of that, the flash drive does light up when plugged in. Am I getting my hopes up or are these good signs?
  14. Sounds retrievable, perhaps even from Disk Manager , try rt click to see if it can be assigned a letter...formatted even
  15. Considering burning the ISO to a DVD yet? On someone else's machine pehaps? Save a lot of hassle...
  16. When I installed w7 from my flash drive (I have no dvd drive) I just formatted it to ntfs and unpacked the iso onto it.
  17. I have no dvd drive and nobody I know has one as well >.<.

    Gonna try that stuff you mentioned with disk manager now...
  18. Ok well apparently the flash drive is still F: and it recognizes how much space is on it. It asks me to format it for it to work but it just won't format. I tried ntfs and FAT and exFAT. I see no option to format for FAT32 (not sure if that's possible, but the isotousb program default format was FAT32).
  19. Problem again...the windows tool requires a purchase to make the USB file bootable.

    Not sure what to do :c

    Oh nvm, it says I have to run the bootsect.exe file...can't figure out how to do that :p.
  20. Open CMD prompt as admin

    Enter D: CD BOOT and hit enter. Where “D” is your DVD drive letter.
    Enter CD BOOT and hit enter
    Enter BOOTSECT.EXE /NT60 H: Where "H" is your USB Drive Letter
  21. Updated + Pictures.


    This is done with the Virtual Cd-Rom as Drive K: and the USB Drive as Drive L:

    Pregame:

    Install http://www.slysoft.com/en/virtual-clonedrive.html

    Begin !

    Right click your ISO or IMG file and mount in virtual CD-ROM see pic below




    Open Command Prompt as admin and do as follows. When doing Select Disk don't just use disk 5 because I did choose your USB drive.




    Copy the contents of drive K: to drive L:



    Insert into machine that needs OS and boot from USB, be sure you have set your BIOS to boot from the USB drive.
  22. ^ Wow! XD thanks for that, I didn't expect anything as awesome as that :D!

    But I have one question, you said virtual cd-rom drive? Do you mean the dvd drive or...am I missing something important >.<?

    I'll start dl'ing that slysoft link, thanks again for the help!
  23. Slysoft creates the virtual Cd rom device it lets you mount the ISO like you have it in a CD-rom to copy the bootsect over to the USB drive. So I used Slysoft's program to mount the w7.iso I used in my K drive which is the drive letter assigned to the virtual CD-rom
  24. EDIT nvm XD
  25. NVM again XD, everything is going exactly like the diagram, thanks again!
  26. Oh....Just hit a problem. Once I type in bootsect.exe etc...
    It gives me the error message that bootsect is not a valid win32 application.
  27. The issue is you're trying to run a 64b app from a 32b system.

    Download this: http://www.sevenforums.com/attachments/installation-setup/47060d1263222191-32-bit-bootsect-bootsect7600x86.zip

    Extract it, put the folder in your C:\, rename it to bootsect

    Do as screen shot shows. This should correct issue I did it on my system and it worked, however my system is not 32b.





    Answer found here: http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_install/bootbootsectexe-is-not-a-valid-win32-application/5d8c84fd-0e2c-40c8-af2c-14e0b2c160d3
  28. avatarair said:
    Problem again...the windows tool requires a purchase to make the USB file bootable.

    Not sure what to do :c

    Oh nvm, it says I have to run the bootsect.exe file...can't figure out how to do that :p.


    Truly can't understand why the Windows 7 download tool didn't work for you, I found it simplicity itself! Anyway, as long as the end result is a bootable USB... and thanks to netwalker, the Windows tool only seems to work for Windows ISOs, anything else generates a 'not a valid ISO' error...
  29. The windows tool will only work with Microsoft released ISO's (in most cases) if you make a copy of a CD even to an image you can get a Anchor Volume Descriptor Pointers (AVDPs) error that makes it not pass the ISO check within the Windows tool. This can be corrected by using a program called isoavdpcopy.exe to correct the pointers in the ISO file. I have used this to fix some images for use with the windows tool but at this point I honestly find it faster to just do it all via CMD to make the installer vs trying to get the windows tool to work. isoavdpcopy is not a 100% solution I remember having an Enterprise Win7 ISO that it didn't like.


    isoavdpcopy.exe DL link : http://www.withinwindows.com/files/uploads/2009/11/isoavdpcopy_0.1.zip
  30. Ok, I downloaded it, copied it to C:, but when I type in cd bootsect, it says that the specified path is not found.
  31. dodger, apparently the problem is I am trying to do this on a 32 bit system. I recently found out that I have no access to any 64 bit systems so I have to find a way around it, hopefully :p.
  32. I'd try using that tool, but when you had the other windows ISO File that it didn't like, did it break the flash drive or just not work?
  33. Just told me that the ISO was not acceptable, or words to that effect. Try it, it should work as long as the ISO is legit...all you're doing is downloading a picee of software to do all the work for you!
  34. avatarair said:
    Ok, I downloaded it, copied it to C:, but when I type in cd bootsect, it says that the specified path is not found.



    Did your cmd prompt say C:\ before you entered cd bootsect? If you weren't at the base of the C drive it isn't going to see the folder to change directory (cd) to.

    When you first open Cmd prompt it's going to be somewhere like

    C:\Users\Administrators>

    You do a

    cd \

    To get it to C:\

    Then do the

    cd bootsect

    To tell it you want to open the bootsect directory in the directory you are already in ( C: )

    Alternatively if you did that then you named the folder wrong or misspelled something.
  35. the file in C: is called bootsect, should it be named cd bootsect?
    And it is at C: and it's still telling me the specified path in invalid =\.

    I can add pictures if you want, would those help >.<?
  36. Alright well I just typed in bootsect>bootsect.exe /nt60 E:
    And it tells me access is denied >.<

    This is an administrator account as well, so it can't be that.
  37. Did you run CMD prompt as an admin ? Right click CMD and run as admin.
  38. Yes a picture would help, at the C:\ do a dir then hit enter and show me.
  39. Ok, thanks for that, I didn't run it as an admin, I thought you just had to be logged into an admin account, my bad.

    But now when I try it it says that "the process cannot access this file because it is being used by another process". I'm not sure why as I closed everything else, but I'll restart my computer or something >.<

    Here's the picture you asked for (I'm not sure exactly what dir is but I assumed this is what it meant)

  40. Ah yea you moved the bootsect.exe into the C:\ instead of the whole folder so no need for the cd bootsect, you can just bootsect.exe /nt60 L: as you found out.

    Let me know what happens after the reboot.

    And Dir lists everything in the current directory.

    You can do dir /p to browse through a large directory with it pausing every time the page fills.
  41. Weird...it stills tells me that the file is being used by another process.

    Should I try this in safe mode or something?
  42. Try extracting the file again, looking in my bootsect folder the bootsect.exe file is 103,312 bytes where yours is 0 from the screenshot.
  43. Ok well I extracted it again, it's now 101 kb, but I still get the same message >.<
  44. Can you give me the exact message it gives you or a screenshot of it.
  45. So....anything >.<?
  46. I take it the M'soft Download tool was an abject failure as well??
Ask a new question

Read More

Download Windows 7