Sign in with
Sign up | Sign in
Your question

XP registry_error

Last response: in Windows XP
Share
August 23, 2002 9:44:11 PM

I have two identical systems:

-Antec case (it’s very common now, the one with all the horizontal air vents in front and removable drive bay inside easy access side panel, etc.) it has a 300-watt power supply,
-Abit KT7A-RAID motherboard (setup using 2 HDD’s in a raid 0 configuration),
-2 Maxtor 40 GB HDDs (7200rpm),
-one system has; one 256MB pc133 memory chip (by Micron), the other has two of the same,
-AMD Athlon (Thunderbird) 1.2Ghz (266 max fsb if I remember correctly),
-TNT 2 32MB AGP video card (by I/O Magic)
-Santa Cruz pci sound card by (Turtle Beach),
-US Robotics 56k Hardware modem pci,
-Yamaha 20x writer 2200 something,
-I/O Magic 48x or 52x cd rom,
-floppy 3 ½”,
-NO NIC
-nothing OEM, all manufacturer


The system with 256 MB mem, that one keeps getting blue screened with "registry_error" but this blue screen and reg error did not happen when this system was running 98se. The system will boot fully into normal OS and backround for about 2-3 seconds and then…big blue.

So here is what I’ve tried so far:

Firstly, I haven’t done any BIOS or OS updates (but neither did I on the other/identical system)

I jumped the cmos settings and started over loading all optimized defaults, replaced memory, replaced hard drives (raid 0), formatted and ran a clean install (xp pro), replaced the only non xp component by upgrading from the montego II to the Santa Cruz, and installed "NO pci cards". I thought this would do it and allow me to move up from here trying to isolate the problem. Well after a few days of doing nothing but word processing I got the registry error again, last night. What is most baffling is that my other pc (which is 100% identical) does not give this type of error at all.

I finally was able to boot into safe mode, (most times it wouldn’t let me boot even into safe mode) and here is what I found:

In event viewer/system there are a lot of red x's and the event mostly repeated is ACPI. When I look at properties it says that:

"acpi is attempting to write to an illegal IO port address (0xcf8) which lies in the 0xcf8-0xcff protected range this could lead to system instability"

and then it suggests contacting the vendor. It also shows the same report with acpi (in event viewer)but using 0x70 and 0x71.

Other event viewer red x's are:

"wmi adapter" "perfnet" "vss" "event system" and "com+" , however I located these while in safe mode so I don't know if that has any relevance.

Also if it will help at all the exact error is:

*** stop: 0x00000051 (0x00000004, 0x00000001, 0xe1af7758, 0x00800210)

the forth section of numbers in this error, changes every time the pc boots, I have a list of many of them.

That was my business pc.


My other pc, which is more for play has 512MB mem and is otherwise identical.

Its problem is that it locks up completely solid, with ctrl alt del useless, and I must restart. Usually when playing games like Age of Empires but sometimes even while viewing an email or website that has a lot of graphic in motion. And now that I have changed to the Santa Cruz sound card some sound or tic will trigger it and the pc will lock while in a fast repetition of the last sound. Other wise it has no problems. And with this one too these problems are timed with my installation of xp (although on this one I may have locked up while playing when using 98se also, I don’t fully remember).

Lastly, does anyone know why windows xp opens menus and programs with a sort of slow fade in? Can anything be done about that?

Thanks
Ian
vienna18@hotmail.com

More about : registry error

August 26, 2002 11:33:22 AM

couple of things:

1) I'm thinking a RAM problem. Have you EXHAUSTIVELY tested all possible memory configurations? What I mean is, bring the 2 sticks from the good machine and try each, one at a time in the bad machine. Also if you could post here what the RATED speed (CAS and FSB) of the sticks are, and how fast you're driving them in the BIOS?

2) Is it definitely being cooled well enough? Is the HSF a good one? Any way of checking the temps on the CPU?

3) have you tried swapping the PS from the good case?

4) Since you have identical mobo's, AFTER you've tried all the other suggestions above, I would swap boards. Leave everything else the same. Hopefully you're running RAID0 on both machines, then the board swap should go smoothly.

That the sort of stuff I would try.

<i>It's always the one thing you never suspected.</i>
August 26, 2002 11:53:30 PM

I have been avoiding swapping motherboards since one is at my office and the other is at home (but they are both raid 0).

Will swapping motherboards (or memory or power supplies etc.) while the error is happening fix it and bring it back to OS, or will OS still need to be reinstalled?

My question is that it is difficult to tell where the problem lies, because even without doing anything other that reinstalling OS the pc will work fine for days, and then...WHAMO!

So since swapping one thing or another will not show an immediate repair of the problem then how will we know if that did it?

We just wait days and days to see if it happens again or not?

I'll need to have both pc either apart or under test for a while. Is there really no other way to figure this out?

What's the first thing you would do?


I have tried swapping the memory from the good pc to the bad one as well as purchasing new memory, and trying different slots. I did this while the registry error was happening though, to see if it would bring the pc back to life.

The problem I have is that using different memory with a clean install makes it unclear if the memory fixed it or not since the problem is inconsistant and sporatic. I comes oddly after a few days of running fine.

I'm not sure how to check temperature on the pc's but I configured them both to be identical, and they each have 4 fans plus the cpu fan and heat sink provided by AMD. And the other pc oddly does not have this error.

I have not even thought of swapping the ps but I guess that is another thing to try.

Again, what would you do?
Related resources
August 27, 2002 12:40:53 AM

I would:

1) swap RAM and let it run until the problem happened or not

2) if it happened, swap PS under same conditions as 1

3) then try swapping motherboard, same as 1.

Unfortunately there are no shortcuts to debugging a problem like this. It's trial and error.

<i>It's always the one thing you never suspected.</i>
August 27, 2002 3:21:48 PM

Additionally, have you tried DISabling the ACPI/Power Saving Settings in your BIOS?
Even identical systems have _some_ differences, if for no other reason than the fact that it's ultimately still made by humans :p 
If all the suggestions bring you no solution, then it might simply be flaky hardware (from your own info, it would seem to be the motherboard, but nothing's for sure, of course).
Good luck!

JF
August 27, 2002 11:27:33 PM

OK well here goes.

I brought my office (registry error) machine home and I'm going to try each idea one by one. It's going to take some time though since I need to do the.."wait and see" thing.

I will post when I have some results.

ACPI...I have two issues with disabling it. 1) I just can't get past the fact that my other identical pc has acpi on and it is working fine, at least in reference to this problem, 2)I don't wanna, I like acpi.

Thanks to everyone for your help and ideas.
I'll keep reading the posts, and I'll post again shortly.
Ian
August 28, 2002 2:02:24 AM

Good luck, and keep us updated.

<i>It's always the one thing you never suspected.</i>
August 28, 2002 9:12:48 AM

Also look at driver problems, I have found some drivers after a while eventually can cause some headaches. Whatever, thats my 2 cents worth{wink]

<A HREF="http://www.btvillarin.com/phpBB/index.php" target="_new">A better place to be</A> :wink:
September 5, 2002 2:29:56 AM

Well here's where I'm at for anyone who's watching.

I've taken the error machine and reloaded xp, without swaping out anything yet. I'm trying to get it to lock up with that registry error again and again so as to establish a window of time that it will lock up. In order to know that it will consistantly lock up after x number of hours, or days, of use. Then when I try a certain fix, if it goes past that amount of time without locking up I may have found the problem.

Well it's not so easy. The darn thing won't lock up. Yet. But that is the plan.

However I did come across an interesting snag. I had a couple of software installs not go to well. Corel Word Perfect Office 2000 froze mid install. After reseting, it seems to be there. And, Quicken 2001 was recognized by autoplay, but when I clicked ok (to begin install) it didn't do anything. Likewise when I tried to go through my computer.

Any thoughts please post.
Ian
!