Https access very slow

Archived from groups: microsoft.public.windowsxp.general (More info?)

I am running XP with all of the latest patches installed.

Everthing is fine except when I access https sites. It seems to take an age
to load the sites.
I am on an adsl broadband connection, my pc is an athlon 64 bit processor
with 1 Gb ram and I use a wireless usb card and router.

Anyone have any ideas please

Thanks
4 answers Last reply
More about https access slow
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Using IE ? - Depending on your Security Zone settings and some
    Advanced IE options, it could be related to certificate validation.

    Also does your system use any type of Proxy ? - Some tools of
    that type don't fully support the https protocol. Normally, a secure
    website access shouldn't be noticeably slower than http.
    When you visit an https site - does it appear in the Internet Zone
    or have you added sites to the "Trusted" zone ? I would probably
    start looking at how your IE Zone security settings are configured.

    "MGrowe" <MGrowe@discussions.microsoft.com> wrote in message
    news:A0B016A2-8492-40C0-AC7D-A56C28D7E4A0@microsoft.com...
    >I am running XP with all of the latest patches installed.
    >
    > Everthing is fine except when I access https sites. It seems to take an
    > age
    > to load the sites.
    > I am on an adsl broadband connection, my pc is an athlon 64 bit processor
    > with 1 Gb ram and I use a wireless usb card and router.
    >
    > Anyone have any ideas please
    >
    > Thanks
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    I don't use any proxy and I tried turning off the firewall on my wieless
    router but it was still very slow. I will check the other settings

    Thanks for the suggestions


    "R. McCarty" wrote:

    > Using IE ? - Depending on your Security Zone settings and some
    > Advanced IE options, it could be related to certificate validation.
    >
    > Also does your system use any type of Proxy ? - Some tools of
    > that type don't fully support the https protocol. Normally, a secure
    > website access shouldn't be noticeably slower than http.
    > When you visit an https site - does it appear in the Internet Zone
    > or have you added sites to the "Trusted" zone ? I would probably
    > start looking at how your IE Zone security settings are configured.
    >
    > "MGrowe" <MGrowe@discussions.microsoft.com> wrote in message
    > news:A0B016A2-8492-40C0-AC7D-A56C28D7E4A0@microsoft.com...
    > >I am running XP with all of the latest patches installed.
    > >
    > > Everthing is fine except when I access https sites. It seems to take an
    > > age
    > > to load the sites.
    > > I am on an adsl broadband connection, my pc is an athlon 64 bit processor
    > > with 1 Gb ram and I use a wireless usb card and router.
    > >
    > > Anyone have any ideas please
    > >
    > > Thanks
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    From: "MGrowe" <MGrowe@discussions.microsoft.com>

    | I am running XP with all of the latest patches installed.
    |
    | Everthing is fine except when I access https sites. It seems to take an age
    | to load the sites.
    | I am on an adsl broadband connection, my pc is an athlon 64 bit processor
    | with 1 Gb ram and I use a wireless usb card and router.
    |
    | Anyone have any ideas please
    |
    | Thanks

    It could be that it is having a hard time checking the Certificate Publisher's web site.

    Try...

    start --> settings --> control panel --> internet options --> advanced

    Uncheck the following....
    Check for publishers certificate revocation
    Check for server certificate revocation

    --
    Dave
    http://www.claymania.com/removal-trojan-adware.html
    http://www.ik-cs.com/got-a-virus.htm
  4. Thanks, some years later; this post really helped me.

    I had a problem with very slow https access towards my NAS server where I had enabled HTTPS.
    I had installed my own self-signed server certificate.

    Reading this I understood that what happens is that the browser attempts to check if revocation information exists for the server certificate, and since my certificate is of my own making info about it is not likely to be found on any revocation server.

    By unchecking the option "Check for publishers certificate revocation" performance returned back to normal.

    Thanks shall go to MGrowe@discussions.microsoft.com who provided this insight in the year of 2005.
Ask a new question

Read More

Windows XP